Como desinstalar um dispositivo de áudio no Linux MInt

Gostaria de solicitar uma ajuda/orientação sobre como desinstalar um dispositivo de áudio no Linux MInt. Vi um vídeo no canal do DioLinux falando sobre aplicações que eram boas e pouco conhecidas e entre elas uma interessou-me pela questão do compartilhamento de tela que ele aborda vagamente no vídeo. O nome da aplicação é “GNOME Network Displays”.

Porém, eu instalei o programa, mas além de não funcionar apareceu o seguinte item nas minhas configurações de som: “Saída analógica Áudio Interno”

Acontece que depois de ter instalado o respectivo programa e mesmo tendo-o desinstalado este dispositivo continua lá. Ademais, toda vez que inicio meu sistema operacional a placa de saída de áudio e o microfone interno que estão selecionados por padrão é esse dispositivo e não o fone de ouvido como era de costume.

Ou seja, se preciso baixar o volume de um vídeo tenho que abrir as configurações de som e selecionar a outra opção, sendo que antes só tinha uma apenas.

Gostaria que alguém me ajudasse mostrando como se faz a desinstalação deste dispositivo. Desde já agradeço a ajuda e atenção! :wink:

Existe o aplicativo pavucontrol (na loja do Linux Mint) que permite escolher os dispositivos padrão de áudio de entrada e de saída (clique no botão indicado para fazer isso)

Agora, para investigar essa saída de áudio misteriosa mais a fundo, vou precisar da saída do comando de terminal pacmd list-sinks , que vai dar detalhes de quais dispositivos estão detectados e como foram detectados. Com isso dá pra ter uma ideia de como eliminar ele completamente.

2 Curtidas

De acordo com esse comando que você mencionou, o resultado mostrado no terminal foi o seguinte:



Parte final da tela do terminal:

name: <alsa_card.platform-snd_aloop.0>

Então, parece que parte do processo de instalação do Gnome Network Displays foi iniciar automaticamente o driver snd_aloop para saídas virtuais.

Teste sudo rmmod -f snd_aloop no terminal e veja se o dispositivo some.

Para desativar permanentemente, edite o arquivo (como adminstrador) /etc/modprobe.d/blacklist.conf e adicione no final:

blacklist snd_aloop

e reinicie.

Testei os comandos mas nenhum funcionou. Esta foi a mensagem que apareceu:

/etc/modprobe.d/blacklist.conf é um arquivo de texto. Você tem que pegar iniciar um editor de texto como administrador para fazer a mudança:

sudo su
nano /etc/modprobe.d/blacklist.conf # ou xed (gráfico), emacs, etc.

Com o nano, se salva a alteração com Ctrl+X. É necessário reiniciar para surtir efeito.

Meu Deus! Dá muito trabalho. Já imagino eu fazendo isso e escrevendo algo errado e o som sumir de vez kkk. @Capezotte Acho que vou tentar a opção do Pavu Control e ver se funciona.

Reverta as opções padrão do pulseaudio do seu usuario novamente ao padrão:

rm .config/pulse/default.pa

Daí faça logout e login e veja se resolveu.

Se não resolveu, cole o conteúdo do arquivo /etc/pulse/default.pa aqui pra analisar.

2 Curtidas

O comando para reverter não funcionou. Aqui está o conteúdo do arquivo “defalt.pa”:

#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see .

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Use hot-plugged devices like Bluetooth or USB automatically (LP: #1702794)
.ifexists module-switch-on-connect.so
load-module module-switch-on-connect
.endif

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GConf settings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gconf.so
.nofail
load-module module-gconf
.fail
.endif

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
load-module module-role-cork

### Block audio recording for snap confined packages unless they have
### the "pulseaudio" or "audio-record" interfaces plugged.
.ifexists module-snap-policy.so
load-module module-snap-policy
.endif

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Make some devices default
#set-default-sink output
#set-default-source input

Então, vou tentar adivinhar como é seu computador:

Vc tem um desktop. Usa o fone de ouvido o tempo inteiro. Deixa ele conectado no conector frontal do gabinete. Sempre que dá esse problema foi quando vc iniciou o computador com o fone de ouvido conectado na porta frontal.

Acertei?

Se for isso, eu tenho o mesmo problema que vc faz meses. Não precisa desativar a outra saída, pois ela é na verdade o conector que fica atrás do gabinete. Acontece um bug que o pulseaudio não troca a saída pro fone de ouvido na inicialização do computador. Eu não me preocupei de resolver pois acabo deixando o computador ligado ou na suspensão, por isso faço manualmente o procedimento de selecionar o fone de ouvido quando acontece.

Ainda não tenho resposta sobre isso…

Não eu uso um notebook com caixas de som. Este problema com essa saída de som analógico começou quando eu instalei o programa “GNOME Network Displays” e essa saída apareceu nas configurações de som e, de lá para cá, se tornou a porta padrão e caso eu queira alterar o volume eu tenho que abrir as configurações toda vez e mudar, coisa que até antes de instalar esse programa nunca tinha acontecido.