Como baixar a nova versão do php e composer no Ubuntu 22.04 LTS

Estou tendo dificuldade em conseguir baixar a versão mais nova do php, e com isto não consigo utilizar o composer para trabalhar com laravel, toda vez que tento criar um projeto em laravel da um problema ou com php ou com o composer, utilizo o Ubuntu 22.04 LTS, alguém sabe a solução?

1 curtida

Qual exatamente o problema, pra termos uma ideia em como orientar? As vezes, não é a versão mais recente do PHP que irá resolver o problema.

Ainda assim, seguem os passos para o que solicitou:

1: Atualize o sistema
sudo apt update && sudo apt upgrade -y

2: instale dependências:
sudo apt install software-properties-common apt-transport-https -y

3: Importe Repositório PPA de PHP
sudo add-apt-repository ppa:ondrej/php -y

4: Instale o módulo Apache/PHP-FPM