Como aumenta a performance do Mint na Steam?

Recentemente acabei decidindo usa o Mint para jogar em um notebook meu, mas a performance na steam não está muito boa e não sei se posso faze algo que possa melhorar, irei especificar algumas coisas pra vocês terem mais informações:

1 - Configurações do notebook que estou usando:

Processador: Intel i5-3337U (4) @ 2.700GHz;
Placa de vídeo: Integrada;
RAM: 8GB DDR3;
SSD: 240GB;

2 - Proton que estou usando:
Obs: Já testei em todos mas não vi nenhuma diferença

3 - Instalei o drive do mesa por esse link:

Driver Mesa

4 - Jogo que estou tentando melhorar a performance:

Himnno Steam

5 - Instalei a Steam pela loja mesmo:

Steam;
Steam-installer;
Steam devices;

Observações finais:

Bom faz um tempo que não usava o Linux pra joga mas como é um jogo bem leve decidi usa ele mesmo mas o jogo está com quedas de FPS em quase todo momento, achei que não ia precisa do Windows pra um jogo leve como esse mas não foi o esperado enquanto no Windows a performance ta bem tranquila passando dos 100 de FPS bem tranquilo (até mais) no Mint estou com 40 de FPS. Não é um notebook muito bom mas como só jogo esse jogo queria roda ele direto no Linux mas com uma performance boa com pelo menos 60 de FPS. Acredito que estou fazendo ou fiz algo de errado.

Obrigado pela sua atenção até aqui.

Começar atualizando o kernel ja e um bom passo, desativar as falhas da intel tbm
Mas da uma conferida se a aceleraçao 3D ta ativada, ate pelo que eu sei a versão mais atual do mint acabou vindo sem os pacotes de aceleração de video pre-instalados
Tbm ajuda bastante usar ppa do padoka stable que serve diretamente pra isso ou a ppa do ubuntu-x-swat

2 Curtidas

Acabei de chega do trabalho, vou toma um banho e irei faze isso e vê se tenho alguma melhora. Obrigado :grinning:

Recomendo você dá uma olhada nesse tópico do @Jedi_Fonseca.

2 Curtidas

Fiz todos os procedimentos e tive uma melhora, mas depois que desativei as falhas da intel quando desligo o notebook e ligo de novo aparece isso:

Ele incia normalmente mas está demorando pra inicia mesmo com SSD.

O kernel eu atualizei pro 5.0.0-050000-generic:

Isso realmente foi de ajuda, fiz o processo e tive uma pequena melhora. :smiley:

E pq tem q tirar o espaço nas linhas kkk Nathan Drake colocou espaços no artigo dele ai acaba dando essa falha na linha

1 Curtida

Vou verificar e depois retorno

Deu certo, mas o primeiro carregando do sistema ainda continua lento quando ligo o PC, teria algo que eu poderia faze? Se não tiver já estou satisfeito já melhoro bastante.

Isso já aconteceu comigo quando troquei o kernel do Mint, tive que ficar trocando até achar um totalmente compatível, pode ser apenas uma variação, mas faz a diferença. Mas antes de trocar tem que saber se é realmente isso.
Digite:

systemd-analyze

Para vermos se é o kernel que está atrasando.

2 Curtidas

Desculpa fiquei o dia fora, o comando retorna isso:

bruno@linuxmintOS:~$ systemd-analyze
Startup finished in 3.389s (firmware) + 4.144s (loader) + 8.592s (kernel) + 36.064s (userspace) = 52.189s
graphical.target reached after 2.835s in userspace

Retorno do systemd-analyze blame:

bruno@linuxmintOS:~$ systemd-analyze blame
33.356s apt-daily.service
1.189s dev-sda2.device
1.153s snapd.service
774ms apt-daily-upgrade.service
737ms vboxdrv.service
410ms udisks2.service
392ms ubuntu-system-adjustments.service
385ms dev-loop1.device
358ms networkd-dispatcher.service
329ms dev-loop0.device
328ms dev-loop2.device
326ms NetworkManager.service
324ms dev-loop3.device
301ms systemd-logind.service
300ms networking.service
286ms dev-loop4.device
246ms ModemManager.service
193ms avahi-daemon.service
178ms accounts-daemon.service
169ms thermald.service
166ms systemd-journal-flush.service
157ms grub-common.service
155ms lm-sensors.service
151ms wpa_supplicant.service
149ms hddtemp.service
141ms speech-dispatcher.service
135ms keyboard-setup.service
115ms upower.service
107ms systemd-udev-trigger.service
107ms lightdm.service
106ms snap-gtk2\x2dcommon\x2dthemes-5.mount
103ms plymouth-quit-wait.service
95ms apparmor.service
91ms lvm2-monitor.service
89ms snap-gtk\x2dcommon\x2dthemes-1353.mount
84ms snap-snapd-4992.mount
84ms systemd-journald.service
82ms gpu-manager.service
81ms pppd-dns.service

1 Curtida

Eu achei isso:
Ubuntu 16.04 inicialização lenta (apt-daily.service)

O comando retorna isso:

bruno@linuxmintOS:~$ systemd-analyze
Startup finished in 3.361s (firmware) + 4.119s (loader) + 4.355s (kernel) + 2.833s (userspace) = 14.670s
graphical.target reached after 2.800s in userspace

“Diminuiu” o tempo na saída do comando, mas na pratica ainda continua a mesma coisa.

1 Curtida

Para ser sincero, está melhor que o meu :sweat_smile:

~$ systemd-analyze
Startup finished in 11.521s (kernel) + 42.311s (userspace) = 53.832s

Depois, com um pouco mais de calma vou dar uma olhada, caso tenha resultados melhores te aviso. Mas acho que, no meu caso, é o HD mesmo, está com muitos erros.

Pior que no meu é SSD e é novo ele não tem um mês e antes de eu faze essas mudanças não levava 10 segundos pra inicia, mas depois que fiz mesmo que mostre 14 segundos ele não leva só 14 ele demora quase um minuto --’
O problema é que no terminal ele mostra 14 segundos mas na prática quando ligo o pc demora pra ■■■■■■■, chega a demora um minuto pra liga e foi logo após as mudanças.

bruno@linuxmintOS:~$ systemd-analyze
Startup finished in 3.361s (firmware) + 4.119s (loader) + 4.355s (kernel) + 2.833s (userspace) = 14.670s
graphical.target reached after 2.800s in userspace