Chrome não abre links magnéticos

Srs, preciso de ajuda com um problema. Estou usando o Ubuntu 19.10 e quando clico em links magnéticos o Chrome abre uma janela popup “Open xdg-open?” toda vez (sempre leva corretamente ao Transmission, no entanto). O mesmo ocorre no Chromium. Ambos instalados recentemente (atualizados, portanto).
xdg-open está corretamente configurado para abrir o Transmission (que reinstalei para garantir e verifiquei que está corretamente associado aos torrents e links magnpeticos). O problema parece ser um bloqueio no Chrome, tipo ter que ter uma autorização do usuário (?).
Firefox está funcionando sem maiores problemas. Quando clico no link magnético, abre diretamente o Transmission.
Mas é aquilo, eu quero usar o Chrome e não quero clicar na janelinha chata (rsrsrs).

Obrigado!

Até onde eu sei, não tem como pular essa etapa no Chrome/Chromium.

Eu acho muito mais seguro e efetivo copiar o link manualmente e colar no cliente.

Acredito que essa janelinha seja uma etapa de segurança pra não ter links da internet interagindo com o sistema local sem a sua permissão.

@anon17586640, @filipemosca, até semana passada eu usava o Mint 19.3 e não tinha esse problema por lá. Se fosse algo nativo do Chrome ou do Chromium, o comportamento deveria ser o mesmo independente do sistema. Também não creio ser uma questão de segurança porque o Firefox, que é o navegador padrão instalado nativo com o Ubuntu, funciona como deveria, abrindo diretamente o magnetic no aplicativo de torrent, o Transmission no caso, para daí você ver o que você vai efetivamente fazer.
Pra mim é algum detalhe na forma com que o Ubuntu/Gnome interage com o Chrome/Chromium que está causando este comportamento. Só não sei o que é ainda…

Eu sempre tive esse comportamento no Chrome, em todos os DEs que usei.

1 Curtida

@anon17586640, cara isto é bizarro. Acabei de dar boot no meu HD antigo com Mint 19.3/Cinnamom, testei o Chrome e não deu este problema. A versão é a 79.0.3945.88, 64 bits.
O Firefox não tem este comportamento, mas nas configurações dele dá pra setar especificamente o Transmission para abrir links magnéticos.
Dando uma lida nos fóruns do Ubuntu eu vi que vários usuários tem tido este problema e parece ser algo a ver com o xdg-open e o fato do Firefox vir configurado como navegador por padrão (e handler para quase tudo que tenha a ver com internet).
Aparentemente, mesmo setando o Chrome como novo navegador padrão, o problema permanece porque deve haver alguma coisa a mais para ser trocada que não é evidente.
Chequei todos os arquivos .desktop que estariam relacionados e testei alguns settings do xdg, mas não encontrei qual seria o problema.

Vou testar no Mint, mas não vejo isso como um problema, é 1 clique à mais só.

Tive o mesmo problema no Debian lxde … estranho

@anon17586640, nem é uma questão de quantos cliques a mais, mas sim de compreender o porque das coisas. Muitas vezes, quando o sistema ou um aplicativo não se comporta como esperado eu sempre procuro pesquisar e entender o motivo. Assim, acabo aprendendo muitas coisas novas, mesmo que acabe não conseguindo resolver o “problema” em si. Neste caso, por exemplo, acabei descobrindo coisas como o “xdg”, que nem tinha ideia que existia; e como arquivos *.desktop aparecem em diversos lugares e servem pra muito mais que criar links.
É assim pra mim, um amontoado de coisas “bobas” que me levam a aprender mais do sistema.

Aprender sempre é bom, independente da forma, mas problematizar algo tão supérfluo é caçar pelo em ovo.