Bluetooth POP-OS reconhece mas não funciona

Comprei um dongle usb para usar meu headphone mas o mesmo não consegue parear, tanto pelo blueman quanto pelo settings. Já fiz as sugestões da system76 mas nada adianta, alguém sabe alguma possível solução?

Olá @Luiz_Costa_de_Moraes tudo bem contigo?

É possível que esteja faltando algum software relacionado ao bluetooth, eu tenho um dongle mega genérico que comprei fazem décadas e aqui no Pop!20.10 ele detecta tudo mas também não pareou nada. Estou no meio de várias atividades aqui então não foi possível reiniciar para ver se resolvia.

Assim que possível vou reiniciar e posto se deu certo ou não.

:vulcan_salute:

1 Curtida

Acabei de fazer um teste aqui e após reiniciar tudo funcionou quase normalmente. O PC não detecta nenhum equipamento próximo, mas os equipamentos (celular, caixa de som e um notebook) encontram o PC e conseguem parear normalmente.

Não precisei instalar nenhum software extra, apenas conectei o dongle e reiniciei o computador.

:vulcan_salute:

1 Curtida

Já tentei reiniciar várias vezes, vou tentar fazer o upgrade para o 20.10

Você poderia colocar a saída do comando lsusb -v no pastebin.com e mandar o link gerado aqui? Recomendo rodar o comando como superusuário (pode usar o sudo pra isso). Com detalhes do modelo, podemos tentar procurar informações mais precisas.

1 Curtida

Meu OS, mesmo atualizando tá dando o mesmo erro de não parear

Excelente. Identifiquei o dispositivo. É um dongle problemático. Você lê em inglês? Se sim, aqui tem uma discussão com várias pessoas comentando sobre as tentativas que fizeram, há algumas técnicas mais simples para tentar contornar incompatibilidades (blacklistando módulos, por exemplo) e há quem tenha falado até em aplicar patch em kernel. Na verdade, numa busca personalizada dentro do Ask Ubuntu, tem muito mais reclamações. Eu achei o troubleshooting de um dos resultados interessante.

Tente fazer os passos indicados para ver se o dongle é falso:

Rode o monitor num terminal:

sudo btmon

Em outro terminal, tente subir o dispositivo:

sudo hciconfig hci0 up

Veja se ele é falso:

Se depois de Delete Stored Link Key surgir um erro como o abaixo, o dongle é falso.

Status: Unsupported Feature or Parameter Value

Se for este o caso, a pessoa lá do link fez um hack no módulo “btusb” para resolver. Não sei qual foi a versão usada por ela. Mas pode ser uma possibilidade também.

1 Curtida

Rodando os dois apareceu isso:

sudo btmon
 Bluetooth monitor ver 5.55
= Note: Linux version 5.8.0-7630-generic (x86_64)                      0.582878
= Note: Bluetooth subsystem version 2.22                               0.582881
= New Index: 00:1A:7D:DA:71:10 (Primary,USB,hci0)               [hci0] 0.582882
= Open Index: 00:1A:7D:DA:71:10                                 [hci0] 0.582883
= Index Info: 00:1A:7D:DA:71:10 (Cambridge Silicon Radio)       [hci0] 0.582884
@ MGMT Open: bluetoothd (privileged) version 1.17             {0x0001} 0.582885
@ RAW Open: hciconfig (privileged) version 2.22               {0x0002} 7.776140
@ RAW Close: hciconfig                                        {0x0002} 7.776162