Bluetooth ligando e desligando

Olá a todos!

Tenho um notebook Samsung com i3-3110, 8Gb de RAM e Ubuntu 20.04 instalado. Estou com um problema com a conexão bluetooth nativa do notebook. Ao iniciar a máquina, o bluetooth fica ligando e desligando, mas não é um ligar e desligar normal, o “desligar” é como se o sistema não reconhecesse o bluetooth (nas configurações fica aparecendo uma mensagem pedindo para conectar um dongle). Mesmo já com algum aparelho pareado, quando ele aparece não conecta automaticamente, eu preciso clicar e conectar manualmente (isso leva vários minutos, pois ele fica sumindo e aparecendo). Quando finalmente consigo conectar, ele para de desligar e funciona normalmente até eu desligar o sistema ou reiniciar.
Alguém poderia dar uma luz sobre o que pode estar acontecendo e como solucionar este mistério? Desde já agradeço.

Veja aqui…

A wiki é do Arch, mas talvez ajude
https://wiki.archlinux.org/index.php/bluetooth#Device_connects,_then_disconnects_after_a_few_moments

Obrigado por responder… mas não é a mesma coisa. No meu caso o bluetooth some e aparece das configurações. Ele “some” como se não houvesse nada de bluetooth no notebook, a ponto de, na sessão bluetooth das configurações aparecer uma mensagem pedindo para conectar um dongle.

Mas após eu conseguir conectar qualquer aparelho bluetooth, o problema não aparece mais, e ele fica conectado normalmente por horas, até eu desligar ou reiniciar.

Tirei um print para mostrar:


Aqui ele fica tentando conectar ao aparelho bluetooth, sendo que já está pareado (no meu entendimento era para a conexão ser automática).


Aí do nada o bluetooth desaparece. Aí fica nesse loop “aparece-desaparece” até eu conseguir conectar manualmente. Depois que conecta, ele volta ao normal e não desconecta mais.

1 curtida

Veja se o blueman or gnome-bluetooth 3stao instalados. Veja se o bluez está instalado

Configure o arquivo

**/etc/bluetooth/main.conf
Acho que é este o caminho…
Tenho que verificar, no momento estou no celular.
E adicione

DiscoverableTimeout = 0
AutoEnable=true

Para audio

*/etc/pulseaudio/default.pa

# automatically switch to newly-connected devices
load-module module-switch-on-connec
1 curtida

Obrigado por responder.

O gnome-bluetooth está instalado.

Arquivo configurado.

Infelizmente o problemas ainda não foi resolvido.

Para tirar a dúvida se poderia ser um problema de hardware, instalei o Ubuntu Studio como dualboot (usa a interface XFCE) e lá o bluetooth funciona normalmente.

Será que seria algo relacionado ao gnome?

É

load-module module-switch-on-connect

Ao digitar antes não saiu completo

Pela linha de comando pode testar com

pacmd load-module module-switch-on-connect
2 curtidas

Obrigado, @swatquest, resolveu parcialmente o problema, e justamente a parte mais chata, que era o bluetooth sumindo e aparecendo!

Ele ainda não conecta automaticamente os dispositivos pareados, mas conectar manualmente agora ficou muuuuuito mais fácil, já que não preciso ficar “brigando” com o bluetooth!!

1 curtida

Conectar acho que seria o primeiro, mas vou pesquisar e informo aqui…
No momento estou no celular…
Depois faço isso
Até

1 curtida

Eu acho que é só isso

Segue em inglês

Setting up auto connection

To make your headset auto connect you need to enable PulseAudio’s switch-on-connect module. Do this by adding the following lines to /etc/pulse/default.pa :

/etc/pulse/default.pa

# automatically switch to newly-connected devices 

load-module module-switch-on-connect

Now make bluetoothctl trust your Bluetooth headset by running trust 00:1D:43:6D:03:26 inside the bluetoothctl console to prevent errors similar to:

bluetoothd[487]: Authentication attempt without agent bluetoothd[487]: Access denied: org.bluez.Error.Rejected

[bluetooth]# trust 00:1D:43:6D:03:26

By default, your Bluetooth adapter will not power on after a reboot. The former method by using hciconfig hci0 up is deprecated, see the release note. Now you just need to add the line AutoEnable=true in /etc/bluetooth/main.conf at the bottom in the [Policy] section:

/etc/bluetooth/main.conf

[Policy] 
AutoEnable=true

Veja se funciona

Até

1 curtida

Bom, ele ainda não conecta automaticamente mas pelo menos já ajudou muito não ter que ficar um tempão tentando conectar. Muito obrigado mesmo, @swatquest, pela paciência e ajuda. Vou marcar o post como resolvido.

Muito obrigado mais uma vez!

acho que tem este procedimento também

Faça com que o bluetoothctl confie no seu fone de ouvido Bluetooth executando trust 00:1D:43:6D:03:26 dentro do console do bluetoothctl para evitar erros semelhantes:

bluetoothctl
[bluetooth]# trust 00:1D:43:6D:03:26

00:1D:43:6D:03:26 tem que ser do seu bluetooth

até

Eu fiz esse procedimento, mas também não adiantou.
Obrigado!

Ok.

Se quiser mais informação, segue a fonte:
https://wiki.archlinux.org/index.php/Bluetooth_headset

2 curtidas

Estou com o mesmo problema, mas o meu não resolveu, no windows o bluetooth funciona normalmente, ja tive debian, ubunto, kali linux, autualmente estou no pop os,kde o estranho é que em todos tive o mesmo problema.
alguem tem alguma sujestao para me ajudar, ja olhei muita coisa e nao consegui encontrar soluçao.

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.