Bluetooth e Wifi no POP_OS 20.04

Olá pessoal, sou um usuário meio antigo de Debian que está tentando migrar para o POP_OS 20.04, já que não consegui instalar o 21.04 no meu note Acer com processador Intel i3-6006U CPU @ 2.00GHz quad core, 8 GB de RAM, SSD kingston 128GB (mantenho a /home em um HD de 1TB) e placa Mesa Intel® HD Graphics 520 (SKL GT2), ou seja, um Aspire ES1-572 (Aspire ES1-572_1085_V1.17).

O sistema é muito bacana, gostei dos gráficos e tudo mais, porém, notei alguns bugs meio malucos, como o chrome ou firefox travando às vezes em vídeos de sites de streaming (como HBO MAX, Netflix…) e um que realmente está me incomodando um pouco, que faz minha internet sem fio (minha placa) praticamente travar quando eu uso o bluetooth, chegando ao ponto de ter que utilizar o cabo para contornar a situação.

Assim, antes de eu me aventurar pelos arquvos de configuração do kernel e/ou gnome, gostaria de ouvir usuários de POP_OS com mais experiência, no sentido de indicar por onde posso começar a procurar a solução, talvez uma otimização nos /etc/sysclt…, instalar um driver mais antigo.

Sobre minha placa wifi, segue a sída do comando lshw:

-network
> descrição: Interface sem fio
> produto: QCA9565 / AR9565 Wireless Network Adapter
> fabricante: Qualcomm Atheros
ID físico: 0
informações do barramento: [email protected]:02:00.0
nome lógico: wlp2s0
largura: 64 bits
clock: 33MHz
capacidades: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
configuração: broadcast=yes driver=ath9k driverversion=5.11.0-7620-generic firmware=N/A ip=(escondi o IP e tb o MAC) latency=0 link=yes multicast=yes wireless=IEEE 802.11

Sobre o bluetooth:

*-usb:2
descrição: Interface sem fio bluetooth
produto: Qualcomm Atheros Bluetooth
fabricante: Lite-On Technology Corp.
ID físico: 5
informações do barramento: [email protected]:5
versão: 0.02
capacidades: bluetooth usb-1.10
configuração: driver=btusb maxpower=100mA speed=12Mbit/s

Bem agradeço desde já qq ajuda no sentido de solucionar ou minimizar este aparente coflito entre wifi e bluetooth.

Antes do Pop!_OS, você utilizava debian 10 com gnome e o problema não ocorria ?

Olá! Não utilizava com Gnome, sim com XFCE. O problema não ocorria.
Então notei que o problema ocorre quando utilizo o bluetooth no note para transmitir o som para outro local, exemplo, um caixa de som. Porém o problema não ocorre quando uso para receber som ou outra mídia no notebook, exemplo, usar o celular como câmera.
Muito doido isso, mas é esse o comportamento.

Opa, possuo a mesma placa de wifi/bluetooth!
Nunca vi nenhum problema na placa em relação a internet lenta (já tive com bluetooth não conectando, parece q corrigiu com o recém-lançado kernel 5.11 no repositório do Ubuntu 20.04)
Tente verificar por drivers ou até mesmo atualizar o kernel (a LTS mais atual é a 5.10, se não me engano)
EDIT: Caso opte por atualizar o Kernel, há a possibilidade de você ter que reinstalar os módulos dos programas neste.