Atualização de um Componente do Pop_Os Não Funciona

Opa pessoal! Meu primeiro post aqui e sou novo no Linux. Estou usando o Pop_Os e não consigo realizar a atualização de um componente ‘Lib’ do sistema chamado “libodbc1 biblioteca ODBC para Linux Versão: 2.3.7” (Segue uma print mostrando melhor).

Quando eu clico em atualizar ele carrega rapidamente, a mensagem de atualização some, mas logo volta falando que precisa atualizar.

Tentei atualizar pelo terminal (não sei muita coisa, btw) e deu nisso aqui:

[email protected]:~$ sudo apt upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
Calculando atualização... Pronto
Os pacotes a seguir serão mantidos em suas versões atuais:
  libodbc1
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 1 não atualizados.
[email protected]:~$ 

É como se o OS não quisesse atualizar isso. Queria só tirar a notificação que fica aparecendo para atualizar isso que fica me dando Toc kk. Se alguém tiver uma solução para isso eu agradeço!

Abraços,
Eduardo Chaves

Boas vindas ao fórum :wave:
Qual a versão do Pop!_OS?
Tente atualizar os pacotes de forma geral: sudo apt update && sudo apt full-upgrade -y && sudo apt autoremove -y && sudo apt autoclean && flatpak update && flatpak uninstall --unused

1 curtida

Opa, obrigado pela resposta. Usei o comando e não deu certo, talvez seja um problema com o servidor deles, ou vai ver já está atualizado e mostra como se não estivesse :thinking:. Segue abaixo a resposta do Terminal ao comando que você me passou…

Log do Terminal
[email protected]:~$ sudo apt update && sudo apt full-upgrade -y && sudo apt autoremove -y && sudo apt autoclean && flatpak update && flatpak uninstall --unused
[sudo] senha para eduardochaves: 
Atingido:1 http://us.archive.ubuntu.com/ubuntu impish InRelease
Atingido:2 http://us.archive.ubuntu.com/ubuntu impish-security InRelease
Atingido:3 http://apt.pop-os.org/proprietary impish InRelease                  
Atingido:4 http://us.archive.ubuntu.com/ubuntu impish-updates InRelease        
Atingido:5 http://apt.pop-os.org/release impish InRelease                      
Atingido:6 http://us.archive.ubuntu.com/ubuntu impish-backports InRelease      
Atingido:7 http://packages.microsoft.com/repos/code stable InRelease           
Atingido:8 https://packages.microsoft.com/ubuntu/21.04/prod hirsute InRelease
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
1 pacote pode ser atualizado. Corra 'apt list --upgradable' para vê-lo.
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
Calculando atualização... Pronto
Os pacotes a seguir serão mantidos em suas versões atuais:
  libodbc1
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 1 não atualizados.
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 1 não atualizados.
Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto        
Procurando por atualizações…
Nada para fazer.
Nada não usado para desinstalar

Pelo teor do log, ele não está deixando atualizar o pacote em questão para evitar de quebrar algum programa em questão, quiçá o sistema em si. Sem crise, tá tudo certo. Outro detalhe, você está usando uma versão não LTS, sendo que a ultima versão não LTS do Pop!_OS é a 21.10. Recomendo que faça o upgrade (por sua própria conta e risco) ou instale o 20.04.

1 curtida

Eu estou usando o Pop!_OS 21.10 sem LTS. Quando instalei eu não sabia a diferença entre essas versões, mas pesquisei aqui um pouco sobre LTS e vi que por mim, vou manter sem mesmo, pois gosto das coisas sempre atualizadas, e vai ser bom para ir aprendendo já que sou um usuário novo no Linux. Inclusive uso W10 como OS principal, e coloquei o Linux em uma VM para começar a aprender programação apenas. Qualquer coisa futuramente troco para uma LTS. Brigadão pelas dicas!

Então… Você nem sempre terá do mais novo e atualizado na base Ubuntu pois é uma base com point release e LTS’s. Sugestão: brinque com o Manjaro, pois é base Arch, um rolling release.

2 curtidas

Hmm, achava que o Pop era rolling, nem conhecia esse point release. Mas vou manter o Pop por enquanto, estou gostando bastante até o momento. Mas vou estar antenado a outras distros, inclusive o Manjaro em caso de alguma novidade me chamar a atenção para uma troca.

Sugestão de leitura:

1 curtida