Ativei o HD e SSD no meu Ubuntu mas não tenho permissão para criar pasta

Estou sem permissão para criar pasta no Pop_Os 20.04, instalei ele a pouco tempo mas so tenho permissão de criar pasta ou salvar coisas no SSD onde o sistema esta, no meu outro HDD e no meu SDD eu não tenho essa opção.

Eu geralmente resolvo isso executando o comando:

sudo chown usuario:grupo caminho_da_particao

Substitua “usuario” e “grupo” por seu nome de usuário e o “caminho_da_particao” pelo caminho até a partição (ou pasta ou arquivo) onde há restrição de escrita. Exemplo:

sudo chown kairand:kairand /mnt/sdb1

Esse comando altera quem é “dono” do arquivo/pasta/partição.

2 curtidas

Preciso reiniciar depois disso? Não teve mudança aqui sem reiniciar

Não é necessário reiniciar. Como ficou seu comando?

Você está indicando o dispositivo (/dev). Creio que seja necessário indicar a partição. Verifique onde a montagem está sendo realizada. Por exemplo, usando o GNOME discos:

2 curtidas

Funcionoooooooou, isso significa que programas instalados nesses discos tambem poderão escrever arquivos, criar pastas e etc né?

1 curtida

E outra duvida, como faço para eles aparecerem como opções ao inves de eu precisar ficar clicando em “outros locais” toda hora?

Sim. E você pode usar normalmente. :slight_smile:

Você pode instalar jogos da Steam nesse disco, por exemplo.

Como assim? Você diz, no explorador de arquivos?

image

Seria isto? Se for, basta usar o GNOME discos (ou outro software semelhante) e editar as opções de montagem para “exibir na interface do usuário”, como está no meu print acima. Você também pode alterar o nome de exibição.

2 curtidas


Não tem essa opção pra mim no programa de discos, acho que vou ter que baixar o gnome discos xD

Mas muito, muito, muito obrigado mesmo!!!

1 curtida

É esse programa mesmo. Clique em “editar opções de montagem” e você verá essas opções do meu primeiro print. :wink:

1 curtida

Mesmo marcado não estão aparecendo e.e, mas enfim, eu reiniciei e percebi que tive que clicar de novo em “montar partições”, elas já não começam montadas não? Tipo funcionando e tals, eu sempre vou ter que iniciar elas manualmente?

Você precisa desmarcar “padrões de sessão de usuário” e marcar “montar ao inicializar o sistema”, para que sejam montadas automaticamente, e “exibir na interface do usuário”, para que apareçam.

Após selecionar essas três opções, reinicie para testar. :slight_smile:

1 curtida


Tá assim agora, é isso?

1 curtida

Isso!

Pessoalmente, também prefiro alterar o “identificar como” para /dev/sdx, deixando o ponto de montagem como /mnt/sdx.

Onde está “nome de exibição” você pode colocar um nome para a partição ao aparecer na interface de usuário, caso queira. Por exemplo, “HDD2”.

1 curtida

Tem by-label e by-partlabel, qual eu escolho?

Seria este (a primeira opção):

Fica mais organizado e facilita a localização ao digitar comandos. Depois disso, experimente reiniciar e veja se está tudo funcionando.

Caso seus discos ainda não apareçam de forma fixa na lateral do explorador de arquivos, lembre-se de que você pode clicar com o botão direito, após abrir o disco, e adicionar aos locais. Assim o atalho ficará sempre ali.

2 curtidas

Funcionou clicando para deixar o atalho xD, mas de qualquer forma, vlw demais, ja sanou um monte de duvida minha de uma vez, muito obrigado Kairan!

1 curtida

Show! Caso tenha mais alguma dúvida sobre isso, fique à vontade para perguntar. :slight_smile:

Fico contente em saber que as informações foram úteis.

2 curtidas