Adaptador USB Bluetooth não localiza dispositivos no Mint 19.1

Olá. Possuo um adaptador USB Bluetooth que funciona perfeitamente no Windows e no Ubuntu.
Porém no Linux Mint 19.1 o adaptador é reconhecido mas na janela de gerenciamento de dispositivos o sistema só fica buscando, buscando mas nada é reconhecido.

Captura%20de%20tela%20de%202019-02-07%2002-35-19

Procurei na internet algum tipo de solução e o que encontrei foi substituir o pacote blueberry pelo blueman. Fiz isso pelo Gerenciador de Pacotes Synaptic mas apesar da mudança do software de gerenciamento bluetooth, o problema não foi resolvido.
Alguém saberia me dizer o que devo fazer para meus dispositivos serem localizados pelo adaptador bluetooth?
Obrigado.

1 curtida

Talvez algum drive esteja faltando, sabe qual o modelo e marca do seu adaptador? Sabendo disso, tente procurar os drives de linux para o adaptador na internet, as vezes ja tem até no repositório da sua distro, pq se ja funcionava no ubuntu, ja deveria vir instalado, tente achar esse drive por lá. :wink:

1 curtida

Boa noite leonardopn. Obrigado pelo retorno.
Então, eu procurei na internet um comando que lista os dispositivos conectados nas portas usb, lsusb -v e obtive a informação que o fabricante é a empresa Cambridge Silicon Radio, Ltd

Vou procurar informações sobre esse fabricante.

1 curtida

Utilizei o comando “sudo service bluetooth status” e lá indica que o bluetooth está rodando, porém nenhum dispositivo aparece na busca.

Captura%20de%20tela%20de%202019-02-08%2001-12-21

2 curtidas

Realizei a desinstalação completa do pacote _blueberry no gerenciador Synaptic e instalei o pacote blueman .
Dessa forma consegui parear meus dispositivos.

Captura%20de%20tela%20de%202019-02-09%2021-47-34

1 curtida

É galera, parece que o bluetooth no Mint 19.1 está bugado.
Achei que tinha resolvido o problema conforme o post acima e caí da cadeira.
O bluetooth parou de funcionar de novo no pacote blueman e no blueberry nem se fala, pior ainda.
Não sei mais o que fazer

2 curtidas

Desculpe a demora. Então, provavelmente está lhe faltando compatibilidade mesmo, não é possível funcionar no ubuntu e não no linux mint, algo está faltando. Tente atualizar o kernel. utilizando o ukuu, ele vai atualizar seu kernel pra versão mais recente e talvez possibilite uma melhor compatibilidade.

Aqui um post do Dio ensinando a usar: https://www.diolinux.com.br/2016/09/conheca-o-ukuu-ubuntu-kernel-update.html

Verifiquei nas informações do sistema o kernel…

De qualquer forma, vou seguir seu conselho para atualizá-lo.
Obrigado @leonardopn

1 curtida

@leonardopn Verifiquei no gerenciador de atualizações do Mint e constatei que o Kernel que utilizo é o último lançado. Estranho que como é o mais atual, os drivers deveriam ser os mais compatíveis possíveis.
Tem a versão 4.18 mas o suporte vai até Agosto desse ano.

Muito estranho o que está acontecendo com meu adaptador bluetooth. No Windows funciona certinho, então posso descartar a possibilidade dele estar com defeito.

Desculpe a demora de novo, faculdade e estágio ta difícil kkk. Mas então… o kernel LTS está no 4.15 mesmo, porém ja lançaram té o 4.20 já, teoricamente não é o melhor dos conselhos te falar pra atualizar para o 4.20, porém como vc ja tentou de tudo e mesmo assim não funcionou, tente utilizar o kernel 4.20, instale pelo ukuu, ele não vai substituir seu kernel atual, então caso o 4.20 não resolva, é só desinstalar ele pelo ukuu também. Tente utilizar o link que eu te enviei, lá tem como utilizar o ukuu, ele é extremamente fácil. qualquer coisa pode me chamar.

Tranquilo @leonardopn, você está me ajudando muito. Agradeço o tempo dedicado para me ajudar.
Vou tentar atualizar o kernel e logo posto aqui se deu certo ou não.
Abraços.

1 curtida

@leonardopn, hoje fui utilizar o computador e como último suspiro antes de atualizar o kernel para o 4.20, para minha surpresa todos os meus dispositivos foram localizados e funcionaram 100% na versão 4.15. As pessoas vão achar que estou louco nestes posts.
Então por enquanto vou manter o kernel do jeito que está, na versão 4.15.

Captura%20de%20tela%20de%202019-02-14%2000-34-29

Obrigado por todo suporte.
Abraços.

2 curtidas

Coisas estranhas do mundo linux, as vezes o computador cansou de te zuar kkk
Qualquer coisa re-abre o tópico se o problema voltar kk.

Estou querendo comprar um adaptador bluetooth também, qual marca e modelo você utiliza?

@marcioandre94 Comprei um adaptador bluetooth usb da China. A marca é Orico.
Ele é bem pequeno. O plug usb é maior que a parte do chip

1 curtida

Estou com o mesmo problema, só que meu adaptador é o CSR 4.0.
Uso o Linux Mint Mate 19.3, poderiam me ajudar?

1 curtida

Também estou com o mesmo problema.

Utilizo o Mint 19.3 e o mesmo adaptador Bluetooth citado, o Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode).

O dispositivo emparelha com o Blueman instalado. Contudo, as vezes quando eu paro de utilizar o PC ele desemparelha da caixinha JBL Flip 4 que uso aqui como som do PC. E o sistema não inicia com ele emparelhado, coisa que acontece no Win10 normalmente.

Queria fazer com que o sistema iniciasse já emparelhando minha caixinha, como no windows.

Alguém sabe uma solução? já tentei de tudo que achei no fóruns e esse foi o mais semelhante.