Instalar Wine no Linux Mint 19.3

Conseguir instalar sim, só dei sudo apt update depois de adicionar o repositório e
sudo apt install --install-recommends winehq-stable, e instalou. Mas eu não tinha nenhuma versão anterior do wine instalada.

1 Curtida

Quando eu limpo os PPAs fica assim eu removo tudo até a chave

ls /etc/apt/sources.list.d/         
git-core-ppa-bionic.list  keybase.list                        teamviewer.list                    vscode.list
google-chrome.list        official-package-repositories.list  ubuntu-x-swat-updates-bionic.list  yarn.list
insync.list               spotify.list                        virtualbox.list

cat /etc/apt/sources.list                               
#deb cdrom:[Linux Mint 19.2 _Tina_ - Release amd64 20190729]/ bionic contrib main non-free
deb [arch=amd64] https://download.docker.com/linux/ubuntu bionic stable

Mas ou vou tentar amanha novamente

Se o problema está na compatibilidade da versão 5 do wine com o ubuntu 18.04, como um ultimo recurso vc pode tentar instalar a versão 4 do wine.

com o respositorio ppa já incluido e com o update feito, esse comando abaixo mostra as versões disponíveis de um programa no respositorio, normalmente os programas tem apenas uma versão no repositorio, mas existe outros que deixam algumas versões pro user poder escolher, que é o caso do wine:
sudo apt-cache policy winehq-stable

aí vc escolhe a versão 4 mais recente, aqui para mim é a 4.0.3, instala com o seguinte comando

sudo apt install --install-recommends winehq-stable=4.0.3~bionic

se vc não definir uma versão ele instala a versão candidata que no momento é a 5.0.0~bionic


Não é o ideal ficar na versão 4 do wine, mas pode ser que resolva de forma paliativa.

Pessoal, eu percebi algo que pode ser o problema.
Eu executei o comando que o @mrkalvin falou e o resultado foi esse:

sudo apt-cache policy winehq-stable
[sudo] senha para rogerio:           
winehq-stable:
  Instalado: (nenhum)
  Candidato: 5.0.0~bionic
  Tabela de versão:
     5.0.0~bionic 500
        500 https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04 ./ Packages
     4.0~bionic 500
        500 http://packages.linuxmint.com tricia/import amd64 Packages

Note que aparece um repositório com a versão 4.0…neste caso acredito que o @YugiMoto está certo em relação de eu não ter removido o “PPA bugado”, porém não acho que dá/pode? remover este repositório.
Apesar do Mint ser baseado no Ubuntu, acredito que por causa de algumas diferenças fazem com que a solução não seja exatamente a mesma.

No caso a sugestão do @mrkalvin em instalar a versão 4.0. da o mesmo erro

sudo apt install --install-recommends winehq-stable=4.0~bionic  
[sudo] senha para rogerio:           
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 winehq-stable : Depende: wine-stable (= 4.0~bionic)
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Sobre a sugestão do @Artur no primeiro comando para instalar as dependências da o seguinte erro:

sudo apt-get install libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 libsdl2-2.0-0:i386 libfreetype6:i386 libdbus-1-3:i386 libsqlite3-0:i386
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
libgpg-error0:i386 is already the newest version (1.27-6).
libgpg-error0:i386 configurado para instalar manualmente.
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 libasound2-plugins:i386 : Depende: libpulse0:i386 (>= 0.99.1) mas não será instalado
 libsdl2-2.0-0:i386 : Depende: libpulse0:i386 (>= 0.99.1) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.  

A sugestão do @CanalOCaraDoTI eu já havia testado ontem e tb não deu.

Em algum momento na atualização do Sistema de uma versão para outra não é perguntado sobre manter pacotes?? ou algo assim??
Estou perguntando isso pq parece que me lembro quando fui atualizar o Mint.
Acho que isso é que está dando estes problemas.

Agradeço a todos pela disposição em me ajudarem… vlw galera!!

Eu não uso mint mas creio que essa PPA ai é do mint, não?
Sei lá, nunca me interessei no mint.
Aqui o meu retorna isso:

Em todo caso eu recomendo você remove a PPA e tenta faze a instalação e depois adiciona essa PPA de novo, pois pelo nome ela é do mint e ela vai faze falta creio eu. Se quiser eu atualizei o meu post lá, ta mais organizado agora eu tinha feito correndo.

1 Curtida

Pessoal consegui resolver!!! eu fiz o seguinte:

Primeiro: Mantive somente o repositório 'Oficial do Mint que é este

Depois peguei os passos daqui Wine Stable install on Linux Mint 19.3 Gives Error - WineHQ Forums
que foram:
sudo apt-get install libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 libsdl2-2.0-0:i386 libfreetype6:i386 libdbus-1-3:i386 libsqlite3-0:i386

Estas dependências são as mesmas citadas no tutorial do @Artur Como Instalar o Wine 5.0 no Ubuntu 18.04/19.10/Mint 19.x que por algum motivo tava dando erro na instalação quando tentei.

Depois confirmei se as duas bibliotecas estavam instaladas: libfaudio0 libfaudio0:i386

apt-cache policy libfaudio0 libfaudio0:i386
libfaudio0:
  Instalado: 19.07-0~bionic
  Candidato: 19.07-0~bionic
  Tabela de versão:
 *** 19.07-0~bionic 100
        100 /var/lib/dpkg/status
libfaudio0:i386:
  Instalado: 19.07-0~bionic
  Candidato: 19.07-0~bionic
  Tabela de versão:
 *** 19.07-0~bionic 100
        100 /var/lib/dpkg/status

Depois tentei instalar

sudo apt-get update
sudo apt-get install -f
sudo apt install --install-recommends winehq-stable

Com isso consegui instalar a versão 4. Instalei o que precisava instalar e funcionou.
Ai já que havia funcionado resolvi tentar atualizar para a versão 5 então segui os passos da wiki : Ubuntu - WineHQ Wiki

Primeiro tentei remover o wine mas não consegui

sudo apt remove wine 
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Pacotes virtuais como 'wine' não podem ser removidos
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

Depois segui com o processo de instalação

wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key

sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'

sudo apt update

sudo apt install --install-recommends winehq-stable

Pronto agora esta na versão 5.0

Obrigado a todos, pois para chegar nesta solução peguei dica de todos… Vlw galera!!!

3 Curtidas

Boa noite…fiz tudo conforme o descrito e nada de conseguir.

Acho que preciso instalar o libfaudio0: i386 na versão 20.01 né?

1 Curtida

Olá… sim precisa instala-lo… Você está com exatamente com o mesmo problema que o meu? Você está usando o Mint 19.3? Estou perguntando pois talvez o meu “tutorial” não seja o melhor pq eu tive que passar por várias tentativas e passos. O pessoal ai acima fizeram tutoriais passo a passo.
Se você já tentou os tutoriais do pessoal ai acima e mesmo assim tá com problemas ai neste caso da para seguir minha solução.
Algo que tem que sei feito antes da instalação é adicionar a arquitetura i386 você ja fez isso?

sudo dpkg --add-architecture i386

e para instalar a lib pode ser baixando aqui

https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/i386/libfaudio0_19.07-0~bionic_i386.deb

Fala Rogerio, estou com o mesmo problema que vc…utilizo o Mint 19.3 mesmo.
Ainda não consegui resolver, segui os passos da galera e nada =…sigo na tentativa.
Também não consegui baixar o libfaudio0: i386 na versão 20.01 .

@MarcelfMaia … aqui eu to usando a versão 19.7-0

➜  ~ apt-cache policy libfaudio0 libfaudio0:i386
libfaudio0:
  Instalado: 19.07-0~bionic
  Candidato: 19.07-0~bionic
  Tabela de versão:
 *** 19.07-0~bionic 100
        100 /var/lib/dpkg/status
libfaudio0:i386:
  Instalado: 19.07-0~bionic
  Candidato: 19.07-0~bionic
  Tabela de versão:
 *** 19.07-0~bionic 100
        100 /var/lib/dpkg/status

No caso para baixar o 20.01 o link e esse:

https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_19.04/i386/libfaudio0_20.01-0~disco_i386.deb

Mas eu acho melhor instalar a versão recomendada que é a 19.07 pq o Mint 19.x é baseado no Ubuntu 18.04

Achei nesse site SDL2 Backport to Bionic : Cybermax o que parecer ser o libfaudio0: i386 na versão 20.01, mas fiquei meio cabreio de instalar este PPA.
Sabem dizer se posso instalar de boa assim…?

Rogerio, como iria remover então - 20.01 para instalar o 19.07?

Cara boa pergunta :sweat_smile: … eu acho melhor você abrir um novo tópico aqui no forum com esta dúvida o pessoal vai lhe ajudar com isso, pois eu não sei se isso pode quebrar seu sistema.
Ou faz o seguinte… como você já tem uma libfaudio0 20.01 instalada, tenta instalar a libfaudio0:i386 20.01 e testa se o wine funciona. Se funciona beleza se não ai tem que instalar a anterior.

Rogerio, consegui fazer a instalação…fui lendo o que o terminal me dizia o que está faltando e fui baixano os arquivos.
Só consegui instalar a versão 4…e habilitou instalação pela loja de aplicativos (vai entender…ahhaha)

tentei atualizar para 5, mas continuou mostrando que está na versão 4

1 Curtida

Depois de instalar a versão 4 eu segui este tutorial oficial para atualizar para a versão 5
https://wiki.winehq.org/Ubuntu

fiz aqui, mas ficou wine 4.0
Será que dá para colocar o 5?

aqui quando tento atualizar dá isso:

master@master-desktop:~$ sudo apt install --install-recommends winehq-stable
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  libcapi20-3 libodbc1 libosmesa6 wine-stable-amd64
Utilize 'sudo apt autoremove' para os remover.
The following additional packages will be installed:
  wine-stable:i386 wine-stable-i386:i386
Os pacotes a seguir serão REMOVIDOS:
  wine-stable
Os NOVOS pacotes a seguir serão instalados:
  wine-stable:i386
Os pacotes a seguir serão atualizados:
  wine-stable-i386:i386 winehq-stable
2 pacotes atualizados, 1 pacotes novos instalados, 1 a serem removidos e 0 não atualizados.
É preciso baixar 1.151 kB/61,4 MB de arquivos.
Depois desta operação, 198 MB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Obter:1 https://dl.winehq.org/wine-builds/ubuntu bionic/main i386 wine-stable i386 5.0.0~bionic [1.151 kB]
Baixados 1.151 kB em 0s (2.952 kB/s)    
(Lendo banco de dados ... 296851 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../winehq-stable_5.0.0~bionic_amd64.deb ...
A descompactar winehq-stable (5.0.0~bionic) sobre (4.0~bionic) ...
A preparar para desempacotar .../wine-stable-i386_5.0.0~bionic_i386.deb ...
A descompactar wine-stable-i386:i386 (5.0.0~bionic) sobre (4.0~bionic) ...
A seleccionar pacote anteriormente não seleccionado wine-stable:i386.
A preparar para desempacotar .../wine-stable_5.0.0~bionic_i386.deb ...
A descompactar wine-stable:i386 (5.0.0~bionic) sobre (4.0~bionic) ...
Configurando wine-stable-i386:i386 (5.0.0~bionic) ...
Configurando wine-stable:i386 (5.0.0~bionic) ...
Configurando winehq-stable (5.0.0~bionic) ...
A processar 'triggers' para gnome-menus (3.13.3-11ubuntu1.1) ...
A processar 'triggers' para mime-support (3.60ubuntu1) ...
A processar 'triggers' para desktop-file-utils (0.23+linuxmint8) ...
A processar 'triggers' para libc-bin (2.27-3ubuntu1) ...
A processar 'triggers' para man-db (2.8.3-2ubuntu0.1) ...
master@master-desktop:~$ winecfg
wine: '/home/master/.wine' is a 64-bit installation, it cannot be used with a 32-bit wineserver.

Aparentemente instalo o wine 5 não?
Qual a saída desse comando:

wine --version

wine --version

Esse comando retorna o wine 5.0, mas da o seguinte erro quando executo no terminal:
wine: ‘/home/master/.wine’ is a 64-bit installation, it cannot be used with a 32-bit wineserver.

E quando tento rodar algum .exe com o wine, não vai por nada.

Você adicionou a arquitetura 32-bit? com o comando

sudo dpkg --add-architecture i386

Ta dizendo que é somente a versão 64-bit

1 Curtida

Sim. E tá dizendo o wine instalado é 64bit e não pode ser usado com um server de 32bit…

Estou confuso! rs