[DICA] Instalando Wine 5 no Debian 10 / Ubuntu 18.04 e 19.04 / Linux Mint 19.x

Mesma coisa. Cada dependência traz mais. “Você manteve (hold) pacotes quebrados”.

Você tento pelo link que eu te enviei?
Faz o teste é só segui esse post que eu criei aqui mas muda para a PPA do link.

Você não respondeu o que eu perguntei, você fez o que eu coloquei nesse post?
Desinstalo o wine primeiro, removeu a PPA e a KEY e depois adiciono a PPA do link que eu enviei, atualizo o pacote e ai tento instala?
Exatamente nessa ordem.

Sim, repeti o processo nesta página, apenas trocando a key e a PPA pela do link que mandou. Esse terminal acima é a última etapa, que falhou com o mesmo erro.

Posta a saída desse comando:

sudo apt-cache policy winehq-stable

aghbi@airis-laptop  Ubuntu  ~  sudo apt-cache policy winehq-stable
[sudo] senha para aghbi:
winehq-stable:
Instalado: (nenhum)
Candidato: 5.0.0~xenial
Tabela de versão:
5.0.0~xenial 500
500 http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_16.04 ./ Packages
aghbi@airis-laptop  Ubuntu  ~ 


@YugiMoto

Tenta isso:

sudo apt-get install libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 libsdl2-2.0-0:i386 libfreetype6:i386 libdbus-1-3:i386 libsqlite3-0:i386

sudo apt update

sudo apt install -f

sudo apt install --install-recommends winehq-stable

Se caso não funciona não sei dizer como vai resolve pois não uso o ubuntu 16.04 e no ubuntu 18.04 (Só que foi mais fácil resolve pois a maior parte dos usuários está nessa versão) já estava tendo problemas pois o wine 5 pelo que muitos falaram aqui ele foi feito diretamente pro ubuntu 20.04

aghbi@airis-laptop  Ubuntu  ~  sudo apt-get install libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 libsdl2-2.0-0:i386 libfreetype6:i386 libdbus-1-3:i386 libsqlite3-0:i386
[sudo] senha para aghbi: 
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 libasound2-plugins:i386 : Depende: libpulse0:i386 (>= 0.99.1) mas não será instalado
 libsdl2-2.0-0:i386 : Depende: libpulse0:i386 (>= 0.99.1) mas não será instalado
                      Depende: libwayland-egl1-mesa:i386 (>= 10.0.2) mas não será instalado ou
                               libwayland-egl1:i386
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Sinto muito, procure uma solução ou alguém que use o ubuntu 16.04 ainda que é mais rápido e fácil pois eu não uso e não to muito afim de fica procurando algo sobre a versão 16.04 ainda mas com toda certeza tem alguém aqui que possa te ajuda, abre um post pedindo ajuda que alguém deve ter a resposta pronta já.

Entao boa sorte ai man, vai precisar mesmo :vulcan_salute:

Ae man, valeu pelo tutorial… usar os repos do opensuse resolveram meus problemas.
Alguma idéia do pq a repo do WineHQ que tem nas instruções da wiki deles mesmo não funciona em algumas distros?
No meu caso eu to usando o Zorin 19.2
Valeu!

Não sei dizer exatamente o problema mas com base no que já vi pessoas comentando e pelo erro é que a versão 5 do wine foi desenvolvida pro ubuntu 20.04 LTS que ainda vai sair e aparentemente algumas dependências já vai vim instalada na nova LTS, coisa que não está incluso na PPA e causa alguns bugs na instalação.

Consegui, obrigado pela dica. :+1:t3:

Eae man, suave?? O ZorinOS usa como base o Ubuntu 18.04, entao se for seguir algum tutorial, se baseia nessa versao q tem la no site do WineHQ q eh pra funcionar.

1 curtida

Cara com o PPA do opensuse funcionou!
Tentei seguir o que tinha lá no WineHQ, mas como o @YugiMoto comentou ali em cima, o PPA deles não tinha as dependencias pro Wine 5… com o PPA do OpenSuse e só daí ele pegou as dependências que precisava pro ubuntu bionic que a instalação tava pedindo… de qualquer forma, resolveu! :smiley:

1 curtida

@YugiMoto, eu também tava quebrando a cabeça aqui
mas seu video me ajudou muito obg. sou usuário iniciante e estava tendo muitas dificuldades e seu video me salvou valleu

1 curtida

Cara, faz a instalação do Ubuntu minimal sem ambiente gráfico, faz o boot no sistema após o fim da instalação e instala o ubuntu-unity-desktop, é bem mais fácil. Também existe um PPA que possui o Unity7 atualizado de acordo com as mudanças que são feitas na base do sistema do Ubuntu, isto para evitar problemas de incompatibilidade e afins, ele funciona até mesmo nas Daily Builds do 20.04.

Vim só passar para agradecer o tutorial. Resolvi meu problema.

2 curtidas