Debian 11 demorando de 30-60 segundo para ligar ou desligar (ssd)

Estou usando o sistema a 24 horas, e hoje ao ligar notei que ele estava demorando muito para ligar e para desligar. Alguma sugestão?

~$ systemd-analyze
Startup finished in 8.485s (firmware) + 3.588s (loader) + 2.183s (kernel) + 9.787s (userspace) = 24.045s
graphical.target reached after 9.783s in userspace

systemd-analyze blame
6.845s plymouth-quit-wait.service
6.011s NetworkManager-wait-online.service
1.637s snapd.service
1.253s snap-core-12603.mount
1.221s snap-gnome\x2d3\x2d28\x2d1804-161.mount
1.102s snap-core18-2284.mount
1.086s snap-spotify-57.mount
963ms snap-tradingview-14.mount
942ms snap-bare-5.mount
937ms snap-bitwarden-59.mount
916ms snap-whatsapp\x2dfor\x2dlinux-31.mount
905ms snap-telegram\x2ddesktop-3544.mount
846ms snap-core20-1270.mount
837ms snap-spotify-56.mount
825ms snap-vlc-2344.mount
824ms snap-core-11993.mount
823ms udisks2.service
719ms snapd.seeded.service
711ms snap-gtk\x2dcommon\x2dthemes-1519.mount
647ms dev-sdb5.device
586ms accounts-daemon.service
564ms smartmontools.service
497ms ufw.service
491ms polkit.service
471ms avahi-daemon.service
469ms NetworkManager.service
464ms switcheroo-control.service
458ms wpa_supplicant.service
453ms systemd-logind.service
449ms dev-loop1.device
397ms ModemManager.service
368ms apt-daily.service
355ms systemd-journal-flush.service

~$ systemd-analyze critical-chain
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @9.783s
└─multi-user.target @9.783s
  └─plymouth-quit-wait.service @2.938s +6.845s
    └─systemd-user-sessions.service @2.914s +20ms
      └─network.target @2.901s
        └─NetworkManager.service @2.427s +469ms
          └─dbus.service @2.425s
            └─basic.target @2.419s
              └─sockets.target @2.419s
                └─snapd.socket @2.418s +978us
                  └─sysinit.target @2.415s
                    └─haveged.service @2.415s
                      └─apparmor.service @2.118s +295ms
                        └─local-fs.target @2.116s
                          └─snap-core-12603.mount @861ms +1.253s
                            └─dev-loop13.device @2.109s +16ms
1 curtida

deixar de usar snaps?

2 curtidas

Isso vai resolver o gargalo? depois que o sistema inicia tudo fica normal.

Recomendo mascarar
Os wait

6.845s plymouth-quit-wait.service
6.011s NetworkManager-wait-online.service

sudo systemctl mask NetworkManager-wait-online.service plymouth-quit-wait.service

Para desfazer

sudo systemctl unmask NetworkManager-wait-online.service plymouth-quit-wait.service

Simplesmente espera, sem fazer absolutamente nada, até que a rede esteja conectada e, quando isso acontece, muda de estado para que outros serviços que dependem da rede possam ser iniciados para começar a funcionar

Para a maioria pode ser desligado sem problema.

Veja se isso ajuda

1 curtida

O grande @frc_kde uma vez num tópico aqui estava explicando que o KDE Plasma em algumas distros usa uma feature chamada PIM, e que deixa o Plasma mais pesado. Enfim, dá uma olha nisso.

Algo aconteceu no sistema para ficar mais lento, se for os aplicativos snap vou tirar todos para ver se são eles que estão dando esse gargalo ao ligar e desligar.

1 curtida

Nunca consegui decifrar essas análises do tempo de boot, mas me parece que o PIM não tem muito a ver, pelo menos neste caso.

Pela minha experiência pessoal, aqui e ali:

Certa época, o Debian me pareceu ser a única distro que verificava a existência de atualizações, ainda durante o boot – ou seja, antes de carregar o ambiente (DE). E nunca descobri como desabilitar isso.

O que faço, é remover o PackageKit e o Plasma-Discover, além do unattended-upgrades – por outros motivos. – Pela lógica, estes seriam os suspeitos de atrasarem o boot, até que a rede esteja disponível.

O resto da análise acima, para mim é grego.

Pessoalmente, não uso pacotes Snap, por isso não conheço as consequências num caso assim.

1 curtida

Qual a saída do comando?


systemd-analyze --user blame

arranca fora tudo de snap, use somente .deb

1 curtida

Vou fazer isso mesmo!

systemd-analyze --user blame
712ms pulseaudio.service
277ms tracker-miner-fs.service
235ms tracker-extract.service
164ms xdg-desktop-portal.service
75ms plasma-kglobalaccel.service
68ms openrazer-daemon.service
52ms obex.service
38ms gvfs-goa-volume-monitor.service
34ms xdg-document-portal.service
32ms xdg-desktop-portal-gtk.service
14ms gvfs-udisks2-volume-monitor.service
6ms xdg-permission-store.service
4ms gvfs-gphoto2-volume-monitor.service
4ms gvfs-mtp-volume-monitor.service
3ms gvfs-daemon.service
3ms gvfs-afc-volume-monitor.service
2ms at-spi-dbus-bus.service
1ms dbus.socket

Agora sim!!! bem vindo ao Debian Plasma! kkkk

Minha sugestão é que você faça isso mesmo. Se você precisar de software mais recente ou que não esteja nos repositórios, dê preferência aos Flatpaks, que não pesam tanto no sistema como os snaps. Uso o Debian 11 com XFCE, tenho mais de 20 apps em Flatpak, incluindo Firefox e LibreOffice, e sem contar as runtimes. Meu sistema está instalado num SSD, e demora cerca de 30 segundos para iniciar, e o desligamento é instantâneo (mesmo num HD ele desligava rápido). Os apps abrem rápido também.

Algumas dicas para o uso de Flatpaks:

  • Instruções de instalação no Debian neste link. E como você usa Plasma, seria bom instalar o pacote plasma-discover-backend-flatpak, para integrar com a loja Discover.
  • Dê uma olhada neste tópico para ver como deixar os apps em Flatpak com mesmo tema do restante do sistema.
  • Você pode, em algum momento, ter que conceder/alterar permissões de apps, para que eles funcionem melhor (semelhante ao Android). Para isso, use o app Flatseal.
2 curtidas

Passei o dia ajeitando aqui kkk

bom, formatei o pc, instalei os programas sem flatpak ou snap e está uma bala, o ruim é que vou ficar sem alguns aplicativos, mas tenho praticamente tudo o que desejo.

1 curtida

Os snaps deixa o boot lento enquanto que os flatpaks deixam o desligamento mais lento, o anydesk em flatpak por exemplo sempre enrosca o Debian na hora de desligar, o mesmo acontece com outros flatpaks que rodam em segundo plano.

Sinceramente 60 s acho pouco tempo de espera, não deixaria de usar app por causa disso.

Como eu disse, eu tenho vários aplicativos em Flatpak, e meu sistema desliga praticamente instantaneamente ao clicar em “desligar”. Mas nenhum deles fica rodando em segundo plano, que eu saiba… talvez esse problema que você teve com o AnyDesk esteja relacionado ao próprio aplicativo e não ao formato Flatpak.


Se preferir, também tem os AppImage, que são semelhantes aos programas portáteis do Windows… tudo o que o programa precisa está incluso em um arquivo, e não precisa de instalação. Só não gosto muito de AppImage porque não é bem integrado ao sistema.

Eu só queria o tradingview em flatpak, mas só tem em snap( e ficou aquela demora pra desligar e ligar). Estou tentando achar whatsapp em flatpak, porém os que tem estão aparecendo que o google chrome está com uma versão muito antiga, no snap abria de boa. De resto eu estou usando .deb e appimage.

Outra coisa, o debian ainda reiniciou sozinho! Fui pesquisar no google e parece ser um problema no kernel, fiz um tutorial e não desligou mais.

Você viu isso?

segui esse tutorial Descubra como instalar o Node.js no Linux nativamente

sudo apt-get install nodejs npm

instalou sem erros.

Depois fui para o seu e aconteceu isso.