Yay foi descontinuado?

Oi pessoal, estou tentando atualizar o meu sistema já há algum tempo mas recebo a mensagem de que o yay não suporta a nova versão do pacman. Ele foi descontinuado? tem alguma forma de atualizar ignorando o erro?

Erro:
erro: falha ao preparar a transação (não foi possível satisfazer as dependências)
:: a instalação de pacman (5.2.1-1) quebra a dependência “pacman<=5.1.3” necessária por yay

Obrigado!

Isso é um erro de transação, para atualizar você vai ter que remover o yay, atualizar o sistema e depois instalar o yay novamente caso queira. Este problema aconteceu com todos AUR helpers nas últimas atualizações.

2 Curtidas

Isso aconteceu comigo também, mas substitui o yay pelo trizen, que ao que parece é atualizado com mais frequência que o yay.

Independente disto se fosse o trizen o erro seria o mesmo, para fazer a atualização seria necessário removê-lo por causa da dependência do pacman (neste caso o pacote que estária sendo atualizado), e o helper foi compilado com uma versão anterior das bibliotecas.
Seria possível fazer a atualização? Sim, porém o helper não funcionaria até que você o reconstruisse, logo o gerenciador de pacotes não pode continuar, claro que se ele fosse mais inteligente ele já faria a remoção do helper “com uma aviso claro” que você teria que instalar novamente, afinal gerenciadores de pacotes em tese deveriam fazer isto. Ainda mais lidando com um pacote básico como o pacman.