Wifi com taxa de upload limitada

Andei achando estranha a taxa de upload no meu notebook…
Hardware:
03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

Então, para testar e me certificar, inicializei o notebook com o Mint no modo live, via USB, testei a velocidade e a taxa de upload está dentro do esperado (quase 100% da velocidade).

Porém, quando inicializo pelo sistema instalado, também o Linux Mint, a taxa de upload não passa de 50% da velocidade.

Prints de testes - modo live - upload normal:


…sistema instalado - upload limitado:


Bem, não lembro se fiz algum ajuste em algum arquivo de configuração ou não, então, se alguém tiver alguma dica, agradeço.

Qual o seu drive?
Usa networkmanager?

instalei, para tentar ver melhor as configurações, o gnome-nettool… mas, como é o Mint Cinnamon, o gerenciador de rede é o padrão do sistema, da instalação.

“drive”, refere-se ao dirver?
Hardware é “Qualcomm Atheros QCA9377”…

Pelo nome da placa, deve ser o ath9k

Tente fazer o procedimento abaixo

sudo nano /etc/modprobe.d/ath9k.conf

e adicione
options ath9k nohwcrypt=1

sudo modprobe -r ath9k
sudo modprobe ath9k

É faça o teste novamente

Sim… agora identifiquei certinho…

*-network
descrição: Interface sem fio
produto: QCA9377 802.11ac Wireless Network Adapter
fabricante: Qualcomm Atheros
ID físico: 0
informações do barramento: pci@0000:03:00.0
nome lógico: wlp3s0
versão: 31
serial: 98:83:89:d8:bb:53
largura: 64 bits
clock: 33MHz
capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuração: broadcast=yes driver=ath10k_pci driverversion=4.15.0-99-generic firmware=WLAN.TF.2.1-00021-QCARMSWP-1 ip=192.168.10.12 latency=0 link=yes multicast=yes wireless=IEEE 802.11
recursos: irq:130 memória:f7200000-f73fffff

driver=ath10k_pci
… e não tem qualquer arquivo, tipo, ath10k_pci.conf em /etc/modprobe.d, somene um “iwlwifi.conf”.

$modinfo ath10k_pci
filename: /lib/modules/4.15.0-99-generic/kernel/drivers/net/wireless/ath/ath10k/ath10k_pci.ko
firmware: ath10k/QCA9377/hw1.0/board.bin
firmware: ath10k/QCA9377/hw1.0/firmware-5.bin
firmware: ath10k/QCA6174/hw3.0/board-2.bin
firmware: ath10k/QCA6174/hw3.0/board.bin
firmware: ath10k/QCA6174/hw3.0/firmware-6.bin
firmware: ath10k/QCA6174/hw3.0/firmware-5.bin
firmware: ath10k/QCA6174/hw3.0/firmware-4.bin
firmware: ath10k/QCA6174/hw2.1/board-2.bin
firmware: ath10k/QCA6174/hw2.1/board.bin
firmware: ath10k/QCA6174/hw2.1/firmware-5.bin
firmware: ath10k/QCA6174/hw2.1/firmware-4.bin
firmware: ath10k/QCA9887/hw1.0/board-2.bin
firmware: ath10k/QCA9887/hw1.0/board.bin
firmware: ath10k/QCA9887/hw1.0/firmware-5.bin
firmware: ath10k/QCA988X/hw2.0/board-2.bin
firmware: ath10k/QCA988X/hw2.0/board.bin
firmware: ath10k/QCA988X/hw2.0/firmware-5.bin
firmware: ath10k/QCA988X/hw2.0/firmware-4.bin
firmware: ath10k/QCA988X/hw2.0/firmware-3.bin
firmware: ath10k/QCA988X/hw2.0/firmware-2.bin
license: Dual BSD/GPL
description: Driver support for Qualcomm Atheros 802.11ac WLAN PCIe/AHB devices
author: Qualcomm Atheros
srcversion: 56ED06FF34B10C7EB832B23
alias: pci:v0000168Cd00000050svsdbcsci*
alias: pci:v0000168Cd00000042svsdbcsci*
alias: pci:v0000168Cd00000046svsdbcsci*
alias: pci:v0000168Cd00000056svsdbcsci*
alias: pci:v0000168Cd00000040svsdbcsci*
alias: pci:v0000168Cd0000003Esvsdbcsci*
alias: pci:v0000168Cd00000041svsdbcsci*
alias: pci:v0000168Cd0000003Csvsdbcsci*
depends: ath10k_core
retpoline: Y
intree: Y
name: ath10k_pci
vermagic: 4.15.0-99-generic SMP mod_unload
signat: PKCS#7
signer:
sig_key:
sig_hashalgo: md4
parm: irq_mode:0: auto, 1: legacy, 2: msi (default: 0) (uint)
parm: reset_mode:0: auto, 1: warm only (default: 0) (uint)

ok

cinnamon
veja se tem instalado ath10k firmware

aqui é do ubuntu…

mas talvez ajude…
procure e veja se está instalado

linux-firmware

Vc também pode configurar para um agressiva transmissão

É para criar o arquivo

echo “options iwlwifi 11n_disable=8” | sudo tee /etc/modprobe.d/iwl11n.conf

Mais informação em
modinfo ath10k_pci

Como o artigo é de 2015, tentei olhar algumas orientações, porém, preferi não executar algumas ações, pois são de 2015. Acredito que agora, em 2020, o Kernel já deve tratar isso melhor do que naquele ano.
A única tentativa que fiz foi:
sudo modprobe -r ath10k_pci && sudo modprobe ath10k_pci

Mas, não mudou nada, tentei revisar os arquivos (.conf), mas, não achei nada de anormal (ou eu não olhei em todos os lugares, claro!).

Enfim, ainda sigo pesquisando sobre o assunto para tentar resolver, visto que, no modo live, funciona 100%, só no sistema instalado que está com esse contra-tempo no upload.

veja as opções de configuração com

modinfo ath10k_pci

mais atualizado

parece ser a verão do kernel
https://forums.linuxmint.com/viewtopic.php?t=290256

troque e veja se funciona

1 Curtida

Perfeito!

Kernel atualizado, problema resolvido.

1 Curtida