Wi-Fi caíndo no Manjaro

Bom dia,

no meu notebook sempre que instalo o Manjaro o Wifi fica caindo de tempos em tempos, fica uns 30 segundos fora e volta no telefone ele continua normal, só no notebook que fica caindo. Tirei print da saída do serviço de internet, alguém pode me ajudar? Pesquisei mas não funcionaram tais soluções.

1 Curtida

Me parece que seu roteador está configurado com “DHCP lease time” de 1 hora. Teoricamente ao final desse tempo ele deveria apenas manter por mais tempo, sem nenhuma percepção ao usuário.

Talvez o roteados esteja trocando seu endereço IP e causando a desconexão a cada 1 hora. Se for esse o caso, você pode configurar no roteador que o “tempo para emprestimo de IP” seja maior, tipo MUITO maior (100000 segundos). Outra opção é configurar no network-manager o seu endereço como estático, geralmente os roteadores aceitam isso tranquilamente.

3 Curtidas

Entendi, o IP estático eu já uso, para manter meu PC em um IP, assim consigo teste os projetos que faço no telefone usando a rede local.

Daí então olhei esse tempo, estava de 120 minutos, estranho cair de hora em hora. Mas aumentei ao máximo, amanhã verei se funcionou. Se funcionar eu fecho o post, obrigado pela resposta.

1 Curtida

A solução do @Deleterium resolveu parcialmente, deixei par a comentar no fim do dia, pois testei durante o dia, a desconexão continuou, mas o número foi menor, embora no roteador esteja 48h para concessão de IP. Durante o dia desconectou umas 3 vezes, mas demorou menos para reconectar.

Apenas atualizando, consegui resolver esse problema apenas habilitando o dhcpcd, segundo a Wiki do Arch ele é um simples cliente de DHCP. Porém nem configurei nada, só habilitei ele e o problema já foi solucionado:

sudo systemctl enable dhcpcd.service

1 Curtida

Olá pessoal.

Sou usuário do Manjaro XFCE e estou passando por este mesmo problema.

Tentei aplicar a solução citada mas não funcionou.

A internet cai de tempos em tempos. Mais ou menos a cada 45 minutos.

Depois que cai, ela só volta a funcionar quando eu clico no nome da rede.

Em configurações de IPv4 a opção Método esta marcada como “Automático (DHCP)”.

Por acaso começou a apresentar este comportamento após a contratação do serviço da Claro. Não sei se é alguma configuração do próprio roteador.

Poderiam me auxiliar? Qual informação adicional devo enviar?

Obrigado

Tentou essa dica?

Pessoal só atualizando. No meu caso, o que estava ocasionando o problema era o repetidor de sinal. Desliguei o mesmo e tudo voltou a funcionar. Não precisei alterar nada no sistema e nem no admin do modem.