Vulkan suportado em uma distro e na outra não

Ok, então eu estava usando meu Pop!OS jogando joguinhos normalmente e tudo funcionando normalmente até que uns dias atras decidi trocar de distro para o Manjaro por querem ir mais alem, até ai tudo bem, mas quando tentei jogar o lutris deu erro de que o vulkan não é compativel com meu hardware (algo que nunca ocorreu no pop).
No proprio menu do lutris na aba de dados do sistema, no Pop!OS está como “vulkan: supported”, já no Manjaro no mesmo dispositivo está “vulkan: not supported”. Já tentei instalar e reinstalar versões diferentes dos drivers até mesmo do kernel e nada funciona.
Não sei o que fazer ou se estou fazendo algo errado.

Manjaro: (está até mais atualizado os drivers no caso)


Pop!OS:
image

N sei se é a causa mas no POP em display server está: X11 e no Manjaro: wayland. Tente mudar a sessão do manjaro para X11 tmb.

Troquei para o X11, infelizmente, sem resultados.

Estava pensando aqui, pode ser alguma diferença nos drivers do kernel já que o Pop!OS utiliza um kernel “generic” e no Manjaro é um versão customizada (no meu caso 5.14.10-1-MANJARO), porem não sei se realmente seria isso.

@Rodrigo_Chile ManjaroKing?

1 curtida

Você tem alguma placa de vídeo tirando a integrada?
Pelo que pesquisei seu processador não tem suporte a Vulkan mesmo, posso está enganado mas acredito que pode ter sido um pequeno erro no Pop em mostra que tinha suporte a Vulkan, mas não vou afirma por hora sksks melhor deixa alguém que jogue e usa isso com mais frequência pois eu mesmo não jogo.

A linha de processadores Intel Pentium G600 não possuem o Vulkan integrado.

Para fins de confirmação, APIs suportadas para controladores gráficos Intel®.

Assim, eu não jogo, sou super leigo no assunto - mas parece que o mistério teria sido resolvido…

1 curtida

Sim, relmente meu video integrado não tem (ou não deveria ter) suporte para vulkan. Porem no Pop ele não somente mostra que é suportado como os jogos abrem e funcionam normalmente com vulkan, coisa que no manjaro os jogos nem sequer abrem.
Acho que vou é reinstalar o Pop mesmo e deixar o Manjaro de lado, não tenho tanto tempo para ficar procurando e corrigindo os problemas.
Mesmo assim obrigado!

Aí tem q esperar os experts do manjaro aqui no grupo. Com. Certeza alguém vai te ajudar.

Se der da uma lida sobre:
https://wiki.archlinux.org/title/Vulkan_(Português)