Volume no KDE mais baixo que no Windows ou outra DE

É impressão minha ou no KDE o volume a 100% é mais baixo que no Windows ou noutra DE? Às vezes aumento para 150% e ai sim parece bem… No Windows a 30% é o mesmo que no KDE a cerca de 70%…

É bug ou os meus ouvidos? :joy:

Obrigado :slight_smile:

1 Curtida

Pra mim é o contrário, no Windows com o volume em 100% ainda deixo de ouvir algumas coisas, enquanto no Plasma em 20% já estoura meu tímpano.

2 Curtidas

Curioso :joy:

1 Curtida

aqui também é assim, mas no gnome, não uso muito kde

1 Curtida

Ao contrário do Windows, cujos drivers de áudio já vem com uns plus a mais, o Alsa vem bem cru, daí o som vir baixo e meio zoado. Sugiro instalar o pulseeffects e olhar a ajuda, configurando pela receita ali e ir testando. Fica bem melhor!

2 Curtidas

Comigo é assim em qualquer distro e DE, talvez pq eu uso o equalizador de intensidade no Windows, e no Linux não achei nada que funcionasse direito pra fazer a mesma função.

1 Curtida

Testou o Pulseeffects? É excelente, tem muito mais opções que qq driver Windows pra áudio!

2 Curtidas

Tentei, as funções tinham um delay enorme, e constantemente o equalizador de intensidade me deixava surdo por estourar o volume no maximo.

1 Curtida

Mas aí tem que seguir as instruções na ajuda e ir ajustando pelo ouvido e com auxílio de ruído rosa (pink noise - o Audacity gera pra vc); ah, na ajuda ele fala pra colocar um ajuste que ignorei, o bass enhancer. No demais, com esses 4 aí da foto (filter, multiband compressor, stereo tools e limiter) obtive excelente resultado

1 Curtida

O que é que tenho que fazer para deixar o som direito? Eu não percebo nada disto :joy:

Prepare seu inglês, pq as instruções são na língua de Shakespeare; consiga um bom fone de ouvido (vai ajudar na equalização do som, o que pode servir bem às caixas do note); gere ruído rosa no Audacity (é chato, mas será necessário; pra quem não sabe, o ruído rosa preenche todas as faixas de frequência ao mesmo tempo - lembrem-se, som é onda, estamos no terreno da física); e escolha uma ou mais músicas que tenham um bom espectro de frequência (ou seja, que tenham timbres graves e agudos na composição; eu uso Supertramp, Yes, já usei Pearl Jam), o bom é que vc busque do mais grave (bumbo e baixo) ao mais agudo (guitarras, violinos). Um concerto (Vivaldi, Mozart) pode ser uma boa opção. Músicas no piano serviriam (em tese, o piano não tem um harmônico ideal, todo o espectro de frequência audível é harmônico para piano), desde que a composição use todos os tons disponíveis (Chopin ou Beethoven servem). E depende muito do gosto de cada um, de deixar mais agudo ou mais grave. Mas o ideal é fazer com que todo instrumento de uma composição esteja lá e seja agradável ao ouvido.
Uma última dica: preste atenção aos tons médios (800 Hz a 2,5 KHz). São o correspondente à voz humana e são um pouco irritantes se excessivos.
No mais, vai testando. Nas instruções, ele recomenda o bass enhancer, mas nas minhas caixas não ficou bom. Eu deixaria sem, e em caso de uso via cabo ou chromecast de aparelhos de som profissionais, usar o próprio equalizador do player ou do aparelho de som para fazer o ajuste fino

(Aos curiosos, trabalhei uns bom anos como DJ e técnico de som em estúdio e em casas noturnas, aprendi umas coisas… hehehehe)

Não tenho Windows, ─ e não sou expert em coisa nenhuma, ─ mas observo diferenças de volume entre 11 distros Linux com KDE.

Também nunca instalei ou usei vários dos recursos que os colegas citam nas respostas anteriores. ─ Como “leigo” total, me limito a dar 1 passo de cada vez. Se não entendo os primeiros 2 passos, não avanço para o 3º, 4º, 15º etc.

O “1º passo”, para mim, é representado pelo Void, onde instalei apenas o Alsa, este ano:

(Ano passado, instalei nele também o PulseAudio, mas não consegui avançar 1 milímetro, por isso, este ano fiquei só no Alsa, mesmo… Daí, só saio quando conseguir alguma coisa).

Em resumo: ─ Não consegui “integrar” nada disso com o widget de “Volume de som” do Painel ─ nem com o KDE System Settings.

Portanto, me limitei a usar o comando alsamixer (1ª imagem) para ativar os “canais” que preciso ─ e colocar um deles em 80%, e o outro em 60%. ─ Mas não me perguntem quais “canais” são esses, nem o que “significam”, pois não consigo entender quase nada, de dezenas ou centenas de páginas que já pesquisei no Google… Em geral, são escritas em um “linuxês” de Techs que não vivem neste mundo, nem conhecem linguagem humana, e por isso não conseguem se expressar em português ou inglês “de gente” (rs).

Não consigo usar os controles do KDE (vazios), e não consigo obter sons de “Notificações”.

Void + KDE (em UEFI-GPT)

Do Void, e Alsa, é só isso que sei, este ano. ─ O que tentei no ano passado (incluindo PulseAudio), deve estar em algum pasta por aqui, mas prefiro nem olhar. Mexer com isso, agora, não faria nenhum bem à minha saúde.

Nas outras 10 distros, ─ todas com Alsa + PulseAudio (acho eu!), ─ não faço a menor ideia de como essas coisas foram resolvidas no “baixo nível”… Apenas constato que “tudo já veio funcionando”.

Vou lá em System settings >> Hardware >> Audio, e vejo que as coisas estão mais ou menos assim (imagem acima).

Me limito a botar Line Out em 80%, VLC em 60% (explicações, adiante), e “Notificações” em 70% (idem).

Meu interesse no assunto é muito limitado. ─ Tudo que quero é: ─ (a) Colocar o VLC em 60%, para ouvir 24 horas por dia, sem interferir demais com o resto; e ─ (b) Colocar o volume do Chromium (ou volume geral??) em 80%, de modo que, se encontrar um vídeo no Youtube, Twitter, Facebook etc., eu consiga ouvir bem, sem ter de abaixar o VLC. ─ Pausar, se necessário… Mexer no volume, jamais!

(Isso ainda vai depender do autor do vídeo… Muita gente da “velha guarda” faz vídeos com som quase inaudível… E mesmo no Youtube, há muita variação de volume. ─ Atualmente, evito baixar músicas com volume baixo, pois o resultado final será ruim).

É muito raro (do meu ponto de vista pessoal), encontrar um vídeo que valha a pena Pausar o VLC, para prestar atenção. ─ Sim, prefiro postagens de Texto, que em 2 segundos você verifica se vale a pena, ─ e mais ainda (no caso de livros), “em papel”, que num instante você percorre 500 páginas ao acaso, parando aqui e ali… ePub (minha preferência atual), PDF, não se comparam com papel.

Acima - Aí está, como “a coisa” aparece no meu widget de Volume, no Painel. ─ Line Out (Volume geral?) em 80%, e VLC em 60%.

O problema que resta é o volume das “Notificações”… De dia, ônibus chacoalham pelas ruas em mil decibéis, motoqueiros torram gasolina com raiva, vizinhos torram o saco pra exibir suas caixas de tum-tum etc., mas você ainda consegue ouvir o som de “notificação” de Login, Logout etc.

Chato, é você acordar sem sono às 3 h da madrugada, ligar o computador, e… rola um som estrondoso de “notificação” de Login, no silêncio universal. ─ Todos os bandidinhos da sua periferia ficam sabendo que você tem um computador roubável…! :scream: :hot_face:

(Diria Dante Aleghieri: ─ Ó vós, que julgais morar em uma “não-periferia”… Sois, por definição, alvos mil vezes mais roubáveis, e nem precisam alardear nada, por meio de sons! A malandragem já nasceu de olho em vós!..) :rofl:

No openSUSE, o volume das “Notificações” está em 70%, e o resultado prático parece bom (para mim, pelo menos). Nada de muito escandaloso, mesmo de madrugada. ─ Mas isso, com Line Out em 80%, claro… Se alterar Line Out, a coisa muda de figura.

Pelo menos 2 das minhas distros fazem um barulho escandaloso, com a notificação de Login ─ uma delas é o Fedora (32, 33…), a outra, prefiro não acusar, por não ter certeza agora. ─ Imagino que o volume das “notificações” não esteja em 70%, mas pra verificar todas, eu teria de reiniciar o computador 11 vezes seguidas, e é claro que eu não vou fazer isso agora. Isso é uma daquelas coisas que a gente resolve verificar, e depois esquece. Em bom português, “tenho mais o que fazer” (rs). Não chega a matar. Bater com o dedão do pé é 1.000 vezes mais grave.

Na realidade, cada distro tem uma versão diferente do KDE ─ e a implementação do System Settings varia muito, de uma distro para outra. ─ No Fedora, por exemplo, lembro que esta seção do volume das “notificações”… (ou será a seção de Line Out???)… apresenta um comportamento absolutamente maluco. Gastei várias horas, no ano passado, mais algumas este ano, e desisti. Minha saúde vale mais do que um sonzinho besta.

Enfim, até hoje não consegui obter o som de Login em várias distros. ─ Void (claro!), Arch, Slackware. ─ No entanto, obtenho nelas outras “notificações” sonoras… No Slackware, por exemplo, ainda uso KDE Spectacle, mas substituí sua notificação visual por uma notificação sonora, e funciona perfeitamente. Quem sabe, o som só é ativado “depois” do Login…? ─ Mistérios buguísticos.

Diria Dante Alighieri: ─ “Ó vós, que acreditais em 1 resposta universal… Sabei que a resposta pode variar conforme a distro, e conforme a versão do KDE, o que vos deixa com um total de possíveis resposta igual a um fatorial de 300+!” ─ Sim, Dante era ph.

E pra quê, que eu quero “som de Login”…? ─ Pra nada, evidentemente. Eu nem sabia que isso existia no Linux, até que, um dia, uma versão do Mint KDE me fez esta surpresa (entre várias outras personalizações do KDE que eu desconhecia durante anos). ─ Recentemente, houve uma pequena festinha de “o bom filho à casa retorna”, quando o PCLinuxOS conseguiu recuperar esta possibilidade… Pelo que (acho que) entendi, o próprio KDE andou dificultando isso, durante algumas versões recentes. Mas mesmo agora, nas distros onde não voltou a funcionar, precisa (ou “basta”) alterar um arquivinho de configuração. ─ Em resumo, som de Login não serve para nada (exceto passar vergonha, na hora errada), mas eu resolvi futricar isso, só “pra ver” como o bicho se comporta, em diferentes distros e versões do KDE.

KDE é assim ─ todo dia, boas e más novidades ─ e algumas voltam, no outro ano.

O Menu >> Recent files, por exemplo… Um belo dia, começou a exibir as mais recentes capturas capturas de tela ─ que faço com o gnome-screenshot, totalmente alienígena ao KDE! ─ e desde então, bastava eu ir no Menu, para abrir o Gwenview…

… mas, bastou o KDE “evoluir” mais um pouco, e agora o Menu >> Recent files virou uma m*!

Mas o próprio Linux também é assim. ─ Em 2018, por exemplo, eu gostava dessa opção do comando uptime, que dava o dia e a hora do último boot:

    $ uptime -s
    2019-01-04 16:58:55

E dessa outra, que dava uma resposta no mesmo padrão que se obtém no Conky:

    $ uptime -p
    up 3 days, 31 minutes

… e hoje, descobri que agora só existem -h (help) e -v (versão) ─ pelo menos, no openSUSE Tumbleweed. ─ Diria Dante: - Ó vós, que ainda tendes velhas opções, em distros point-release, sabei que esta sopinha vai acabar".

2 Curtidas

Examinei de novo as configurações de Audio nas distros, e consegui abaixar o volume das Notificações no MX Linux e no Fedora.

Instalei o PulseAudio no Void, e finalmente apareceram os controles de Volume no Painel e no KDE System settings.

Para meu gosto pessoal, o esquema é esse:

  • Line Out = 80% (de uma escala até 150)
  • Notifications = 70%
  • VLC = 60%
  • Chromium =80%

(No Mageia, não aparece o % percentual à direita)

O PCLinuxOS é diferente… cheio de “novidade”.

Em algumas distros (ou versões do KDE), ao mexer no volume Line Out, ele fica mudo… Então, é preciso mais um clique para voltar a liberar.

O som de Login já estava funcionando no:

  • MX Linux
  • Mint
  • Mageia
  • PCLinuxOS
  • KDE Neon
  • Fedora
  • openSUSE

Continuam sem o som de Login, ao reiniciar:

  • Void ─ tem som de tudo, exceto Notificações
  • Debian ─ toca Login ao testar, e ao sair dá som de Logout, mas ao reiniciar não toca nada… Talvez falte mais um clique no System Settings
  • Arch

xxx