Void Linux sem nenhum som

Opa bom dia, recentemente eu resolvi instalar o Void Linux, que acabei gostando muito, mas percebi que estava sem som.
Pesquisei, mas mesmo tentando de tudo nada funciona, alguma pessoa aqui poderia me ajudar com esse incomodo?

Vou pedir que siga esse tópico, para que possa nos fornecer mais informações sobre a sua máquina, kernel e driver instalado para gerência do som.

Se tiver o LiveCD de alguma distribuição onde o som funciona, poderia ser uma boa comparar a saída do inxi nos dois.

Instalou os componentes de som?
Quando eu instalei o void eu optei pelo pipewire, foi só instalar o pipewire e o pipewire média session depois ativar o serviço.

1 curtida

Instale estes pacotes > pulseaudio alsa-utils alsa-plugins-pulseaudio
Para ter um controle de volume > pavucontrol
Para fazer funcionar o ALSA, nescessário em ambiente de linha de comando, talvez precise de configurações em alguns arquivos. Veja: ALSA - Void Linux Handbook

Handbook do Void:
https://docs.voidlinux.org/about/index.html

Certifique-se que o serviço ALSA está sendo carregado, pois deve ser carregado. Adicione os usuários a permissão de audio.

Se você estiver usando um sistema com uma interface pré-definida (XFCE) de instalação, muito provavelmente estas coisas não sejam causas do problema. Mas, você pode tentá-las mesmo assim…

1 curtida

Por obsequio, como você faz pra instalar o pipewire? No Handbook do Void está muito resumido. Não consigo, como está no site, obter o
Server Name: PulseAudio (on PipeWire 0.3.18)
com o comando $ pactl info

https://docs.voidlinux.org/config/media/pipewire.html

Lá diz que tem que se certificar que não deve haver instancias do pulse em execução, mas quando desinstalo o pulse audio fico sem som… mesmo sem o serviço pulseaudio.

Eu instalei o pipewire e o pipewire-media-session e ativei ambos serviços.
Que eu lembre, depois vou dar uma olhada.

Pessoal, estou com o mesmo problema.
Instalei o Void Linux, consegui encontrar os drivers p/ o Wi-fi no Wiki Kernel e ta ok.
Mas estou sem audio e sem bluetooth. Já tentei algumas (várias) coisas mas ainda nada. :sweat_smile:

Segue informações, se alguém puder ajudar… =)

Vlw!!

System:
  Kernel: 5.18.17_1 arch: x86_64 bits: 64 Desktop: Xfce v: 4.16.0
    Distro: Void Linux
Machine:
  Type: Laptop System: Dell product: XPS 13 9310 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0MRT12 v: A00 serial: <superuser required> UEFI: Dell
    v: 3.9.0 date: 07/05/2022
Battery:
  ID-1: BAT0 charge: 26.0 Wh (53.1%) condition: 49.0/51.0 Wh (96.1%)
    volts: 7.6 min: 7.6
CPU:
  Info: quad core model: 11th Gen Intel Core i7-1185G7 bits: 64 type: MT MCP
    cache: L2: 5 MiB
  Speed (MHz): avg: 754 min/max: 400/4800 cores: 1: 1080 2: 517 3: 692
    4: 685 5: 836 6: 810 7: 846 8: 567
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: intel
    unloaded: fbdev,modesetting,vesa gpu: i915 resolution: 1920x1200~60Hz
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.7
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio
    driver: sof-audio-pci-intel-tgl
  Sound Server-1: ALSA v: k5.18.17_1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
Network:
  Message: No PCI device data found.
  IF-ID-1: wlp113s0 state: up mac: <filter>
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
Drives:
  Local Storage: total: 931.51 GiB used: 3.16 GiB (0.3%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB
Partition:
  ID-1: / size: 45.23 GiB used: 2.95 GiB (6.5%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 499 MiB used: 148 KiB (0.0%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 869.8 GiB used: 212.1 MiB (0.0%) fs: ext4
    dev: /dev/nvme0n1p3
Swap:
  Alert: No swap data was found.
Sensors:
  Missing: Required tool sensors not installed. Check --recommends
Info:
  Processes: 215 Uptime: 7m Memory: 31.08 GiB used: 2.19 GiB (7.0%)
  Shell: Bash inxi: 3.3.19

Você precisa pôr, no mínimo, os serviços necessários como atalhos, de /etc/sv para /var/service. No caso do Bluetooth, ‘bluetoothd’ deve constar em /var/service.

Para ter o serviço de bluetooth disponível instale o pacote ‘bluez’. Precisará de um programa “Manipulador”, eu uso o ‘blueman’, mas há outros, ‘bluedevil’ e, parece, ‘gnome-bluetooth’.

Para o som, você deverá escolher entre ‘PipeWire’ ou ‘PulseAudio com Alsa’. No caso do PipeWire não é por atalhos do serviço, é um pouco diferente.

As informações para o som
https://docs.voidlinux.org/config/media/index.html

As informações para o bluetooth
https://docs.voidlinux.org/config/bluetooth.html

Documentação/Manual do Void Linux
https://docs.voidlinux.org/about/index.html

Ainda não funcionou o bluetooth, mesmo seguindo os passos

  • Criei o atalho do bluetoothd
lrwxrwxrwx 1 root root   19 Aug 27 10:08 bluetoothd -> /etc/sv/bluetoothd/
  • Instalei o bluez e blueman
Package `bluez' already installed.
Package `blueman' already installed.
  • Meu user está com acesso a esses grupos e inclui nesse grupo bluetooth tbm (não sei se precisava)
wheel floppy audio video cdrom optical kvm xbuilder bluetooth

Quanto ao som…
Como faço p/ escolher entre um e outro?
Eu tinha visto a documentação já, mas não ficou muito claro p/ mim

  • Com o comando rfkill só lista o wifi
$ rfkill
ID TYPE DEVICE      SOFT      HARD
 0 wlan phy0   unblocked unblocked
  • Comando aplay
$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
default
    Default ALSA Output (currently PulseAudio Sound Server)

$ aplay -l
aplay: device_list:275: no soundcards found...

lrwxrwxrwx 1 root root 19 Aug 27 10:08 bluetoothd → /etc/sv/bluetoothd/

O atalho deve estar em /var/service. Você colocou em /etc/sv. O atalho deve ser de /etc/sv para /var/service.

E outra, acredito que você errou o caminho, criou uma pasta ‘bluetoothd’ dentro de outra ‘bluetoothd’… confira.

Meu user está com acesso a esses grupos e inclui nesse grupo bluetooth tbm (não sei se precisava)

Realmente, precisava sim…

Fácil, ou você instala um, ou outro…

PulseAudio é para usar na interface gráfica, e Alsa para interface de linha de comando. Você precisa ter os dois… Caso tenha preferido-os…

Os pacotes necessários estão no guia do link que lhe passei…

Apesar do artigo não ser direto, conclui-se que o pacote do PulseAudio é o pacote ‘pulseaudio’, instale se for seu caso e terá o serviço disponível…

Lembre-se também de meu post antigo…

Desculpe, acho que me enrolei ao me referir de onde para onde…

Mas finalmente, os atalhos devem estar localizados em /var/service.

Eita, rs… Fiquei confuso, vou mandar como ta aqui.
Pfv, pode ver novamente?

Listando o /var/service/ o bluetoothd ta apontando p/ /etc/sv/bluetooth/ e parece que ta certo.

  • O comando foi esse
$ sudo ln -s /etc/sv/bluetoothd/ /var/service/
  • O atalho ficou assim
$ ls -lah /var/service/bluetoothd
lrwxrwxrwx 1 root root 19 Aug 27 10:08 /var/service/bluetoothd -> /etc/sv/bluetoothd/

Somente para habilitar o áudio (alsa):

# xbps-install -S alsa-utils
# ln -s /etc/sv/alsa /var/service/
$ alsamixer

Ou seja, instalar, habilitar, em seguida executar o alsamixer para ajustar os canais que eu precisava – unmute, e regular o volume geral de cada um.

Parei nisso – não tenho o widget no Painel, nem a seção de Áudio no System Settings (KDE); e quando preciso regular o volume em algum caso específico, uso os controles do VLC, ou dos próprios sites (Youtube, Twitter, Facebook, entre outros) – porque não quis usar o PulseAudio; e na época não conhecia o Pipewire.

(Isso foi em 2020, quando montei meu PC atual. – Eu já tinha feito uma primeira experiência no meu PC anterior, em 2019, quando tentei também o PulseAudio, sem êxito).

É o suficiente, para mim. – Sei que você quer mais do que apenas isso. – Citei apenas para exemplo dos comandos; e você pode investigar e adaptá-los para o resto das coisas que você precisa, pois os passos básicos são a instalação e a habilitação dos serviços.

Que isso, ta tranquilo.

Estava testando de novo p/ ver se tinha feito certo, kkkk.

Instalei todos, mas nada de som ainda

Package `pulseaudio' already installed.
Package `alsa-utils' already installed.
Package `alsa-plugins-pulseaudio' already installed

Aparece Dummy Output

Criei também o atalho citado pelo @frc_kde

image

O comando foi esse

$ sudo ln -s /etc/sv/bluetoothd/ /var/service/

Está certo…


Verifique, por curiosidade…

$ xbps-query -Rs xorg-input-drivers

Veja se está instalado…


No caso do Bluetooth, você tá procurando a aplicação né?
O ‘blueman’ tem implicações no atalho é só aparece em algumas DE’s. Você pode contornar isso, ou instala outro software. O nativo do KDE é o ‘bluedevil’…

Você clicou no primeiro item à direita de “Dummy Output” – aquele ícone de alto-falante com um “x”?

E antes disso, você executou o alsamixer e habilitou (unmute) os canais que estavam desabilitados (mute)?