Virtualização - VT-x error

Boa noite.

Tenho um notebook de 2010 => Compaq Presario CQ56.
Pentium® Dual-Core CPU T4500 - 4 Gb de RAM.
OS: Arch Linux
DE: KDE Plasma 5.19.3
Kernel: 5.7.8-arch1-1
OS-Type: 64-bit

Encontrei 2 tópicos com o mesmo erro porém em OS: windows 10, por isso criei este tópico.

Usei o manjaro com Plasma, durante muito tempo.
Tinha 2 vms (virtualbox) com Debian 32 bits. Uma com o mariadb e outra para estudos. Que sempre funcionaram sem problemas.

Recentemente instalei o Arch Linux, instalei o kde, instalei o virtualbox, e tudo que eu preciso, o notebook está um avião, muito show, só que agora as minhas vms não sobem mais.
Quando tento iniciar qualquer vm aparece “VT-x is not available”.

Não existe na BIOS do meu notebook a opção de habilitar ou desabilitar o suporte a virtualização, nem de atualizar a BIOS (InsydeH20 F.05 jan/2010).

Estou a dois dias procurando em todo lugar, wiki, fóruns, cheguei até em um fórum russo, não sei se tinha a solução.

Acredito que tem alguma configuração errada ou falta algum pacote.

Tentei com o virt_manager, gnome-boxes, os dois com todos os pacotes adicionais e ainda apresenta o mesmo problema.
Instalei o pacote libvirt com as dependências, iniciei o serviço e nada.

Sugestões?

Isso significa que você só pode virtualizar sistemas 32, 16 e 8 bits, então, você está tentando bootar os sistemas 32 bits que você usava ou baixou outros?

Estou usando uma iso de 32-bit, a mesma que eu usava antes. Do debian 9.5 (debian-9.5.0-i386-netinst.iso).
Baixeo a iso do debian 10.4-32-bit também, sem sucesso.

Seu processador não possui suporte para VT-X segundo site da intel:


Ja tentou utilizar o PAE/NX no virtual box em " sistema > processador > recursos estendidos" ?

Eu tentei.
Sistema de 64-bit não rola mesmo, nunca rolou e nem vai, mas de 32-bit funcionava.

Começando a pensar em montar um pc.

Eu lé em um lugar que as versão recentemente o VirtualBox deixo de oferecer suporte a x86 por software.
Se for verdade só da para rodar com processador que tenha Tecnologia de virtualização Intel® (VT-x).
Eu não verifiquei em mais fonte se isso é verdade.
Se for verdade vai rodar usando VirtualBox versão antiga.

Opa aguamole, obrigado, vou pesquisar sobre isso.

Encontrei.

https://www.virtualbox.org/wiki/Downloads


If you’re looking for the latest VirtualBox 5.2 packages, see VirtualBox 5.2 builds. Please also use version 5.2 if you still need support for 32-bit hosts, as this has been discontinued in 6.0. Version 5.2 will remain supported until July 2020.

Se você está procurando os pacotes mais recentes do VirtualBox 5.2, consulte Construções do VirtualBox 5.2. Use também a versão 5.2 se você ainda precisar de suporte para hosts de 32 bits, pois isso foi descontinuado na 6.0. A versão 5.2 permanecerá suportada até julho de 2020.

Vou procurar outras versões e aviso aqui.

Acho que pra conseguir rodar no virt-manager tem que criar a máquina virtual no domínio do qemu. O padrão é usar kvm, que precisa do hardware de virtualização.

Eu recomendo passar pra virtualização pelo qemu, vai continuar com suporte um tempão!

Nossa que noticia ruim né.
Eu comprei esta minha CPU faz pouco tempo e quando comprei nem olhei se tinha o suporte a virtualização de x86 em hardware.
Ainda bem que tinha se não eu não iria poder usar as versão recente do VB.
A versão 5.2 deve ter o bug que impede a instalação do driver da GPU virtual no sistema convidado que tenha um kernel 5.x
Mais mesmo assim tomara que a versão 5.2 seja suficiente para você.