Virtualbox/Virtmanager no Ubuntu Budgie com UEFI (Resolvido)

Virtualbox (preferência em resolver este aqui)

Já instalei tanto da Oracle, pela loja do Ubuntu e pelo terminal… todos deram errado e pelo mesmo motivo:

Kernel driver not installed (rc=-1908)
 
 The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please reinstall virtualbox-dkms package and load the kernel module by executing
 
 'modprobe vboxdrv'
 
 as root.
 
 If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system's documentation for more information.
 
 where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT. 

Sei que já existe um post aqui a respeito disso, porém não consegui solucionar seguindo ele, e para piorar, reinstalei por último pelo apt, que passou a me dar esse erro:
Captura de tela de 2020-09-26 10-06-38

Não sei se é o mesmo, mas antes apareciam duas telas, uma como esta acima e outra que infelizmente não tirei print, mas era o erro que já citei acima, Link para o mesmo post citado anteriormente.

Virtmanager.

Também baixei o virtmanager, mas como minha máquina e eu temos uma ÓTIMA relação de amizade… adivinhem… :roll_eyes:
Segui este tutorial no youtube, mas estou com alguns problemas mais simples(ou não).

  • Minhas ISO’s de sistemas operacionais estão em uma partição distinta da home, e parece que o virtmanager não tem acesso à elas, e não sei como resolver isso. Quando a minha iso estava na home, pude usa-la normalmente, mas não quero ter que ficar movendo iso por iso cada vez que eu queira usar elas… (Eu tenho “apenas” 200GB de isos baixadas, pois sofro de Distrohopping)

  • Quando consegui criar uma máquina virtual com a única iso que estava na minha home, a máquina virtual ficou muuuuito lenta, e eu sei que o hardware que disponibilizei era sufciente para ela funcionar numa boa… Não sei se isso é de fato um problema… mas se for gostaria de resolve-lo.

Bem, se fiz alguma coisa errada neste post gostaria que fosse comentada e no mais é isso, agradeço a todos, e espero que eu consiga segurar as pontas e não formate meu setup rsrsrs
Grato…

Ja tentou desativar Secure Boot na BIOS? senão for possível desativar tera que assinar esses módulos (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) manualmente que não me parece ser um processo fácil.

Minhas ISO’s de sistemas operacionais estão em uma partição distinta da home, e parece que o virtmanager não tem acesso à elas, e não sei como resolver isso. Quando a minha iso estava na home, pude usa-la normalmente, mas não quero ter que ficar movendo iso por iso cada vez que eu queira usar elas… (Eu tenho “apenas” 200GB de isos baixadas, pois sofro de Distrohopping)

Quando consegui criar uma máquina virtual com a única iso que estava na minha home, a máquina virtual ficou muuuuito lenta, e eu sei que o hardware que disponibilizei era sufciente para ela funcionar numa boa… Não sei se isso é de fato um problema… mas se for gostaria de resolve-lo.

tente mudar as permissores do diretório que se encontra as ISOs

1 Curtida

Então,

Isso é um “problema” com um módulo e o secure boot.
Solução: desativar o secure boot ou adicionar o módulo.

“VT-x is disabled”
Pelo visto seu cpu não suporta VT-x ou está desativado na BIOS.
Solução: usar o virtualbox 5 ou um outro cpu.

Tente montar a partição e veja se resolve ou tente usar o gnome-boxes.

1 Curtida

Como eu faço isso?? Eu instalei com UEFI, posso desativar numa boa? Qual módulo seria? Como instalar?

Isso está relacionado ao número de núcleos que eu posso disponibilizar para minha máquina virtual? Me recordo de ter ativado uma opção na BIOS pra usar o virtualbox… Só não lembro qual :grimacing:

Ela está montada, tentei mudar as permissões, mas não consigo saber se foi…


É assim que tem que ficar??

Vamos lá:

UEFI é diferente de secure boot, você pode desativar o secure boot a qualquer momento.

Não, é um recurso no cpu, consulte no site https://ark.intel.com se o seu cpu tem VT-X (se for Intel, é claro).

Aí fica difícil hein…

Não foi a isso que eu me referia, estava dizendo montar a partição que estão as ISO’s com o comando mount…

1 Curtida

Ah ta, compreendo, vou tentar…

Meu processador tem suporte sim… é um i5 3470
image

Bem, eu posso dar uma fuçada na web pra ver se acho o tutorial de novo, mas não acho que seja isso, pois o erro que me levou a ativar essa função na BIOS aparentemente não está ocorrendo.

Blz, vou testar e mando os resultados

Mas dês de já agradeço :+1:t2:

Então veja se na BIOS está ativado ou não.

Cara, eu consegui, montei num diretório aqui da Home…
O único problema é que: ou meu pc já está consumindo muito hardware, ou o virtmanager é horrível… eu dei 2 núcleos do meu processador e 4GB de ram pra rodar o Lubuntu… e simplesmente não deu…
Eu costumava fazer “uma seção de testes” em distros que se propunham ser leves e ver até onde ela conseguia rodar em um hardware virtual limitado pelo virtualbox… e o Lubuntu sempre se provou ser um boa distro…Acho que é o virtmanager mesmo…

Mas agradeço sua atenção, mais tarde vou fazer os próximos testes

1 Curtida

Se é pra testar distros, vai de Gnome Boxes, funciona sem dor de cabeça

1 Curtida

Nem conhecia essa alternativa, quando puder vou instalar… Senti falta da opção de configurar a coisas como rede e número de núcleos pelo que vi num vídeo do próprio Diolinux.
Mas, de qualquer forma é uma alternativa viável para testes, gostei… valeu :+1:

Mas ainda vou testar o virtualbox

Eu tbm não consegui usar o VirtualBox, aparece pra mim acho que o mesmo erro. Mas como já usava o Boxes, foi de boa. Como é pra testar distros mesmo, funciona. Ele permite configurar quanto de RAM e HD vai ser separado pra VM. E em cada VM tem mais configs, como número de núcleos da CPU, acessos etc.

Valeu à todos pessoal, agora eu estou usando o Gnome Boxes e descobri que o meu problema com o virtualbox era que estava desativado na BIOS a opção VT-x
Thanks :v:t2:

1 Curtida