Ubuntu não reconhece a rede cabeada

Olá, boa noite
Tenho um notebook com dual boot com Ubuntu 20.04 e Windows 10. Recentemente a internet cabeada parou de funcionar no Ubuntu (funciona perfeitamente no Win10) e só funciona o wi-fi.

A conexão cabeada (eth0) não aparece no ifconfig -a:

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Loopback Local)
RX packets 11627 bytes 1191835 (1.1 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 11627 bytes 1191835 (1.1 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.107 netmask 255.255.255.0 broadcast 192.168.0.255
inet6 fe80::58f4:c38b:1bf9:87ae prefixlen 64 scopeid 0x20
ether 98:83:89:d3:61:1b txqueuelen 1000 (Ethernet)
RX packets 48380 bytes 38930701 (38.9 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 33794 bytes 6176865 (6.1 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Saída ifconfig eth0 up:

eth0: ERRO ao obter marcadores da interface: Dispositivo inexistente

Saída lshw -C network

*-network DISPONÍVEL
descrição: Ethernet controller
produto: RTL810xE PCI Express Fast Ethernet controller
fabricante: Realtek Semiconductor Co., Ltd.
ID físico: 0
informações do barramento: pci@0000:01:00.0
versão: 07
largura: 64 bits
clock: 33MHz
capacidades: cap_list
configuração: latency=0
recursos: porta de E/S:e000(tamanho=256) memória:f7200000-f7200fff memória:f0000000-f0003fff
*-network
descrição: Interface sem fio
produto: QCA9377 802.11ac Wireless Network Adapter
fabricante: Qualcomm Atheros
ID físico: 0
informações do barramento: pci@0000:02:00.0
nome lógico: wlp2s0
versão: 31
serial: 98:83:89:d3:61:1b
largura: 64 bits
clock: 33MHz
capacidades: bus_master cap_list ethernet physical wireless
configuração: broadcast=yes driver=ath10k_pci driverversion=5.4.0-25-generic firmware=WLAN.TF.2.1-00021-QCARMSWP-1 ip=192.168.0.107 latency=0 link=yes multicast=yes wireless=IEEE 802.11
recursos: irq:128 memória:f7000000-f71fffff

Não achei a resolução pra isso em lugar nenhum, agradeceria a ajuda.

1 curtida

Olá!
Você conecta o cabo reinicia e nada da Ethernet subir, é isso? Se sim, poderia passar a saída do seguinte comando:

sudo dmesg | grep -i eth

A um tempo atrás um usuário aqui do forum teve uma duvida parecida, eu respondi com umas possíveis soluções caso queira dar uma olhada: Problema de rede no Linux (Internet Cabeada)

Espero ter lhe ajudado, até mais! :+1:

Esse comando retornou apenas algo relacionado ao Bluetooth:

[ 40.796756] Bluetooth: BNEP (Ethernet Emulation) ver 1.3

Eu tentei alterar o “eth” do comando para “ens”, mas nada apareceu tbm.

Porém, dei o comando
sudo dmesg | grep -i realtek
para ver se era algo relacionado à placa de rede, e aparentemente é, já que recebi a seguinte linha:

[ 1.159460] r8169 0000:01:00.0: realtek.ko not loaded, maybe it needs to be added to initramfs?

Talvez seja um problema relacionado ao driver? Ou devo tentar fazer o que ele sugero e adicionar ao initramfs? Se sim, como faço isso?

EDIT: Pesquisei o erro e achei a mesma situação no forum do arch linux [SOLVED] No ethernet interface after upgrading to linux-lts-5.4.30-1 / Kernel & Hardware / Arch Linux Forums A solução foi instalar o drive disponibilizado pela realtek no site oficial deles, o driver é para kernel 4.15, mas funcionou perfeitamente no 5.4.

Agradeço muito a sua ajuda!

1 curtida