Ubuntu 22.04 LTS - Wifi fica desconectando e conectando sozinho

Atualizei recente do Ubuntu 20.04 LTS para 22.04 LTS, o meu computador começou apresentar falha com o Wifi.
O Wifi fica desconectando e conectando sozinho.

segue os detalhes do hardware

evandro@evandro:~$ inxi -F
System:
  Host: evandro Kernel: 5.15.0-25-generic x86_64 bits: 64 Desktop: GNOME 42.0
    Distro: Ubuntu 22.04 (Jammy Jellyfish)
Machine:
  Type: Laptop System: Acer product: Aspire E1-571 v: V2.15
    serial: <superuser required>
  Mobo: Acer model: EA50_HC_CR v: Type2 - Board Version
    serial: <superuser required> UEFI: Insyde v: 2.15 date: 03/11/2013
Battery:
  ID-1: BAT1 charge: 23.2 Wh (100.0%) condition: 23.2/48.8 Wh (47.5%)
CPU:
  Info: dual core model: Intel Core i5-3230M bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 1256 min/max: 1200/3200 cores: 1: 1197 2: 1259 3: 1277
    4: 1291
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: Sunplus Innovation HD WebCam type: USB driver: uvcvideo
  Display: wayland server: X.Org v: 1.22.1.1 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: modesetting unloaded: fbdev,vesa
    gpu: i915 resolution: 1: 1360x768~60Hz 2: 1024x768~75Hz
  OpenGL: renderer: Mesa Intel HD Graphics 4000 (IVB GT2)
    v: 4.2 Mesa 22.0.1
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.15.0-25-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Broadcom NetLink BCM57785 Gigabit Ethernet PCIe driver: tg3
  IF: enp2s0f0 state: down mac: 20:89:84:0b:99:86
  Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k
  IF: wlp3s0 state: up mac: 2c:d0:5a:d2:e1:61
Drives:
  Local Storage: total: 465.76 GiB used: 143.43 GiB (30.8%)
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-9WS142 size: 465.76 GiB
Partition:
  ID-1: / size: 191.1 GiB used: 143.25 GiB (75.0%) fs: ext4 dev: /dev/sda7
  ID-2: /boot/efi size: 96 MiB used: 30.8 MiB (32.1%) fs: vfat
    dev: /dev/sda2
Swap:
  ID-1: swap-1 type: partition size: 5.72 GiB used: 150.4 MiB (2.6%)
    dev: /dev/sda6
Sensors:
  System Temperatures: cpu: 72.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 300 Uptime: 44m Memory: 5.62 GiB used: 4.34 GiB (77.2%)
  Shell: Bash inxi: 3.3.13

veja se ajuda: How to fix Qualcom Atheros AR9485 problem under Ubuntu 14.04 LTS - YouTube

Olá a todos

Não consegui resolver completamente, porem melhorou bem o comportamento do Wifi.
Atualizei o Ubuntu e alterei o parâmetro abaixo de 3 para 2

Adicione o parâmetro na linha do kernel no grub ou no modprobe

ps_enable=1

https://wiki.archlinux.org/title/Network_configuration_(Português)/Wireless_(Português)#Economia_de_energia_2