Ubuntu 20.04 + Nvidia 440 + Monitor secundário: não funciona na GeForce 1050ti

Estou tentando utilizar o monitor secundário mas sem sucesso.

Não enfrento screen tearing, então não cheguei a utilzar os procedimentos a seguir:

nano /etc/modprobe.d/nvidia-drm-nomodeset.conf

then >

options nvidia-drm modeset=1

Contudo, eu apliquei esse código aqui:

sudo nano /etc/gdm3/custom.conf

then descomente a linha wayland

[daemon] # Uncoment the line below to force the login screen to use Xorg WaylandEnable=false

Testei, mas nenhum sinal de vida também. Como reabilitar o monitor secundário? Ah, e o pessoal do Pop OS também está sofrendo este problema?

Notebook:

  • Dell G7 7588
  • GeForce 1050 ti
1 Curtida

Eu acabei de instalar o 20.04 no meu notebook, um Dell G3 e o mesmo problema aconteceu comigo.
Tentei resolver usando o nvidia-xconfig ( sudo nvidia-xconfig ) para gerar o arquivo xorg.conf, porém no meu caso após o boot veio a falsa impressão que ia funcionar pois as duas telas apresentaram o logo do Ubuntu carregando, só que depois apenas o monitor “externo” ficou ativo. A tela do notebook ficou desativada.

Como eu tinha testado o Fedora 32 recentemente e havia tido o mesmo problema de não ativar o monitor externo com o driver 440, fiz o mesmo procedimento que funcionou por lá, retornei para o driver da série 390.

Escolhi o driver pelo gerenciador e após a instalação do mesmo, apaguei os arquivos xorg.conf que o nvidia-xconfig gerou e após o boot os dois monitores estão ativos.

Ontem cheguei a testar o Opensuse Leap 15.1 nesta mesma partição onde esta o Ubuntu 20.04, nele o driver da série 440 funcionou, instalei seguindo as orientações da wiki da Opensuse.

2 Curtidas

Obrigado pela contribuição. Estarei buscando alguma solução com o driver 440 pois preciso do mais recente.

1 Curtida

Veja se está outra solução daqui do fórum lhe atende. Já vi q vc fez essa tb

1 Curtida

Não é recomendado utilizar Wayland com o drive proprietário da Nvidia no momento, existem diversos problemas de compatibilidade. Eu uso Xorg aqui no meu micro com dois monitores (já coloquei até 3 só para ver se funcionava) sem problema algum.

Essa discussão aqui no reddit explica um pouco sobre os motivos para esse problema entre Nvidia e Wayland.

:vulcan_salute:

1 Curtida

Cara, estou com o mesmo problema. Se vc achar uma solução posta aqui. Se eu conseguir algo eu coloco aqui tb.

1 Curtida

Galera, tô ficando maluco aqui já. Tenho um DELL G7 7588 tbm e não consigo me livrar do tearing. Atualmente utilizo 2 monitores externos. Não ligo ora versão do driver nvidia nem nada. Só queria não ter o tearing e ter a opção de desligar a placa de vídeo as vezes. Alguém pode ajudar???