Ubuntu 20.04 LTS xorg.conf não funciona com meu monitor lg

Meu PC: Core 2 Quad Q6600, XFX Geforce 8600GT 512 MB VRAM, 8 GB de RAM, HD 400 GB, Ubuntu 20.04 LTS.

O principal item crucial de toda a configuração é o monitor utilizado: LG modelo 22LG30R.

Estou usando a entrada do monitor de “vídeo componente”, e isso é o que está sendo usado nas configurações do Ubuntu, e está sendo reconhecido normalmente, mas a resolução máxima disponível no Ubuntu é 1024x768.

O driver nvidia 340 foi instalado e automaticamente durante a instalação do ubuntu. xorg.conf padrão gerado por nvidia-settings:

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “Module”
Load “dbe”
Load “extmod”
Load “type1”
Load “freetype”
Load “glx”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”

# HorizSync source: builtin, VertRefresh source: builtin
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "TV-0"
HorizSync       15.73 - 67.5
VertRefresh     59.94 - 60.0
Option         "DPMS"

EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 8600 GT”
EndSection

Section “Screen”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "TV-0"
Option         "metamodes" "1024x768 +0+0"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24
EndSubSection

EndSection


xorg.conf alterado por mim:

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “Module”
Load “dbe”
Load “extmod”
Load “type1”
Load “freetype”
Load “glx”
EndSection

Section “InputDevice”

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”

# HorizSync source: builtin, VertRefresh source: builtin
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "TV-0"
HorizSync       15.0 - 67.0
VertRefresh     59.0 - 60.0
Modeline       "1280x1024" 114.98 1280 1312 1744 1776 1024 1045 1055 1076
Option         "DPMS"

EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 8600 GT”
Option “ModeValidation” “AllowNonEdidModes”
EndSection

Section “Screen”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "TV-0"
Option         "metamodes" "1280x1024 +0+0"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24
    Modes      "1280x1024"
EndSubSection

EndSection


Mas nas configurações do ubuntu, no item de monitor, e nas configurações da nvidia, a resolução máxima é 1024x768.

Desejo usar as resoluções 1280x1024 e 1680x1050 e 1920x1080.

De acordo com o manual do monitor, essas resoluções são possíveis usando “vídeo componente”, página 7:

https://drive.google.com/file/d/1boOYV-JkVKhGiD8B3aX0BMR0ci5KDb7L/view?usp=sharing

Acredito que vai ajudar um pouco na minha dúvida:

Usando geradores de modeline gerais, a modeline é gerada com um clock de pixel acima do aceito pelo monitor.

O único gerador que aceita pixel clock é umc (universal modeline creator).

Algum modeline usando o programa umc:

->1280x1024x59.35 @ 63.084kHz
Modeline “1280x1024x59.35” 108.000000 1280 1360 1496 1712 1024 1028 1032 1063 -HSync +VSync

->1680x1050x60.29 @ 65.714kHz
Modeline “1680x1050x60.29” 148.250000 1680 1784 1968 2256 1050 1054 1058 1090 -HSync +VSync

->1920x1080x51.98 @ 58.008kHz
Modeline “1920x1080x51.98” 148.500000 1920 2032 2240 2560 1080 1084 1088 1116 -HSync +VSync


Obs .: Utilizando Windows 7 e Windows 10 no mesmo PC com a mesma configuração,
e também utilizando vídeo componente, no mesmo monitor, são aceitas todas as resoluções:
640x480, 800x600, 1024x768, 1280x1024, 1680x1050, 1920x1080.


Antes de criar xorg.conf e tambem de altera-lo, eu nao tinha xorg.conf no sistema, e o problema era o mesmo.

Outra observacao, é que não funcionam:

  1. xrandr, não deixa criar modos novos de video.
  2. xorg.conf, não surte efeito algum, mesmo apos o boot.

O ubuntu já foi reinstalado 4 vezes ( 20.04 LTS ) neste mesmo PC, do zero, com opções
completas de instalação, mais opção de fazer download de atualizacoes durante a
instalação. Acredito estar bem completo, com libs (.h) instaladas, gcc etc.

Complementando:

A saida de inxi -G: indica driver nvidia 340.108, placa de video Geforce 8600GT, e X.org 1.20.8.

Já tentei colocar o arquivo xorg.conf em /etc/X11, em /etc/X11/xorg.conf.d, em /usr/share/X11/xorg.conf.d, neste ultimo subdiretorio eu tbem criei um arquivo de nome 20-nvidia.conf que é uma copia exata de xorg.conf

Mas nenhum configurador de resolucao reconhece mais que 1024x768, nem em config Monitores do Ubuntu, e nem em nvidia-settings.

Log do Xorg:

https://drive.google.com/file/d/1zshZwTaydxlnIg2Slm1Zc-XhWCcJvOrP/view?usp=sharing

Olha, dando uma olhada no site da NVIDIA, o driver 340.108 ta sem update desde 23.12.2019, e creio q a NVIDIA não dará mais suporte pra essa linha de GPU. O que vc pode fazer é tentar usar o driver open source pra NVIDIA, o Nouveau e vê se as resoluções aparecem para você. Infelizmente NVIDIA é assim mesmo brow.

Obrigado pela ajuda, outra tentativa de tentar encontrar o erro: (arquivos modificados e atualizados)
xorg.conf:

Section “ServerLayout”
Identifier “Layout0”
Screen “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “Module”
Load “dbe”
Load “extmod”
Load “type1”
Load “freetype”
Load “glx”
EndSection

Section “InputDevice”
# generated from default
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “Monitor”
# HorizSync source: builtin, VertRefresh source: builtin
Identifier “Monitor0”
VendorName “LG”
ModelName “TV-0”
HorizSync 15.0 - 67.0
VertRefresh 59.0 - 60.0

#1280x1024 59.79 Hz (CVT 1.31M4-R) hsync: 63.02 kHz; pclk: 90.75 MHz
Modeline “1280x1024” 90.75 1280 1328 1360 1440 1024 1027 1034 1054 +hsync -vsync
#1680x1050 59.88 Hz (CVT 1.76MA-R) hsync: 64.67 kHz; pclk: 119.00 MHz
Modeline “1680x1050” 119.00 1680 1728 1760 1840 1050 1053 1059 1080 +hsync -vsync
#1920x1080 59.93 Hz (CVT 2.07M9-R) hsync: 66.59 kHz; pclk: 138.50 MHz
Modeline “1920x1080” 138.50 1920 1968 2000 2080 1080 1083 1088 1111 +hsync -vsync
Option “DPMS”
Option “PreferredMode” “1280x1024”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
BusID “PCI:1:0:0”
VendorName “NVIDIA Corporation”
BoardName “GeForce 8600 GT”
Option “UseEDIDFreqs” “false”
Option “NoEDIDModes” “true”
Option “ModeValidation” “TV-0: NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowNon60HzDFPModes, AllowNonEdidModes”
Option “IgnoreEDID” “true”
Option “IgnoreEDIDChecksum” “TV-0”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
Option “HorizSync” “TV-0:15-67”
Option “VertSync” “TV-0:59-60”
DefaultDepth 24
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “TV-0”
Option “TwinView” “0”
Option “TwinViewXineramaInfoOrder” “TV-0”
Option “Metamodes” “1280x1024”
Option “UseEDID” “False”
SubSection “Display”
Depth 24
Modes “1920x1080” “1680x1050” “1280x1024” “1024x768” “800x600” “640x480”
ViewPort 0 0
Visual “TrueColor”
EndSubSection
EndSection


log do Xorg:
[ 42.344] (II) Loading sub module “ramdac”
[ 42.344] (II) LoadModule: “ramdac”
[ 42.344] (II) Module “ramdac” already built-in
[ 42.380] () NVIDIA(0): Depth 24, (–) framebuffer bpp 32
[ 42.380] (==) NVIDIA(0): RGB weight 888
[ 42.380] (
) NVIDIA(0): Default visual is TrueColor
[ 42.380] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 42.407] () NVIDIA(0): Option “Stereo” “0”
[ 42.407] (
) NVIDIA(0): Option “UseEdidFreqs” “false”
[ 42.407] () NVIDIA(0): Option “nvidiaXineramaInfoOrder” “TV-0”
[ 42.420] (
) NVIDIA(0): Option “SLI” “Off”
[ 42.420] () NVIDIA(0): Option “MultiGPU” “Off”
[ 42.420] (
) NVIDIA(0): Option “AddARGBGLXVisuals” “True”
[ 42.420] () NVIDIA(0): Option “ModeValidation” “AllowNonEdidModes”
[ 42.420] (
) NVIDIA(0): Option “BaseMosaic” “off”
[ 42.420] () NVIDIA(0): Stereo disabled by request
[ 42.420] (
) NVIDIA(0): NVIDIA SLI disabled.
[ 42.421] () NVIDIA(0): NVIDIA Multi-GPU disabled.
[ 42.421] (
) NVIDIA(0): Option “IgnoreEDIDChecksum” “TV-0”
[ 42.421] () NVIDIA(0): Enabling 2D acceleration
[ 42.868] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
[ 42.886] (II) NVIDIA(0): NVIDIA GPU GeForce 8600 GT (G84) at PCI:1:0:0 (GPU-0)
[ 42.886] (–) NVIDIA(0): Memory: 524288 kBytes
[ 42.886] (–) NVIDIA(0): VideoBIOS: 60.84.43.00.14
[ 42.886] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 42.892] (–) NVIDIA(0): Valid display device(s) on GeForce 8600 GT at PCI:1:0:0
[ 42.892] (–) NVIDIA(0): CRT-0
[ 42.892] (–) NVIDIA(0): CRT-1
[ 42.892] (–) NVIDIA(0): NVIDIA TV Encoder (TV-0) (boot, connected)
[ 42.892] (–) NVIDIA(0): DFP-0
[ 42.892] (–) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[ 42.892] (–) NVIDIA(GPU-0): CRT-1: 480.0 MHz maximum pixel clock
[ 42.892] (–) NVIDIA(GPU-0): NVIDIA TV Encoder (TV-0): 400.0 MHz maximum pixel clock
[ 42.892] (–) NVIDIA(0): DFP-0: Internal TMDS
[ 42.892] (–) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[ 42.892] (
) NVIDIA(0): Not using HorizSync/VertRefresh ranges from the EDID for
[ 42.892] () NVIDIA(0): display device NVIDIA TV Encoder (TV-0) (Using EDID
[ 42.892] (
) NVIDIA(0): frequencies has been disabled on all display devices.)
[ 42.892] (II) NVIDIA(GPU-0): Mode Validation Overrides for NVIDIA TV Encoder (TV-0):
[ 42.892] (II) NVIDIA(GPU-0): AllowNonEdidModes
[ 42.894] (WW) NVIDIA(0): No valid modes for “TV-0:1920x1080”; removing.
[ 42.894] (WW) NVIDIA(0): No valid modes for “TV-0:1680x1050”; removing.
[ 42.894] (WW) NVIDIA(0): No valid modes for “TV-0:1280x1024”; removing.
[ 42.895] (II) NVIDIA(0): Validated MetaModes:
[ 42.895] (II) NVIDIA(0): “TV-0:1024x768”
[ 42.895] (II) NVIDIA(0): “TV-0:800x600”
[ 42.895] (II) NVIDIA(0): “TV-0:640x480”
[ 42.895] (II) NVIDIA(0): Virtual screen size determined to be 1024 x 768
[ 42.896] (WW) NVIDIA(0): Unable to support custom viewPortOut 1024 x 576 +0 +96
[ 42.923] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[ 42.923] () NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
[ 42.923] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[ 42.932] (II) NVIDIA(0): Setting mode “TV-0:1024x768”
[ 43.190] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 43.191] (==) NVIDIA(0): Backing store enabled
[ 43.191] (==) NVIDIA(0): Silken mouse enabled
[ 43.235] (
) NVIDIA(0): DPMS enabled
[ 43.236] (WW) NVIDIA(0): Option “IgnoreEDID” is not used
[ 43.236] (WW) NVIDIA(0): Option “PreferredMode” is not used

Complementando:

Desinstalei driver nvidia e instalei nouveau:

  1. CTRL+ALT+F3 (F1 nao funciona, tela preta cursor piscando)

  2. sudo su

  3. service gdm3 stop

  4. CTRL+ALT+F3 (denovo)

  5. apt-get autoremove --purge nvidia-*

  6. apt-get install xserver-xorg-video-nouveau

  7. startx

Obs.: sempre que entro no terminal desse jeito, start gdm3 nao funciona

Resultado: somente resolucao 640x480, mesmo usando meu xorg.conf e alterando em /etc/default/grub (GRUB_GFXMODE=1024x768), ou mesmo 1280x1024, ele insiste em 640x480

Conclusao: Voltei pro driver nvidia, que antes foi instalado automatico durante a instalacao ubuntu, agora fiz o processo manual, parecido ao mostrado acima

  1. CTRL+ALT+F3 (F1 nao funciona, tela preta cursor piscando)

  2. sudo su

  3. service gdm3 stop

  4. CTRL+ALT+F3 (denovo)

  5. apt-get remove --purge xserver-xorg-video-nouveau

  6. chmod +x ./NVIDIA…340.run

  7. ./NVIDIA…340.run

E ficou igual ao original, resolucao ate 1024x768


Outras perguntas:

Não existe mais o XConfigurator? Qual seu substituto pro ubuntu 20.04?

Nova tentativa:

Section “Module”
Load “dbe”
Load “extmod”
Load “type1”
Load “freetype”
Load “glx”
EndSection

Section “InputDevice”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/psaux”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “LG”
ModelName “TV-0”
HorizSync 15.0 - 67.0
VertRefresh 59.0 - 60.0
Modeline “1280x1024” 108.000000 1280 1360 1496 1712 1024 1028 1032 1063 -HSync +VSync
Modeline “1680x1050” 148.250000 1680 1784 1968 2256 1050 1054 1058 1090 -HSync +VSync
Modeline “1920x1080” 148.500000 1920 2032 2240 2560 1080 1084 1088 1116 -HSync +VSync
Option “DPMS”
#Option “PreferredMode” “1280x1024”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
BusID “PCI:1:0:0”
VendorName “NVIDIA Corporation”
BoardName “GeForce 8600 GT”
Option “RegistryDwords” “RMDisableRenderToSysmem=1”
#Option “DynamicTwinView” “false”
Option “UseEDIDFreqs” “false”
Option “NoEDIDModes” “true”
#Option “ModeValidation” “TV-0: NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowNonEdidModes”
Option “IgnoreEDID” “true”
Option “IgnoreEDIDChecksum” “TV-0”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
Option “UseDisplayDevice” “TV”
Option “TVOutFormat” “COMPONENT”
Option “TVStandard” “HD1080p”
#Option “TVOverScan” “0.80”
DefaultDepth 24
Option “UseEDID” “False”
SubSection “Display”
Depth 24
Modes “1920x1080” “1280x1024” “1024x768” “800x600” “640x480”
ViewPort 0 0
Visual “TrueColor”
EndSubSection
EndSection

Section “Extensions”
Option “Composite” “Disable”
EndSection

Resultado:

Antes de entrar na tela de login, a tela fica piscando com uma imagem verde, e apos algumas piscadas, volta pro prompt com um cursor piscando, tendo que pressionar CTRL + ALT + F3, para ir para o console.

trecho Xorg.0.log

[ 74.547] (II) Module “ramdac” already built-in
[ 74.549] () NVIDIA(0): Depth 24, (–) framebuffer bpp 32
[ 74.550] (==) NVIDIA(0): RGB weight 888
[ 74.550] (
) NVIDIA(0): Default visual is TrueColor
[ 74.550] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 74.550] () NVIDIA(0): Option “TVStandard” “HD1080p”
[ 74.550] (
) NVIDIA(0): Option “TVOutFormat” “COMPONENT”
[ 74.550] () NVIDIA(0): Option “UseEdidFreqs” “false”
[ 74.550] (
) NVIDIA(0): Forcing COMPONENT output
[ 74.550] () NVIDIA(0): TV Standard string: “HD1080p”
[ 74.550] (
) NVIDIA(0): Option “IgnoreEDIDChecksum” “TV-0”
[ 74.550] () NVIDIA(0): Option “UseDisplayDevice” “TV”
[ 74.550] (
) NVIDIA(0): Option “RegistryDwords” “RMDisableRenderToSysmem=1”
[ 74.550] () NVIDIA(0): Enabling 2D acceleration
[ 74.898] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
[ 74.900] (II) NVIDIA(0): NVIDIA GPU GeForce 8600 GT (G84) at PCI:1:0:0 (GPU-0)
[ 74.900] (–) NVIDIA(0): Memory: 524288 kBytes
[ 74.900] (–) NVIDIA(0): VideoBIOS: 60.84.43.00.14
[ 74.900] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 74.904] (–) NVIDIA(0): Valid display device(s) on GeForce 8600 GT at PCI:1:0:0
[ 74.904] (–) NVIDIA(0): CRT-0
[ 74.904] (–) NVIDIA(0): CRT-1
[ 74.904] (–) NVIDIA(0): NVIDIA TV Encoder (TV-0) (boot, connected)
[ 74.904] (–) NVIDIA(0): DFP-0
[ 74.904] (–) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[ 74.904] (–) NVIDIA(GPU-0): CRT-1: 480.0 MHz maximum pixel clock
[ 74.904] (–) NVIDIA(GPU-0): NVIDIA TV Encoder (TV-0): 400.0 MHz maximum pixel clock
[ 74.904] (–) NVIDIA(0): DFP-0: Internal TMDS
[ 74.904] (–) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[ 74.904] (
) NVIDIA(0): Not using HorizSync/VertRefresh ranges from the EDID for
[ 74.904] () NVIDIA(0): display device NVIDIA TV Encoder (TV-0) (Using EDID
[ 74.904] (
) NVIDIA(0): frequencies has been disabled on all display devices.)
[ 74.907] (II) NVIDIA(0): Validated MetaModes:
[ 74.907] (II) NVIDIA(0): “TV-0:1920x1080”
[ 74.907] (II) NVIDIA(0): “TV-0:1280x1024”
[ 74.907] (II) NVIDIA(0): “TV-0:1024x768”
[ 74.907] (II) NVIDIA(0): “TV-0:800x600”
[ 74.907] (II) NVIDIA(0): “TV-0:640x480”
[ 74.907] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[ 74.936] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[ 74.936] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[ 74.945] (II) NVIDIA(0): Setting mode “TV-0:1920x1080”
[ 75.081] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 75.081] (==) NVIDIA(0): Backing store disabled
[ 75.081] (==) NVIDIA(0): Silken mouse enabled
[ 75.082] (**) NVIDIA(0): DPMS enabled
[ 75.082] (WW) NVIDIA(0): Option “DynamicTwinView” is not used
[ 75.082] (WW) NVIDIA(0): Option “NoEDIDModes” is not used
[ 75.082] (WW) NVIDIA(0): Option “IgnoreEDID” is not used
[ 75.082] (WW) NVIDIA(0): Option “TVOverScan” is not used