Ubuntu 18.04 não reconhece GoPro Hero6 Black

Bom dia pessoal.

Estou tentando transferir meus arquivos da GoPro via USB usando Ubuntu, mas a câmera não aparece para eu poder acessa-la (como aparece um pendrive por exemplo).

Com a câmera conectada, executo o lsusb, vejo uma saída em identificação, se retiro a câmera da usb essa saída não aparece.

Com a câmera conectada, executo o lsblk e vejo apenas meu disco /dev/sda. Se eu retiro a câmera da usb e coloco o microSD no pc e executo o lsblk vejo meu disco /dev/sda e /dev/sdb (desta forma eu consigo acessar o conteúdo do cartão e ele aparece como um pendrive).

Curiosidade: tenho virutalbox instalado para testar as distros e ontem eu estava usando o Linux Mint na vm e vi que ele (Mint) reconheceu a câmera (como aparece um pendrive) mas não consegui acessar o conteúdo, o gerenciador de arquivos parece que trava.

Informações Adicionais

Pelo que pesquisei pela internet, vi que a gphoto2 é quem tem o suporte para as câmeras, o gphoto2 que vem instalado no Ubuntu tem suporte para a GoPro Hero 6 Black (gphoto2 --list-cameras). Mesmo sendo suportado eu não consegui acessa-la e acabai instalando o gphoto2 do Ubuntu 19.10, mesmo nessa versão mais nova não consegui acessar a câmera usando o usb (e agora não sei como desinstalar).

Cheguei a instalar gmtp, exfat-fuse e outras coisas que fui lendo, mas nada funcionou. Resumindo desinstalei tudo (usei apt para instalar e remover e tbm usei deborphan para limpar o sistema).

Se eu conecto a câmera em um Windows eu consigo acessar o conteúdo pelo usb (Acho que vou acabar colocando um Windows numa VM e fazer a transferência por pastas compartilhadas rsss…).

Já tentou o pacote mtp-tools?

Boa tarde Raul, obrigado pela ajuda.

O pacote esta instalado, segue outros instalados tbm

mtp-tools/bionic,now 1.1.13-1 amd64 [installed]
gmtp/bionic,now 1.3.10-1 amd64 [installed]
gphoto2/bionic,now 2.5.15-2 amd64 [installed]
gphotofs/bionic,now 0.5-5 amd64 [installed]
python3-gphoto2/bionic,now 1.8.2-1 amd64 [installed]
python3-gphoto2cffi/bionic,now 0.3~a1-1build1 amd64 [installed]
libgphoto2-6/bionic,now 2.5.16-2 amd64 [installed]
gvfs/bionic-updates,bionic-security,now 1.36.1-0ubuntu1.3.3 amd64 [installed]
gvfs-backends/bionic-updates,bionic-security,now 1.36.1-0ubuntu1.3.3 amd64 [installed]
gvfs-fuse/bionic-updates,bionic-security,now 1.36.1-0ubuntu1.3.3 amd64 [installed]
exfat-fuse/bionic,now 1.2.8-1 amd64 [installed]

Veja que agora a camara aparece no nautilus, mas da esse erro, acabou meu horario almoço, vou pesquisar por ele depois.

Captura de tela de 2019-12-16 12-43-52

É, fiquei sem ideias… :confused:

Já pesquisou no AskUbuntu?

Ja, no askubuntu.com e no ubuntuforum-br.org, ambos sem respostas.

Ontem instalei varios outros pacotes relacionados a gmtp, fuse, gphoto, sem sucesso.

1 Curtida

Já testou o GUVC View?
Apesar que eu acho que ele só daria suporte a ajustar configurações da captura.

:vulcan_salute:

Bom dia pessoal.

Ontem fiquei fazendo testes e vejam os resultados.

Desinstalei todos os pacotes citados no inicio desta conversa (acabei descobrindo que o nautilus utiliza alguns pacotes do gvfs).

Sem nenhum dos pacotes acima, se eu conectar a camera no usb a camera fica dando loop (na tela da camera, como se ela estivesse conectada e sendo removida). No meio dos testes acabei reinicinando o pc com a camera conectada no usb, qdo o pc inicia a camera aparece conectada, eu consigo clicar nela, ela demora para responder e abre, mas sem conteudo (tenho videos no cartao que esta na camera), mas se eu retirar a camera do usb e conectar novamente ela voltar a dar loop.