Ubuntu 18.04.5 LTS (Minimal) - Demorando muito para Iniciar!

Instação Minimal demorando para inicializar

Eu fiz a instalação da distribuição (ubuntu-minimal 18.04.5 LTS) esperando que conseguisse inicializar o sistema de forma mais rápida do que a antiga distribuição que eu estava utilizando (popOS 20.04). O fato é que continua a mesma coisa!

Rodei os seguintes comandos:

systemd-analyze time =

Startup finished in 38.127s (kernel) + 16.158s (userspace) = 54.286s
graphical.target reached after 16.152s in userspace

systemd-analyze critical-chain =

graphical.target @16.152s
└─gdm.service @16.008s +143ms
  └─systemd-user-sessions.service @16.004s +3ms
    └─network.target @16.003s
      └─NetworkManager.service @13.870s +2.133s
        └─dbus.service @13.708s
          └─basic.target @13.704s
            └─sockets.target @13.704s
              └─uuidd.socket @13.704s
                └─sysinit.target @13.670s
                  └─systemd-timesyncd.service @13.533s +136ms
                    └─systemd-tmpfiles-setup.service @13.361s +103ms
                      └─systemd-journal-flush.service @4.403s +8.956s
                        └─systemd-remount-fs.service @2.986s +533ms
                          └─systemd-fsck-root.service @2.308s +677ms
                            └─systemd-journald.socket @2.270s
                              └─system.slice @2.269s

systemd-analyze blame =

      9.559s dev-sda1.device
      8.956s systemd-journal-flush.service
      6.498s keyboard-setup.service
      6.449s systemd-tmpfiles-setup-dev.service
      4.683s swapfile.swap
      2.133s NetworkManager.service
      1.641s networkd-dispatcher.service
      1.304s grub-common.service
      1.186s wpa_supplicant.service
      1.143s udisks2.service

Eu segui os passos de instalação da ISO de acordo com o vídeo do DIO. Apenas na parte de instalar alguma interface gráfica que eu não segui os mesmos passos que o do vídeo, mas sim de outro vídeo do mesmo.

https://youtu.be/zIbJh7xtCGI ( Instalação ubuntu minimal )
https://youtu.be/bZr_4dhT2fs ( Eu fiz um “ArchBuntu”? - Um GNOME MEGA MINIMAL!!! )

Pelo fato de ser uma instalação minima achei que o sistema iria carregar mais rápido, mas continua a mesma coisa, existe alguma coisa que eu poderia fazer?

Olá @wesleygessner seja bem-vindo :wave:

Aparentemente possa ser limite de hardware, qual seria os detalhes de hardware que você está instalando o OS?

Se estiver com algum HD Externo conectado ao USB, remova-o, reinicie, e veja se melhora o tempo.

Meu Setup do BIOS estava com uma configuração que realizava leitura no HD Externo, e após alterar as configurações, meu Startup reduziu de 36 para 19 segundos.

Olá, @RuKsu segue os detalhes:

Processador: Intel i5 650
Memória Ram: 8 GB
Placa de Vídeo: NVDIA Geforce GTX 660

Não estou com HD externo, mas obrigado!

O CPU e GPU são competentes, talvez o HDD estaria limitando os procedimentos. Mas antes de culpar o HDD teriamos de analisar logs para indentificar oque poderia estar deixando o sistema lento ao iniciar. O detalhe é que eu sou leigo nessa parte, teria de usar a ferramenta journalctl para verificar logs de inicialização. Estou pesquisando aqui no fórum e em outras fontes de informação e então te passo uma informação. Tem uma sugestão simples de quando o sistema estiver ligando depois que passar a tela do BIOS, aperta o esc ou o delete onde aparece o logo do Ubuntu, para ver como ele esta carrregando as informações, se da para notar algum erro. Caso não conseguir poderiamos tentar alterar uns parâmetros no Grub, splash e quiet.

2 curtidas