Tomb Raider2013 /Doom 2016 Linux Mint

Boa tarde amigos, após a instalação do Tomb Raider 2013 (nativo) ele simplesmente não executa.
Outro caso curioso é o com o jogo Doom. Ele não roda por nada com o Vulkan, somente com o OpenGL 4.5. Usei o Proton 5.0.9 e ele simplesmente abre o console de crash ao mudar para a API vulkan. Tem alguma dica do que possa ser feito?
(Linux Mint 19.3, Mesa 19.2.8, Kernel 5.0, RX 580, driver amd gpu)
Obs: na minha máquina rodando ubuntu 20.04 o tomb raider abre perfeitamente “out of the box”

1 Curtida

Olá @JG22 tudo beleza?

Dá uma verificada com calma nos drivers que estão instalados, apesar do Mint ser famoso por facilitar a instalação de drivers, nos meus testes com ele foi onde obtive os piores resultados.

Dá uma olhada nesta matéria aqui do blog, talvez te ajude de alguma forma.

:vulcan_salute:

2 Curtidas

Respondendo sua pergunta: sim. Estou bem, caro Watson. E com você?
Obrigado pela ajuda, porém não adiantou muito (infelizmente). Estou usando driver “AmdGPU” (vulgo o que já vem após instalar o SO). Além dessa matéria que você mandou, dei uma pesquisada nesta https://diolinux.com.br/2019/09/tudo-sobre-drivers-amd-no-linux.html para me situar melhor.

1 Curtida

O Doom 2016 está com um bug na versão vulkan mesmo, já foi reportado ao proton/mesa…, apenas em opengl (que roda bem o suficiente)

1 Curtida

Menos um problema então. Obrigado, amigo :slight_smile:
Agora só me resta mesmo descobrir o porque o Tomb Raider não esta iniciando mesmo…

é o TR 2013 está rodando de boa aqui (mesa 20.1.1)

1 Curtida

Creio que é um problema com o driver mesa (que ainda esta atrasado, se comparar com o ultimo release). Esperarei até o final deste mês pelo lançamento do Mint 20 e fazer um teste…

No meu Ubuntu 16.04.6 o TombRider roda.
Executa o TombRider pelo terminal e coloca o resultado aque:
$ steam steam://rungameid/203160

1 Curtida

Como falei com o amigo a cima, tudo indica que seja um problema do driver mesa (possivelmente, mesmo sendo difícil isso, do kernel). Esperarei mesmo pelo mint 20 e tabem ficar na torcida do wine 5.0.1 ou superior entrar na loja de aplicativos, visto que não estará baseado no Ubuntu 18.04…
DE qualquer forma obrigado pela dica, mano

Eu não uso mesa o OpenGL e Vulkan é fornecido pelo driver da Nvidia.
O mesa 18 só esta instalado porque é dependência de vários software incluindo o xorg

A questão é que minha GPU é da AMD (RX 580), por isso sou “refém” dos drivers mesa