Tela escura; Ajuste de brilho não funciona

Formatei meu notebook Lenovo ideaPad z400 para experimentar o Ubuntu, mas, assim como no windows, estou com problemas com o brilho da tela. Existem muitas formas de arrumar esse problema pelo windows, mas no ubuntu eu fiquei totalmente perdido…

Não sou bom com o terminal, mas encontrei uma solução para o problema neste fórum: 14.04 - Lenovo Z400 low brightness video driver problem - Ask Ubuntu. Porém não tive sucesso, acredito que por ser uma versão mais antiga do ubuntu.
Algum iluminado poderia me ajudar, por favor? (ou amaldiçoado, caso tenha comprado um notebook desse)

Qual o problema encontrou quando tentou a solução do link?

1 curtida

Ao colocar a primeira linha da solução, ao invés do terminal retornar:
/sys/class/backlight/ideapad/brightness/sys/class/backlight/intel_backlight/brightness

Ele retorna apenas: ls /sys/class/backlight/*/brightness
E os demais comandos não são aceitos.
Uma duvida que tive, é em relação ao *, eu devo substituir ele por alguma coisa? Sou meio novo nesse negócio…

Nem sequer uma mensagem de erro, como:
ls: não foi possível acessar '/sys/class/backlight/*/brightness': Arquivo ou diretório inexistente
Talvez eu esteja te subestimando, mas faltou um Enter para confirmar o comando?

Não é necessário. A resposta é justamente o que o ls achou tentando substituir o * por qualquer coisa.

1 curtida

Qual o problema com o brilho…

Mais informação seria interessante para ter uma noção do erro

1 curtida

O diretório pode variar de nome conforme versão do kernel e módulos carregados.

O ideal é vc ir até o diretório e ver quais são os subdirertórios.

cd /sys/class/backlight
ls

Daí veja qual o diretório, e continue o procedimento. Vou assumir que apareceu intel_eDP1

cd intel_eDP1
cat max_brightness

Daí veja o valor que aparece e executa o comando:

echo XX | sudo tee brightness

Interessante é que se funcionar desse jeito é porque deveria funcionar como aplicativo da bandeja da interface gráfica.

2 curtidas

Aparece, com os comandos seguintes essa mensagem de erro sim.
E dei enter sim kkkk.

O problema é um pouco mais especifico, pois acredito que tenha a ver com o modelo do notebook. Eu ja tinha esse problema no windows, porem sabia resolve-lo nele. Bastava que eu alterasse os valores do registro ‘‘FeatureTestControl’’, no regedit, para FFFF, que estava resolvido. Mas no linux nao sei se existe algo do tipo…
Mas vou tentar o que diz no site, obrigado!

Esse método não funcionou, o aplicativo da bandeja não responde a mudanças… Nem outros aplicativos de controle de brilho que instalei. Mas obrigado desde ja!

Você conseguiu resolver? Eu estou tendo o mesmo problema e não consigo de jeito nenhum resolver.

O meu notebook é um Lenovo Ideapad S145 i7 e a minha distro é a Pop!_OS 20.04 LTS. Eu uso o sistema em modo híbrido (Intel + Nvidia). Para resolver o problema do brilho e também os gráficos corrompidos, eu precisei especificar o parâmetro acpi_backlight=native para o Kernel (no Pop se usa o comando kernelstub e em outras distros pode-se especificar o parâmetro no Grub) e configurar o Xorg (modifiquei o arquivo 20-intel.conf). Nos sites abaixo você poderá encontrar essas soluções.

https://wiki.archlinux.org/title/Backlight#Kernel_command-line_options
https://wiki.archlinux.org/title/intel_graphics
https://man.archlinux.org/man/intel.4
https://wiki.archlinux.org/title/Intel_graphics_(Português)

O meu arquivo de configuração do Xorg:

/etc/X11/xorg.conf.d/20-intel.conf

Section "Module"
  Load "nvidia"
EndSection

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  BusID "PCI:0:2:0"
  Option "Accel" "true"
  Option "AccelMethod"  "sna"
  Option "VSync" "false"
  Option "SwapbuffersWait" "true"
  Option "TearFree" "true"
  Option "TripleBuffer" "true"
  Option "DRI" "3"
  Option "Backlight" "intel_backlight"
EndSection 

A minha placa integrada é a Intel UHD Graphics 620 e a placa dedicada é a Nvidia MX110.

Essa configuração ficou excelente no meu sistema, mas se alguém identificar algo errado nas configurações, por favor, comente aqui.

Espero que as informações disponibilizadas nos sites indicados ajude a você configurar o seu sistema.
Por favor, leia a documentação e faça as modificações para o seu sistema. O relato que fiz é específico para a distribuição que uso e para o meu notebook. Eu pesquisei muito para fazer essas configurações e precisei fazer diversos testes. Configurar incorretamente o Xorg pode impedir a inicialização do ambiente gráfico. Se isso acontecer basta entrar no modo de recuperação do sistema ou usar o modo Live USB para modificar o arquivo do Xorg.