Teclado internacional no Manjaro KDE (cedilha)

Ola pessoal. Já tentei de tudo para configurar o teclado internacional com acentos no Linux, mas nada dá certo. O máximo que consegui foi usando o comando “setxkbmap -model abnt -layout us -variant intl” no terminal, mesmo assim a cedilha não funciona. Sempre quando reinicio o sistema, as configurações não ficam salvas.

Alguém no fórum já passou por isso e resolveu o problema? Lembrando que em tty1 tudo funciona normalmente com o layout “us-acentos”.

Olá @flavio_ux seja bem-vindo :wave:

Isto é um palpite mas, se você acrescentar o 2 no abnt no comando setxkbmap -model abnt2 -layout us -variant intl será que funcionaria?

:pray:

1 curtida

Muda o model pra pc105. O comando que eu uso no meu ThinkPad X200, que tem teclado US, é: setxkbmap -model pc105 -layout us -variant intl

1 curtida

Para travar as configurações fixas vc tem que usar a GUI do manjaro-settings, Na parte de teclado vc fixa o layout permanente ali alem de selecionar o formato do teclado

Engraçado que as vezes a cedilha funciona e as vezes não, que doidera :smiley:

Mas de qualquer forma, não consegui de forma alguma fazer o script rodar na inicialização, com systemd e tudo… Poxa, nunca poderia imaginar ser tão difícil resolver um problema aparentemente tão simples :cry: :sob:

Desde já agradeço a força de todos.

Mencionando a sugestão do @knimer eu também tenho um Thinkpad, mas o T450 sem o super e control da direita, o ?/ ficam no lugar, então eu tenho de usar um modelo diferente z60. Dito isto e perdão a pergunta mas, qual seria o modelo do seu computador e teclado?

Uma outra sugestão, o seu sistema operacional teria como ver oque cada tecla faz virtualmente? Por exemplo, acessar um teclado virtual nas configurações e apertar a tecla “ç” para ver qual tecla no virtual que vai fazer um pequeno “pop up”.

Eu comprei um teclado recentemente e estava com o mesmo problema. Porém, depois de muita busca eu conseguir resolver o ‘ç’.

Faça o seguinte:

  1. Abra as “Configurações de sistema” do Plasma.
  2. Te, pois vai em “Dispositivos de entrada”
  3. Te pois siga os seguintes passos:

  1. Você vai deixar da seguinte forma:

image

  1. Fim. Agora vai funcionar.
1 curtida

Costuma ser fácil, mas como você disse que usa o Manjaro e não especificou qual gerenciador de janelas ou ambiente desktop, além de ter citado o setxkbmap, eu assumi que você é um usuário intermediário ou avançado.

Se usar o KDE Plasma, siga os passos acima e marque a resposta do colega como solução.

1 curtida

Então @knimer , parece ser um bug maldito do manjaro kde porque está configurado exatamente como nosso amigo @IgorM citou, conforme como está mostrado na imagem a seguir do ambiente gráfico:

1 curtida

Você consegue ir na parte do teclado em input devices e mostrar como está? Um usuário relatou que não estava adiantando alterar em Keyboard Settings no fórum do Manjaro:

Eu não sei dizer se em outras distribuições também ocorre isso… Anteriormente eu tinha instalado o Arch Linux com gnome e tava tudo certo… Agora no Manjaro kde está dando esse problema. com o comando setxkbmap resolveu bem o problema porém a cada logon no ambiente gráfico eu tenho que habilitar ele de novo :cry: Já tentei fazer ele inicializar junto com o sistema de diversas formas e até hoje não consegui :scream:

já gerei um script e coloquei para inicializar com o sistema com o chmod =x habilitado e nada funciona… frustrante :hot_face:


A solução do fórum também não resolveu:

You can add/change the line
Option "XkbModel" "abnt"
Option "XkbLayout" "us"
Option “XkbVariant” “,intl”
inside /etc/X11/xorg.conf.d/00-keyboard.conf

Acredito que seja um bug doido do kde (não sei se esse kde é neon ou plasma) :stuck_out_tongue_winking_eye:

Não entendi o motivo do script não funcionar.

Acho que o pessoal que usa KDE pode dar uma olhada e sacar o problema.

Se você optar por informar as configurações desejadas diretamente pelo X, seria bom que :

  1. Informe qual é o comando específico que você executa para fazer funcionar.
    Você confirma que é esse mesmo ?
  1. Mostre seu arquivo de configuração

cat /etc/X11/xorg.conf.d/00-keyboard.conf

  1. Veja quais são os outros lá nessa pasta

ls /etc/X11/xorg.conf.d/

Eu tô achando que você está fazendo muitas tentativas ao mesmo tempo, mas só uma acaba valendo e é justamente a que não está funcionando.

Olá @chimpa_theist. Respondendo:

  1. Sim, uso o comando setxkbmap -model abnt -layout us -variant intl As outras variantes sugeridas aqui deram o mesmo resultado. OBS.: Em softwares de terceiros, com o comando setxkbmap, a cedilha funciona corretamente digitando <’ + c > . Nos programas nativos do sistema dessa forma já não funciona, necessitando digitar <alt direito + c> para gerar a cedilha.

Você tá vendo que tem outro arquivo de configuração de teclado aí nessa pasta ?
O que tem nele ?

cat /etc/X11/xorg.conf.d/10-keyboard.conf

Porque no final, é esse que tá valendo.

E você poderia executar o comando ?

setxkbmap -query

Olha o que tem no conteúdo dos arquivos:

Ok.

Com essa configuração ele funciona em alguns aplicativos e em outros não, é isso ?

Vamos tentar uma das sugestões do @knimer (que era mudar o modelo).

setxkbmap -model pc105

setxkbmap -query

É que eu acho que o modelo abnt é para aqueles teclados que já vêm com a tecla ç no layout.

Depois de mudar para pc105, não esqueça de mostrar como ficou, com o

setxkbmap -query

N~ao funciona de jeito nenhum. S’o pode ser bug no kde plasma, n~ao tem como :unamused:

Mas pelo menos toda vez que inicializar o sistema e der dois cliques no script vai funcionar… :expressionless: :roll_eyes:

Ok, ele colocou mais coisas lá.

Vamos dar o comando completo.

setxkbmap -model pc105 -layout us -variant intl

E claro, vamos ver como ficou

setxkbmap -query