Suporte de PPAs no Mint

Uso o Linux Mint LMDE 3 Cindy, que é baseado no Debian 9. Estou desde ontem tentando instalar PPAs, mas recebo o erro “Adding PPAs is not supported”. Eu segui diversos tutoriais para resolver isso, mas não deu.

O LMDE usa a base debian, então não é possivel instalar PPAs nele. PPAs só são suportados por distros que usem o ubuntu como base.

1 Curtida

Sim, mas eu vi diversos tutoriais dizendo que é possível, como por exemplo: https://www.diolinux.com.br/2013/03/tem-como-instalar-ppa-no-debian.html
Mas mesmo após seguir os passos não deu certo.

1 Curtida

É possível, mas não é nada oficial, não tem nenhuma garantia de que vai dar certo e é possível que o seu sistema acabe quebrando, sem contar que esse exemplo é um tutorial antigo e pode não dar certo em versões mais recentes do debian e consequentemente do LMDE

Você sabe se há outra forma de instalar o f.lux?

tem um tutorial no github deles, mas eu resumi tudo em um unico comando gigante.

sudo apt-get install -y python3-distutils gir1.2-appindicator3-0.1 gir1.2-gtk-3.0 && cd /tmp && git clone "https://github.com/xflux-gui/fluxgui.git" && cd fluxgui && ./download-xflux.py && sudo ./setup.py install --record installed.txt && fluxgui

só copia, abre o terminal, cola, digita a senha e espera

E: Unable to locate package python3-distutils

aparentemente não tem o pacote no repositório do debian

não dá pra usar o redshift?

1 Curtida

Acho que é a única saída mesmo. Obrigado pela ajuda.