Sumiu os nomes das redes wifi

Olá pessoal, instalei o Manjaro linux e, apesar de estar gostam do sistema, não estão aparecendo as redes wifi. Consegui concertar seguindo um tutorial que dizia para adicionar as linhas

[main]
dhcp=dhclient
dns=dnsmasq

em /etc/network/network.conf

Deu certo por um tempo, as redes apareceram. Por um dia eu fui feliz. Porém parou de novo e não volta mais.

vocês tem ideia do que está acontecendo e de como posso resolver?

Toturial que deu certo temporariamente: YouTube

Consegui (por enquanto)

instalei a versão LTS recommended do Kernel

https://www.vivaolinux.com.br/topico/vivaolinux/nome-das-redes-wifi-sumiram/?pagina=1

Uma dica, o fórum oficial do Manjaro tem bastante coisa. Depois dê uma pesquisada lá usando nome da sua placa wirless.

Link do fórum: https://forum.manjaro.org/

1 Curtida

funcionou mas acabou de para de novo, fiz downgrade de novo e nada :frowning:

Tive esse mesmo problema, aqui basto atualiza o sistema e reinicia e já volto ao normal. (faz um mês e está tudo ok)

1 Curtida

vou ver se tem algo pra atualizar por aqui. Troquei o kernel de novo e voltou a pegar. Mas to com medo de desligar o computador e quando ligar não estar pegando de novo kkkk

ainda estou me adaptado aos comandos do manjaro

o que seria equivalente aos

apt update

apt upgrade

você tem ideia?

sudo pacman -Syu
https://wiki.archlinux.org/

que coisa, queria muito saber o que esta acontecendo, mas ja tentei de tudo e so pega as vezes. Doidera

Qual a saída do comando?

systemctl list-unit-files --state enabled

Outra coisa… sobre informações de diferenças de comandos de gerenciadores de pacotes vc pode ver no link abaixo
Pode ocorrer do link em português estar desatualizado

link em inglês

https://wiki.archlinux.org/index.php/Pacman/Rosetta

link em português

https://wiki.archlinux.org/index.php/Pacman_(Português)/Rosetta_(Português)

1 Curtida

Descobri um detalhe: quando inicio o computador as redes não aparecem. Porém se eu colocar o computador em modo sleep e depois tirar eles aparecem.

saida do comando

UNIT FILE STATE VENDOR PRESET
org.cups.cupsd.path enabled disabled
apparmor.service enabled disabled
autovt@.service enabled disabled
avahi-daemon.service enabled disabled
cronie.service enabled disabled
dbus-org.freedesktop.Avahi.service enabled disabled
dbus-org.freedesktop.ModemManager1.service enabled disabled
dbus-org.freedesktop.nm-dispatcher.service enabled disabled
display-manager.service enabled disabled
getty@.service enabled enabled
linux-module-cleanup.service enabled disabled
ModemManager.service enabled disabled
NetworkManager-dispatcher.service enabled disabled
NetworkManager-wait-online.service enabled disabled
NetworkManager.service enabled disabled
org.cups.cupsd.service enabled disabled
sddm.service enabled disabled
snapd.apparmor.service enabled disabled
snapd.service enabled disabled
tlp.service enabled disabled
avahi-daemon.socket enabled disabled
org.cups.cupsd.socket enabled disabled
remote-fs.target enabled enabled
pamac-cleancache.timer enabled disabled
pamac-mirrorlist.timer enabled disabled

25 unit files listed.

Obrigado pelas dicas, ajudou muito

tenta o seguinte e veja se funciona…

simplesmente desative o NetworkManager-wait-online.service

eu não sei se ele desativa ou tem que mascarar

tente

sudo systemctl mask NetworkManager-wait-online.service

e reinicie e veja se funciona

1 Curtida

ja tentei mascarar esse serviço, mas não deu certo, então reativei o serviço. Vou desabilitar mais uma vez e ver no que da

ok…

outra coisa

se não me engano o wpa_supplicant tem que estar ativo…

no opensuse o serviço tem o nome de wpa_supplicant.service

para saber o nome

systemctl list-unit-files | grep -i wpa_supplicant

e depois inicia com ele

habilite para iniciar com wpa_supplicant
para habilitar no boot

sudo systemctl enable wpa_supplicant.service

para iniciar o serviço
sudo systemctl start wpa_supplicant.service

e veja se funciona…

reicie e veja se funciona

se o outro método não funcionou
volte o serviço
sudo systemctl unmask NetworkManager-wait-online.service

1 Curtida

$ systemctl list-unit-files | grep -i wpa_supplicant
wpa_supplicant-nl80211@.service disabled disabled
wpa_supplicant-wired@.service disabled disabled
wpa_supplicant.service disabled disabled
wpa_supplicant@.service disabled disabled

qual deles é?

tente o wpa_supplicant.service

sudo systemctl start wpa_supplicant.service

e veja se funciona

talvez seja necessário desativar e ativar a rede wifi no networkmanager

1 Curtida

fiz oque você disse, sem desligar o wifi e o problema persistiu. Reiniciei com o wifi desabilitado e quando tentei habilitar apareceram as redes. Será que deu certo?

sabe me explicar as causas do problema?

o responsável pelo rede wifi é o wpa_supplicant.

normalmente o networkmanager inicia ele, mas pode estar falhando…

para testar

habilite no boot e reinicie o pc

sudo systemctl enable wpa_supplicant.service

e veja se funciona

apesar de ser o wiki do arch, é legal ler para conhecer o serviços e configurações manuais

https://wiki.archlinux.org/index.php/Network_configuration/Wireless

1 Curtida

valeu meu caro

parece que meu problema está resolvido.

como já pensei isso 3 vezes ainda não sei até quando. Mas estou conseguindo usar o wifi. Obrigado

valeu pelo o link vou estudar o assunto

ok…
wpa_supplicant-wired@.service

é o que o serviço fornece com cabo

o resto é serviço dependente

boa leitura

até

1 Curtida

obrigado, realmente não deu certo. ainda quando desligo o computador a internet volta off

por enquanto estou colocando o computador em modo sleep e depois voltando à liga-lo

está dando certo isso.

Enquanto não há outra solução; solucionado está!