Sugetão de correção, Global Menu no Ubuntu

ubuntu
#1

Senhores,

  • Vi o Livepatch nos programas do Ubuntu 19.04 e o abri para ver o que era. Ao abrir eu encontrei um erro de digitação (não vou subir a imagem para não ocupar o espaço do fórum haha). Como posso sugerir correção para a Canonical?
  • A extensão (que se bem me lembro está descontinuada) que envolve o Global Menu e HUD no Ubuntu está Ok no 19.04? Se não, há opção satisfatória?
1 Like
#2

Como reportar bugs específicos no Ubuntu

2 Likes
#3

Cara, tava pesquisando hoje sobre a extensão. Infelizmente ela não está funcionando nas versões 3.30+ do GNOME.
O motivo pra isso pelo que andei vendo é que o desenvolvedor simplesmente desistiu do projeto depois de cansar de bater cabeça com a galera do projeto GNOME/GTK, o que eu entendi é que ele fez um “hack” no GTK Toolkit para que fosse possível fazer essa extensão de menu global. Porém no GTK+4 isso não será possível, eles vão bloquear qualquer modo de “hack” do tipo que o cara o global menu fez, o que faria a extensão não ser compatível com aplicações GTK+4.
Ele já tentou argumentar com a galera dos projetos GNOME/GTK, a própria comunidade pediu uma extensão oficial de global menu, mas parecem simplesmente não querer.
Aí no fim o cara desistiu da extensão, disse que poderia consertar de boa pra funcionar no GTK 3.30+, mas não vê sentido em continuar investindo nisso visto que a comunidade GNOME/GTK não tá nem aí e logo mais a extensão não vai ter de jeito nenhum como suportar aplicações GTK4.

1 Like
#4

Sei lá, cara. Mas acho a galera do projeto gnome muito cabeça dura. Poxa, Global Menu e HUD são ótimas sacadas. Incriveis. Barrar isso é, perdão pela palavra, burrice.

#5

São bem isso mesmo, burros. Se houvissem mais a comunidade seria a melhor DE. Mas não, a comunidade que tem que trabalhar por eles colocando extensões, e depois vem eles e bloqueiam. Parece uma tal de Microsoft ai.

1 Like
#6

E mais uma vez a “comunidade” GNOME/GTK sendo extremamente nociva e tóxica pro mundo Linux, é por essas e outras que eu acho que o toolkit padrão no Linux deveria ser o Qt, o GTK só piora a cada build

1 Like