Stremio erro no Gerenciador de Atualizações

Olá,
Tentei instalar o Stremio para assistir filmes e não rodou no meu Linux Mint 20. Após tentar desinstalá-lo o Gerenciador de Atualizações passou a exibir o seguinte erro:
“E: O pacote stremio precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.” (ver imagem) Agora o sistema não atualiza. Reinstalei o Stremio e nada mudou. Continua assim. Alguma dica?

Tente o comando:
sudo dpkg --remove --force-all stremio

Tente atualizar o sistema. Caso ainda reclame, há a segunda opção:

sudo rm -i /var/lib/dpkg/info/stremio.*
sudo dpkg --remove --force-remove-reinstreq stremio

Esses dois comandos fazem o sistema esquecer que um dia o Stremio existiu.

Pergunta, ao instalar esse Stremio, ele puxou alguma biblioteca específica dele?

1 Curtida

No meu Linux Mint 20 também não abriu o Stremio, então ao invés de instalar pelo .deb, instalei pelo flatpak. Vá neste site: Stremio - All You Can Watch e baixe a versão Flatpak.

Vá na pasta Downloads, clique com botão direito e dps clique em Abrir no Terminal. No terminal, você vai escrever este comando:
flatpak install Stremio+4.4.116.flatpak

Só esperar instalar, e pronto!

Espero ter ajudado amigo! :wink:

2 Curtidas

Valeu. A primeira solução resolveu o problema do gerenciador. Vou tentar o Flatpak. Obrigado!

1 Curtida

Socorro pessoal, eu estou com esse mesmo problema, eu tentei fazer isso que vocês disseram aqui, mas não funcionou, tentei instalar o Flatpak mas quando eu baixo e clico com o botão direito, ele não me da a opção de instalar usando o terminal :frowning: Tentei usar os comandos para remover ou desinstalar mas ele continua me apresentando a mensagem: Erros foram encontrados durante o processamento de:
stremio
Eu já não sei o que fazer, eu até pensei em restaurar o computado por conta disso, mas também falhei nessa parte, alguém me ajude por favor.

innmark,

Utilizei os comandos sugeridos pelo Capezotte para limpar o Stremio do sistema e deu certo.

sudo dpkg --remove --force-all stremio

ou

sudo rm -i /var/lib/dpkg/info/stremio.*
sudo dpkg --remove --force-remove-reinstreq stremio

Fiz o download do Flatpak e instalei sem problemas.
Veja se o caminho para o pacote no terminal está correto para proceder a instalação, comigo deu certo.
Acho que ão sei se posso lhe ajudar muito com isso.
Abçs

2 Curtidas

No primeiro comando que você me mandou, apresentou isso aqui :frowning:

E no segundo comando, já apareceu assim:

Cara, depois que eu fiz esse comandos, deu esses erros que mostrei, mas apareceu atualizações aqui, atualizei e sumiu o erro, não sei o que aconteceu mas deu certo. Obrigado viu, me ajudou e muito, já estava no surto aqui HAHHAHA.

2 Curtidas

Instalei o Stremio e tive um erro.
Não consegui rodar até baixar o arquivo de biblioteca que estava faltando.

que biblioteca é essa? Já tetei todas as opções deste site e de outros e não consigo. Até insta, mas não roda.

Depois de instalar o .deb via instalador, aparece este erro ao executar o programa

o Flatpak fala que não encontra no momento da instalação

Está usando qual distro?

Tentei rodar o Stremio no Ubuntu MATE 20.04.1 LTS.
Quando eu não consigo abrir um programa, eu tento executar ele pelo terminal pra ver o que aparece de erro. Depois de instalar o .deb do site e não conseguir rodá-lo, o terminal retornou o seguinte erro:

stremio: error while loading shared libraries: libx264.so.152: cannot open shared object file: No such file or directory

Baixei o pacote que fornece o arquivo libx264.so.152
Não instalei o pacote com o dpkg. Apenas descompactei o deb e retirei o arquivo e depois copiei ele para a pasta /usr/lib/x86_64-linux-gnu/

1 Curtida

Obrigada Francehelder, mas não faço ideia do que vc fez…
Infelizmente meus meses de teste com linux estão sendo um pesadelo…

Qual comando você usou pra rodar o Stremio pelo terminal?

e desinstalei pelo sinaptic, que fala q n removeu 3 pacotes, mas q eles não serão atualizados

Baixe o pacote que eu linkei, instalei e depois tente rodar o Stremio de novo.
No meu caso bastou pra resolver.