SpaceExplorer 3D Connexion - como instalar no Manjaro XFCE?

Eu tenho um mouse 3D da 3D Connexion e quero instalar ele no Manjaro XFCE para usar com o Blender

Não tenho um mouse 3D aqui, mas fonte: 3D Mouse - ArchWiki

  1. Instale libspnav e spacenavd no PAMAC (ative o AUR)
  2. Inicie o driver systemctl enable --now spacenavd no terminal.
  3. Reinicie o Blender.

Valeu, vou pesquisar como funciona o Pamac, não tenho a mínima idéia de como fazer, mas isso já é uma direção

Obrigado amigo, eu volto com o resultado rsrsrs

O PAMAC é bem moleza de usar… e tem post no blog, se liga!

Rapaz, deu erro aqui, acho que o mouse 3D que eu tenho é muito antigo, eu já tive problema para usar ele mesmo no windows

tem um driver para fazer download no site do fabricante mas eu não sei como posso habilitar aqui no linux

eu vi um dos vídeos do Diolinux e consegui usar, mas creio que o meu mouse 3D seja muito antigo, deu erro na instalação aqui

1 Curtida

Se o driver for pra Windows, acho pouquíssimo provável (pra não dizer impossível) que funcione no Linux. Mas uma fuçada pelo AUR pode ser a solução…

tem o driver para linux sim eu já baixei, na verdade é um aplicativo

https://3dconnexion.com/us/drivers/

1 Curtida

Olha, tá em tar.gz
Já tentou instalar?

tentei… não tem um executável igual no windows, e no txt com as instruções de instalação tem o seguinte texto:

INSTALLATION INSTRUCTIONS FOR 3DxWare FOR Linux (x86_64) - V 1.8.0

To install the files for 3DxWare for Unix to the corresponding directories
and to run the driver you need root privileges.

Make sure you fulfill the following prerequisites:

Linux:
	kernel 2.6.8 and higher

NOTES: 

	For distributions with libXm.so.4 installed, please create a symbolic link
            to libXm.so.3 in the same directory.

            For Example:
               cd /usr/lib64
               ln -s libXm.so.4 libXm.so.3


	With SuSE Linux 10.x the usbfs is not mounted by default. 
	Please make sure you mount the usbfs to get support for the USB controller.
	To mount USBFS, please do (as root user):
		mount -t usbfs none /proc/bus/usb
	You should enter a line for usbfs in your /etc/fstab to have USBFS
	mounted at boot time.

	You might also find useful hints about USB on Linux here:
	http://www.linux-usb.org/USB-guide/c122.html
	http://www.linux-usb.org/USB-guide/x173.html

	In some cases some X11 fonts may not have been installed, which are used to
	draw on the device LCD.
	Please make sure you have installed the 75 and/or 100DPI fonts for X11.
	The packages are named for example:
		xorg-x11-fonts-75dpi-7.2-3.fc8,
		xorg-x11-fonts-100dpi-7.2-3.fc8
		or
		xorg-x11-fonts-ISO8859-1-100dpi-7.2-8.fc11.noarch,
		xorg-x11-fonts-ISO8859-1-75dpi-7.2-8.fc11.noarch

	Packages names may vary depending on the distribution (and version) you are using!


    Automatic startup in Red Hat EL 6:
    The service initialization in RHEL 6 has been changed from init (Sys V Init)
    to upstart.

    Related articles:
    https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Technical_Notes/deployment.html
    https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Migration_Planning_Guide/sect-Migration_Guide-Networking-Service_Initialization.html
   
    The installation determines the release version of Red Hat EL and installs for
    the appropriate service start procedure:
    RHEL release <= 5.x: System V Init (/etc/inittab)
    RHEL release = 6.x: upstart (/etc/init/3dxware.conf)

The files for the driver are provided with the following archive:

Linux:
	3dxware-linux-v1-8-0.x86_64.tar.gz

Please save the file 3dxware-linux-v1-8-0.x86_64.tar.gz into the /tmp directory
and extract and run the script install-3dxunix.sh:

tar xfz 3dxware-linux-v1-8-0.x86_64.tar.gz install-3dxunix.sh
./install-3dxunix.sh

If you don’t choose during installation the possibility to start the driver during login from the
/etc/inittab please make sure the driver is started before you launch your application.

For the USB devices start the driver with the following command:

Linux:
	/etc/3DxWare/daemon/3dxsrv -d usb

For the serial devices start the driver with:

/etc/3DxWare/daemon -d /dev/<serialport>
	where <serialport> is the name of your serial port to which the device is attached.
	Example: /etc/3DxWare/daemon/3dxsrv -d /dev/ttyS0

For the start of the driver from the /etc/inittab the following line is added:
3dx:234:respawn:/etc/3DxWare/daemon/3dxsrv -d </dev/null >/dev/null 2>&1
where is the name of the port to which the device is attached.

Demos:

After unpacking 3dxware-linux-v1-8-0.x86_64.tar you can find two demos:
The cube demo: /tmp/xcube and
a value demo:  /tmp/xvalue

Those are two simple demos that work with the setting "Any Application". You may copy the
binaries to your favourite location for binaries.

Udev-Scripts:

After unpacking 3dxware-linux-v1-5-0.i386.tar you can find two scripts:
Start script "udev_3DxSrvStart": /tmp/udev_3DxSrvStart 
Udev rule "85-3DX_SPP.rule" for SpacePilot PRO: /85-3DX_SPP.rule

Put the rule file in "/etc/udev/rules.d/" and the start script into "/etc/3DxWare/daemon".
These locations may vary depending on the distribution used and installation favours.
Thus the rule file and the start scricpt may to be modified to refelct these indifidual environment.  

Known issues:
- On Red Hat EL 5 the driver will not start from /etc/inittab if root logs in to :0

- the driver has to run with root privileges(or started from the inittab)
  Reason: Linux doesn't provide write access for standard users to USB devices
		  in /proc/bus/usb

- SuSE 10.1 does not have the required USBFS activated/mounted per
  default. Please get root permissions and mount the filesystem via:

  mount -t usbfs none /proc/bus/usb

  For permanent effect, edit the file /etc/fstab and change the line

  usbfs		/proc/bus/usb	usbfs	noauto		0  0

  to

  usbfs		/proc/bus/usb	usbfs	defaults	0  0


  You can find more informations on USBFS at the following pages:
  http://www.linux-usb.org/USB-guide/x173.html
  http://www.linux-usb.org/USB-guide/c122.html

- Automatic startup in Red Hat EL 7:
  The starting mechanism on RHEL 7 has been changed to use systemd.
  Automatic startup on login is not implented.

  Related article:
  https://access.redhat.com/site/solutions/521533

  Starting 3dxsrv on the commandline is suggest as follows and my be applicable
  to systemd scripts as well:
  /etc/3DxWare/daemon/3dxsrv -d usb </dev/null >/dev/null 2>&1

Supported devices:
SpaceMouse Pro Wireless
SpaceMouse Wireless
SpaceMouse Pro
Space Pilot Pro
Space Pilot
Space Explorer (Serial, USB)
Space Navigator for Notebooks
Space Navigator

Pois então… o driver foi pensado para algumas distros, entre elas o Red Hat e o SUSE. Mas vc pode testar descompactando o tar.gz e rodando o script e ver se funciona… vai que…

Como eu rodo esse script?

Ali, ó - se não me engano deve ser isso

Funcionou, @Guarinon?

rapaz, eu não sei usar o terminal ainda, eu estou pensando até em vender esse mouse, eu já marquei o tópico como resolvido por que eu desisti, mas muito obrigado pela atenção meu amigo!

Um forte abraço!

1 Curtida

vende não… vê se o povo ajuda aqui no passo-a-passo, é mais fácil do que parece

1 Curtida