Simple Scan fechando do nada no Linux Lite

Estou tentanto scannear documentos com o Simple Scan, ele detecta normalmente o scanner, mas na hora de iniciar a digitalização o programa se fecha do nada. Ao tentar executá-lo pelo terminal, o programa abre, mas aparece a seguinte mensagem no terminal:

(simple-scan:8315): Gtk-WARNING **: 12:59:03.454: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: Method “RegisterClient” with signature “ss” on interface “org.xfce.Session.Manager” doesn’t exist

O que é esse erro e como consertá-lo?

1 Curtida

Tenta usar o XSane. (20chars)

Com o Xsane, Skanlite e gscan2pdf funciona tudo normalmente, mas o simple scan tá com esse problema. Gostaria de poder usar ele porque, como o nome já diz, é o mais simples e ao mesmo tempo tem todas as funções que preciso.

Você pode rodar um visualizador de log tipo o gnome-system-log, pra saber qual é o problema.

aparece isso aqui

Dec 10 08:54:59 wagner-desktop simple-scan: io/hpmud/model.c 532: no ther_dcp-l5652dn attributes found in /usr/share/hplip/data/models/models.dat
Dec 10 08:54:59 wagner-desktop simple-scan: io/hpmud/model.c 543: no ther_dcp-l5652dn attributes found in /usr/share/hplip/data/models/unreleased/unreleased.dat

O modelo da impressora é Brother L5652DN

Busca por esse erro no Google, deve encontrar algo.

encontrei isso aqui, mas além de não entender inglês, não tenho um conhecimento tão grande de informática, tenho medo de fazer alguma besteira e piorar as coisas

https://bugs.launchpad.net/ubuntu/+source/simple-scan/+bug/1805039

Eu havia seguido o exato procedimento desse link aqui pra instalar o scanner

https://support.brother.com/g/b/downloadhowto.aspx?c=br&lang=pt&prod=dcpl5652dn_us&os=128&dlid=dlf006645_000&flang=4&type3=566

Pelo que eu li ele não fez nada de demais, ele só desinstalo os drivers que ele instalo manualmente e foi no site do fabricante e baixo direto, ou seja, ele desinstalo os drivers que ele instalo e não é oficial e instalo baixando os originais direto do site.

Pois é, mas eu já tinha baixado os drivers direto do site, então não deveria estar dando esse problema

Antes de você instalar esse deb, o scanner estava funcionando ou não?

Não, a impressora foi instalada ontem, e o scanner da impressora anterior não era detectado por nenhum dos aplicativos