Sem Bootloader na hora de ligar

grub
#1

a algum tempo migrei para o linux ate ai tudo bem mas ai instalei em dual boot o windows 10 só que continuou sem o bootloader, e sempre para entrar em algum dos sistemas tenho que ir na bios e trocar a ordem de boot, e também dpeois de instalar o windows 10 começou a aparecer isso na hora de entrar no linux

que para sair e entrar no linux tenho que rodar os comando ( set prefix=(hd0,gpt6)/boot/grub, set root=(hd0,gpt6), insmod normal, normal ) so depois de rodar esses comandos que entra se alguém puder me ajudar a resolver isso agradeço desde já

1 Like

#2

Cara, para não ter dor de cabeça, pega e reinstala o Grub!

Boota em um Live CD do Linux (de preferência da mesma distribuição) e roda um grub-install /dev/sd(x) - Onde “x” é a letra do disco do Linux. Depois teria que dar o “chroot” no sistema e rodar um “update-grub”.

Deve ter algum passo a passo disso, mas a moral é reinstalar o grub.

Att,
Mateus

2 Likes

#3

obrigado vou baixar a iso da distro e procurar algum passo passo disso

0 Likes

#4

Talvez:

2 Likes

#5

Primeiro quando for fazer dualboot o windows tem que ser instalado primero para evitar esse problema com o GRUB, no meu PC pessoal eu posso escolher na BIOS o boot pelo windows manager ou pela minha Distro so que ao deixar o windows manager não tenho opção de escolher o linux, talvez no seu PC é igual.

2 Likes

#6

não sabia dessa de ter que instalar o windows primeiro, aqui a partição do windows ficou com esse nome windows manager mas não da para escolher simplesmente entra no windows

1 Like

#7

legal fui fazer o livependrive para seguir o tutorial de recuperação do grub o pendrive ta bugado plugo ele no pc e ele simplesmente fica conectando e desconectando ‘-’ alguém sabe se tem como salvar o pendrive?

1 Like

#8

Pode ser problema com seu hardware eu já vi máquina que as USB da frente da esse problema tenta nas USB traseira que é mais confiável se não tenta refazer o pendrive. No windows o melhor app é o Rufus no Linux é o etcher

2 Likes

#9

nas portas traseiras também não funcionaram vou tentar no windows

1 Like

#10

atualizando: agora a pouco apareceu um update no gerenciador de updates do sistema de um update do grub2 então atualizei e o erro da imagem do post desapareceu, ah e mais cedo hoje deixei o pendrive plugado no pc ele ficou conectando e desconetando por horas mas uma hora ele conectou e não desconetou mais então conseguir fazer live pendrive nele e funcionou normal, então seguir o passo a passo e quando rodei o ultimo comando “sudo grub-install --root-directory=/mnt /dev/sda” deu o seguinte erro “grub-install: error: install device isn’t specified”

1 Like

#11

faltou especificar em qual hd vc quer que instalei o grub o correto seria:

sudo grub-install /dev/sda

pois ele ta pedindo o caminho do hd (/dev) e nao da pasta onde ta o linux como vc especificou ai… sda no caso diz pra ele o primeiro hd o segundo seria o sdb e assim por diante…

em uma nota separada só pra tornar mais rica a explicação… quando estamos falando de sda somente estamos especificando a raiz do disco a agora sda1 ou sda2 por exemplo seria: disco a partiição 1 ou disco a partição 2 e assim por diante quando especificariamos por exemplo pra ele montar uma partição numa pasta…

1 Like

#12

entendi, então depois vou la testar colocando o numero da partição

0 Likes