Screen Tearing no Regata OS

Instalei a iso Regata OS + Nvidia

No momento estou enfrentando screen tearing. Como solucionar?

Já tentou ativar o “Force Full Composition Pipeline” no nvidia-settings ?

1 Curtida

Essa opção nem aparece pra mim :confused:

E essa é a minha conf no compositor

GPUs com Prime não suportam essa opção.

2 Curtidas

De mais detalhes do seu equipamento, que somente com essa informação fica meio dificil de lhe ajudar. Pode editar a postagem e adicionar ela.

2 Curtidas

O melhor lugar para se obter ajuda com o Regata OS é usando a comunidade no Facebook ou o grupo no Telegram.

Você está tendo problemas com screen tearing na área de trabalho ou executando jogos com a dGPU NVIDIA?

2 Curtidas

em
/etc/X11/xorg.conf.d/20-nvidia.conf

adicione

    Option         "metamodes" "nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"

exemplo:

/etc/X11/xorg.conf.d/20-nvidia.conf

Section "Device"
        Identifier "Nvidia Card"
        Driver     "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName  "GeForce GTX 1050 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
EndSection

mais info
https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Avoid_screen_tearing

1 Curtida

como falaram se estiver usando prime

  • Turning PRIME Synchronization[5] off (will introduce screen tearing):

xrandr --output HDMI-0 --set “PRIME Synchronization” 0 #replace HDMI-0 with your xrandr output ID

mais info
https://wiki.archlinux.org/index.php/PRIME

1 Curtida

Atualização:
Eu estava estranhando que eu só estava percebendo o tearing apenas no Firefox. (Após corrigir o travamento do sistema Colocando pro Automático a Prevenção de Deslizamento

Então, esbarrei num comentário no YouTube de um cara dizendo estar sofrendo isso apenas no Firefox, que quando testou no Chrome não tinha tearing.

Realmente foi isso mesmo.

No entanto, a solução que ele deu não tinha no meu Firefox.

Acabei tendo de dormir porque já era tarde e agora estou no trabalho.
Assim que eu solucionar o tearing no Firefox eu informo aqui.

Ainda não pude testar nos jogos pois ainda vou baixar. Mas testarei o Dota e retorno também com maiores informações se está experienciando Tearing em jogos também.

Também postarei um print com o Neofetch para as informações de sistema

Abraços.

Não sei se é essa solução que não há no seu firefox, mas você pode tentar isso para eliminar o tearing:

1 - Digite about:config na barra de endereços.
Captura de Tela_Área de Seleção_20191217093031

2 - Clique em Aceitar o risco e continuar.

3 - Clique em Mostrar tudo.

4 - Pesquise por layers.acceleration.force-enabled, que estará como false por padrão. Clique duas vezes sobre a opção para mudar para true.

5 - E, por fim, reinicie o firefox.

3 Curtidas

Muito obrigado.
Eu estava com tearing no firefox do Solus.

3 Curtidas