Scanner V600 Epson só funciona no root/sudo

Instalei o Iscan, drive da própria Epson, mas o danado do scanner só funciona em root, usando qualquer outro programa (o próprio digitalizador do Iscan, o Xsane etc.).

Busquei fóruns pela internet e achei algumas soluções, mas não sou usuário avançado e não as entendi bem. Pelo visto tem a ver com permissões. Deixo o link delas abaixo.

Se alguém puder me ajudar de um jeito pra leigos um pouquinho avançados… Uso o Mint 19.3

Abraços

Não cheguei a ler os links, mas parece ser um problema de udev que a sol resolve.

Edite como root o arquivo /etc/sane.d/dll.conf

Faça com seu editor preferido
No exemplo vou usar o nano

sudo nano /etc/sane.d/dll.conf

Procure por sua impressora, se não existir descomente a Epson

Por exemplo

epson

Para

epson

Salve

Desligue a impressora e liga ela novamente.

Veja se agora funciona o scanner .

Até

Nada.

Mas obrigado pela tentativa amigo.

Experimente colocar seu usuário no grupo “scanner”.

Use o comando abaixo substituindo “usuário” pelo seu nome de usuário. Usar o comando como usuário root.

gpasswd -a usuário scanner

Só uma pergunta depois de instalar o Iscan
vc reiniciou a máquina?

Acho que iscan precisa reiniciar a máquina para aplicar no udev

1 Curtida

Nada.

Mas obrigado.

Reinicie, sim.

Ok…

Só faz a parte da permissão

  • Permissions will be broken for non-root users. The scanner’s device handle needs a configuration file to allow the scanner group access, and any users that need the scanner need to be manually added to said group:

O idvendor tem que ser o seu

sudo nano /etc/udev/rules.d/79-udev-epson.rules

ATTRS{idVendor}==“04b8”, ATTRS{idProduct}=="*", MODE=“0660”, GROUP=“scanner”, ENV{libsane_matched}=“yes”

sudo adduser seuusuario scanner

Para mais informação sobre permissão

1 Curtida