Ruído múltiplos microfones UBUNTU 20.04

Boa tarde. Sou iniciante no mundo linux e a tempos venho enfrentando problemas com a gravação de som.

Meu note veio originalmente com windows, e lá eu gravo perfeitamente com meu microfone pela entrada do note ou ainda pela placa USB que eu tenho.

Porém no Ubuntu é impossível gravar, o audio sai apenas estática, ficando a voz lá no fundo imperceptível.

Já tentei uma infinidade de listas, comandos e tutoriais, mas nenhum com sucesso.
Aqui está um resumo do que já tentei:

Nesses 2 links abaixo, estou enviando uma demonstração do ruído usando o Simple Screen Record, mas o mesmo acontece no OBS e qualquer outro software de captura de som:

Veja se funciona
17 Down vote Accepted

Type in the terminal alsamixer . It will open the present levels, adjust the microphone level at 75 and set the microphone boss level to 50. Worked for me perfectly and removed the noise from microphone.

Bom dia, fiz a configuração do alsamixer mas infelizmente nao obtive sucesso.

alguma outra ideia?

É um notebook?
Qual a configuração?

Vou pesquisar mais quando tiver um tempo…
E retorno com a informação

Em uma rápida pesquisa encontrei isso

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Audio_quality

sim é um notebook. é um 2am c300. Uso o fone do celular no celular e está OK e no windows está ok tb para gravar/escutar.

Quanto a configuração, acho que está perguntando sobre a placa de audio?

 cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xa4310000 irq 136

esse link é inclusive o primeiro da lista que coloquei na abertura do post. infelizmente já realizei esse procedimento também

Este procedimento é outro

Vc fez
https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Static_noise_in_microphone_recording

O que passei é Enable Echo/Noise-Cancellation

sim, apesar de ser uma aconragem diferente é a mesma pagina.

ja ativei o cancelamento de eco/ruido e nao tive efeito.

1 Curtida

Ok vc selecionou a outra entrada

Veja aqui em br

https://qastack.com.br/ubuntu/18958/realtime-noise-removal-with-pulseaudio

sim, selecionei a nova entrada com cancelamento de ruido ativo (inclusive vi isso em um dos vídeos do Diolinux no youtube)

novamente refiz o procedimento dos links que enviou (do arch e do qastack), que basicamente são carregar no pulse o modulo de cancelamento de ruido ativo e depois selecionar ele via interface gráfica como dispositivo de entrada. porém continuo sem captar o audio.

realizei ainda o procedimento do alsamixer novamente testando diversos valores ainda nao consegui gravar a voz. apenas a estatica/ruido.

1 Curtida
1 Curtida

Possuo um Lenovo Ideapad 330, e encontro o mesmo problema. Já tentei muitos tutorias de “como resolver”, incluindo os listados, e mesmo assim continua. Já troquei até de Distro, inclusive, e nada. :worried:

veja ai se resolve , eu tambem tinha esse problema e resolvi com esse procedimento,
Tambem sou iniciante mas acho que se assistir o vidéo com atenção creio que vai te ajudar tambem.

1 Curtida

note que a linha ( load-module module-echo-cancel…etc…
ela não está no local correto , cole logo abaixo da linha 144 , abaixo de (load module module-filter-apply)

ai com certeza dará certo
e após conectar o Headset vá no terminal e digite pulseaudio -k para reiniciar o pulse audio.

Está certo sim…

O que tem antes é um comentário

Tudo com # é um comentário… Isso quer dizer que o serviço não lê

:+1:t2:

tente essa linha abaixo:
Obs: a descrição abaixo se trata apenas de uma linha e não duas , pois está assim por causa da quebra automatica.

load-module module-echo-cancel aec_args=“analog_gain_control=0 digital_gain_control=0” source_name=Headsetsource source_properties=device.description=headset

E no final cole essa:

#set-default-source Headsetsource

verdade é isso mesmo!!!

assim que deixei para que desse certo.
linha 145 e linha 150