Review: Adaptador bluetooth Orico BTA-508 no Linux

Eu tenho alguns adaptadores aqui, mas são todos muitoooo antigos. Se eu conseguir colocar meus “dedinhos” em uma adaptador novo, farei com certeza.

:vulcan_salute:

1 curtida

infelizmente tive que parar de usar o adaptador o mesmo fica parando de funcionar e eu tenho que o tirar fisicamente do computador e ligar novamente para ele voltar a funcionar em alguns casos tenho que reiniciar o sistema por completo voltei ao orico 4,0, pode que seja um problema no sistema devido a quantidade de configurações já mexidas e feitas outra hora com mais tempo irei formatar para fazer um teste

2 curtidas

Tenho um Ugreen 5.0 com o mesmo chipset. Só avisando que o driver já foi aplicado oficialmente no kernel do Linux, eu só não sei quando de fato as pessoas não precisarão instalar o driver manualmente. Eu particularmente preferi baixar os binários dessa página do kernel e fazer a instalação manual do que utilizar esses binários de terceiros

2 curtidas

Todas as versões do kernel mais antigas e que não receberem os patches de compatibilidade de hardware (HWE) continuarão precisando fazer o procedimento manual. No Fedora 35 o meu dongle funcionou automaticamente, mas o desempenho não me pareceu tão bom quanto o driver “não oficial”.

:vulcan_salute:

2 curtidas

A post was split to a new topic: Como resolver um possṕivel conflito de drivers bluetooth

Comprei o adaptador da Orico por essa recomendação e deu muito certo. Já estava a um bom tempo procurando um adaptador Bluetooth que funcionasse no Linux. Muito obrigado pela contribuição!

1 curtida

Salvou a minha vida!
Muito obrigado!

1 curtida

Estou pensando em comprar esse adaptador, mas não queria ter dor de cabeça de ficar instalando driver. Alguém aqui que tem ele sabe se nas últimas versões do Kernel ele está funcionando de primeira? E funciona fone de ouvido e controle de PS4 sem travar?

Eu tenho um clone chinês aqui que não tem jeito nenhum de funcionar no Linux, então queria algo que não vai me dar dor de cabeça. Obrigado.

1 curtida

Nos meus testes, o Fedora 35/36 e o Arch Linux detectaram o adaptador automaticamente, não testei em outras distribuições. Para evitar este problema, você pode pesquisar por outro modelo que já tenha sido amplamente testado pela comunidade e tenha bom histórico de funcionamento.

Se você não formata seu computador toda hora, vai precisar fazer esse procedimento apenas uma vez e pode esquecer. Meu Debian está há quase 8 meses instalado e não precisei me preocupar mais com o driver do adaptador.

:vulcan_salute:

3 curtidas

Eu comprei esse adaptador Orico pela loja afiliada da Orico no Aliexpress e o mesmo chegou hoje. Estou usando o Fedora Workstation 35 e o adaptador passou a funcionar no momento em que eu o conectei no computador. Completamente plug and play, sem necessidade de configuração adicional.

Segue o link do adaptador:

3 curtidas

Obrigado por avisar do plug and play no fedora 35, chequei na pasta de firmware em lib, eles incluem o driver do chipset já, não precisa mais realizar o processo. Esperando meu adaptador chegar. Precisava de um adaptador 5.0 pra usar a conexão simplificada com meu Buds Pro da Samsung, tinha testado um outro xingling sem marca que ficava desconectando o fone a cada 10-15 segundos… Espero que esse dê certo.

Aqui pra mim, está dando “Falha de Conexão: Protocol not available” Estou com o ultimo kernel disponível no repo do Ubuntu 20.04. E fiz todo o procedimento do tuto. Deu certo por alguns meses. Depois, começou a dar esse erro.

Alguma luz?

Olá @Isai tudo bem contigo?

Sugiro desparear o dispositivo e tentar novamente, apesar de possível é pouco provável que este erro esteja relacionado ao driver. Esse erro ocorre com apenas este dispositivo que você destacou?

Sugiro abrir um tópico específico para que a comunidade possa te auxiliar nessa situação.

:vulcan_salute:

1 curtida

Olá, amigo! Há alguns meses eu passei aqui pq não conseguia usar o dongle orico BTA-508 no Zorin OS 16, mas consegui resolver o problema graças a esse post. Tudo estava bem até agora. De repente após uma atualização de sistema o Dongle deixou de ser reconhecido novamente. Ele é identificado pelo sistema mas o status fica “desligado”. Se alguém souber alguma solução eu agradeço!

1 curtida

Confere a versão do kernel e tente refazer os passos do tutorial, sugiro abrir um tópico específico caso isso não resolva.

:vulcan_salute:

1 curtida

Tentei realizar o tutorial e acabei tendo o mesmo problema que o Diogo. Ele reconhece o adaptador, mas não encontra nenhum aparelho (fone ou celular). Utilizo o Ubuntu 21.10 e a versão do kernel é 5.13.0-28-generic.
quando faço o systemctl status bluetooth tenho como output:

● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2022-02-15 19:55:23 -03; 27min ago
       Docs: man:bluetoothd(8)
   Main PID: 5219 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 9384)
     Memory: 684.0K
        CPU: 28ms
     CGroup: /system.slice/bluetooth.service
             └─5219 /usr/lib/bluetooth/bluetoothd

fev 15 19:55:23 BB-8 bluetoothd[5219]: Starting SDP server
fev 15 19:55:23 BB-8 bluetoothd[5219]: Bluetooth management interface 1.20 initialized
fev 15 19:55:23 BB-8 bluetoothd[5219]: Endpoint registered: sender=:1.123 path=/MediaEndpoint/A2DPSink/sbc
fev 15 19:55:23 BB-8 bluetoothd[5219]: Endpoint registered: sender=:1.123 path=/MediaEndpoint/A2DPSource/sbc
fev 15 19:55:23 BB-8 bluetoothd[5219]: Endpoint registered: sender=:1.123 path=/MediaEndpoint/A2DPSink/sbc_xq_453
fev 15 19:55:23 BB-8 bluetoothd[5219]: Endpoint registered: sender=:1.123 path=/MediaEndpoint/A2DPSource/sbc_xq_453
fev 15 19:55:23 BB-8 bluetoothd[5219]: Endpoint registered: sender=:1.123 path=/MediaEndpoint/A2DPSink/sbc_xq_512
fev 15 19:55:23 BB-8 bluetoothd[5219]: Endpoint registered: sender=:1.123 path=/MediaEndpoint/A2DPSource/sbc_xq_512
fev 15 19:55:23 BB-8 bluetoothd[5219]: Endpoint registered: sender=:1.123 path=/MediaEndpoint/A2DPSink/sbc_xq_552
fev 15 19:55:23 BB-8 bluetoothd[5219]: Endpoint registered: sender=:1.123 path=/MediaEndpoint/A2DPSource/sbc_xq_552
1 curtida

Olá @Anna_Garcia tudo bem contigo?

Se você seguiu os passos do tutorial e não deu certo, o melhor caminho é abrir um novo tópico fornecendo informações sobre o seu computador para podermos tentar te ajudar.

:vulcan_salute:

3 curtidas

Xubuntu 20.04 Kernell 5.13.0-30 . Consegui instalar e reconhece tudo certo . Mas tenho algumas ressalvas , mas acho que isso depende mais do Fone do que do adaptador Orico . Testei com um Headphone Baseus D02 e o som sai todo picotado e com falhas e o alcance não é dos melhores , fico na frente do adaptador e mesmo assim picota só virando a cabeça :cold_sweat: . Já com Headphones vagabundos ( aqueles 3 em 1 com radio e Sd card ) funcionam que é uma beleza :grinning:. Vou comprar mais um Fone pra ver se melhora a situação .
Ah ! Só lembrando que o fone funciona ok no iphone , ipad e android .

Olá @ken, tudo bem contigo?

Esse adaptador é 5.0, mas se você estiver usando um fone com uma versão anterior do bluetooth não conseguirá usar todo o potencial dele. Outro ponto é que a “pilha de som” do sistema também influencia na experiência, no Debian usando Pipewire não tenho nenhum tipo de problemas - mas - no Pulseaudio, tinha limitações pela ausência dos codecs mais modernos como Aptx e SBC-XQ.

Faça um teste com o Pipewire e veja se obtém melhores resultados.

:vulcan_salute:

2 curtidas

Sim , o Headphone é 5.0 . Fiz a troca do Pulse Audio pelo Pipeware e deu uma melhorada significativa . Não há mais cortes abruptos , ou quando vejo um filme e o som fica baixo , o bluetooth cortava o som e muitas vezes só tocava em um dos lados do fone , até o som do filme ficar mais alto . Nesse ponto melhorou e muito ! Porém , o problema do alcance ficou igual , como disse antes , tem vezes(raro) que só de mexer a cabeça o som dá uma picotada . Já testei com um outro Headphone de meu amigo e deu o mesmo problema . Agora pedi um outro adaptador pelo Ali , e vou esperar pra ver se melhora ou não . Valeu .

1 curtida