Ressucitando pc antigo, wifi não pega 100% da rede

Beleza pessoal

estou ressuscitando um netbook antigo que tenho em casa.

instalei lubuntu nele e está rolando muito bem.

Porem deu um certo trabalho instalar o driver de rede Broadcom BMC4311. Mas consegui!

Mas ele não pega 100% da rede

mesmo ao lado do roteador a rede fica em dois pontos.

Alguém tem ideia do que está acontecendo, podem me ajudar?

Com pacot3 instou?

Não lembro qual é, mas é alvo como b43

1 curtida

bom dia @swatquest

segui esse tutorial para instalar o drive https://www.vivaolinux.com.br/dica/Instalando-Broadcom-BCM43-no-LinuxMint

1 curtida

Remove também estes abaixo

sudo apt-get remove  broadcom-sta-common broadcom-sta-dkms

Acho que não precisa instalar o b43-fwcutter

1 curtida

Não deu certo, quando remove esses broadcom o wifi sumiu ao reiniciar, então instalei de novo

Ok

Sabe o módulo do drive?
Veja se é b43

Se for este

modinfo b43

Se não for

Veja a saída do drive em

lspci -k

1 curtida

Eu tinha um netbook que também nunca pegava sinal cheio… Eu desconfiava do cabo que leva o sinal da placa à antena (geralmente em cima do monitor). Como o notebook fica abrindo e fechando pode ter danificado o cabo. No final eu usava ele mais no cabo e nunca resolvi, até que foi pro lixo por obsolescência.

De repente se você tiver outro notebook quebrado pode tentar roubar o cabo da antena wifi e fazer teste pra ver se com outro cabo e antena ele pega sinal bom.

1 curtida

na saida do modinfo

acho que é este sim.

modinfo b43
filename: /lib/modules/4.15.0-109-generic/kernel/drivers/net/wireless/broadcom/b43/b43.ko
firmware: b43/ucode9.fw
firmware: b43/ucode42.fw
firmware: b43/ucode40.fw
firmware: b43/ucode5.fw
firmware: b43/ucode30_mimo.fw
firmware: b43/ucode33_lcn40.fw
firmware: b43/ucode29_mimo.fw
firmware: b43/ucode26_mimo.fw
firmware: b43/ucode25_mimo.fw
firmware: b43/ucode25_lcn.fw
firmware: b43/ucode24_lcn.fw
firmware: b43/ucode16_mimo.fw
firmware: b43/ucode16_lp.fw
firmware: b43/ucode15.fw
firmware: b43/ucode14.fw
firmware: b43/ucode13.fw
firmware: b43/ucode11.fw
license: GPL
author: Rafał Miłecki
author: Gábor Stefanik
author: Michael Buesch
author: Stefano Brivio
author: Martin Langer
description: Broadcom B43 wireless driver
srcversion: 30E7D1C384DA8629A763454
alias: ssb:v4243id0812rev10*
alias: ssb:v4243id0812rev0F*
alias: ssb:v4243id0812rev0D*
alias: ssb:v4243id0812rev0C*
alias: ssb:v4243id0812rev0B*
alias: ssb:v4243id0812rev0A*
alias: ssb:v4243id0812rev09*
alias: ssb:v4243id0812rev07*
alias: ssb:v4243id0812rev06*
alias: ssb:v4243id0812rev05*
alias: bcma:m04BFid0812rev2Acl*
alias: bcma:m04BFid0812rev28cl*
alias: bcma:m04BFid0812rev1Ecl*
alias: bcma:m04BFid0812rev1Dcl*
alias: bcma:m04BFid0812rev1Ccl*
alias: bcma:m04BFid0812rev18cl*
alias: bcma:m04BFid0812rev17cl*
alias: bcma:m04BFid0812rev15cl*
alias: bcma:m04BFid0812rev11cl*
depends: mac80211,ssb,bcma,cfg80211
retpoline: Y
intree: Y
name: b43
vermagic: 4.15.0-109-generic SMP mod_unload 686
signat: PKCS#7
signer:
sig_key:
sig_hashalgo: md4
parm: bad_frames_preempt:enable(1) / disable(0) Bad Frames Preemption (int)
parm: fwpostfix:Postfix for the .fw files to load. (string)
parm: hwpctl:Enable hardware-side power control (default off) (int)
parm: nohwcrypt:Disable hardware encryption. (int)
parm: hwtkip:Enable hardware tkip. (int)
parm: qos:Enable QOS support (default on) (int)
parm: btcoex:Enable Bluetooth coexistence (default on) (int)
parm: verbose:Log message verbosity: 0=error, 1=warn, 2=info(default), 3=debug (int)
parm: pio:Use PIO accesses by default: 0=DMA, 1=PIO (int)
parm: allhwsupport:Enable support for all hardware (even it if overlaps with the brcmsmac driver) (int)

saida lspci -k

Rs,

To usando no cabo também .

Também abri algumas vezes esse netbook

Agora estou desconfiado da placa também

Esta é a configuração do dispositivo
Não sei se vai melhorar, só testando

parm: btcoex:Enable Bluetooth coexistence (default on) (int)  ---- vc pode tentar desabilitar esta opção
 parm: allhwsupport:Enable support for all hardware (even it if overlaps with the brcmsmac driver) (int) - vc pode tentar habilitar esta função

Só testando para ver…

Coloque na em /etc/modules-load.d

Por exemplo, crie o arquivo wifi-b43.conf e adicione o conteúdo abaixo:

options b43 btcoex=off
options b43  allhwsupport
1 curtida

Obrigado irmão,

vou testar

parm: btcoex:Enable Bluetooth coexistence (default on) (int)  ---- vc pode tentar desabilitar esta opção
 parm: allhwsupport:Enable support for all hardware (even it if overlaps with the brcmsmac driver) (int) - vc pode tentar habilitar esta função

Como faço para habilitar e desabilitar essas opções?

É só remover o arquivo do /etc/modules-load.d

Ou uma das options

1 curtida

AAh entendi

Eu só criei o arquivo wifi-b43.conf e adicionei as instruções, mas não deu em nada.

Posso mover todos os arquivos do diretório para uma pasta backup invés de exclui-los

Pode…

As configurações estão em parm

Isso serve para qualquer módulo

vc chegou a reiniciar o móduflo ou o pc?

eu te passei o caminho errado

No caso não é em /etc/modules-load.d e sim em /etc/modprobe.d/

Por exemplo, crie o arquivo wifi-b43.conf e adicione o conteúdo abaixo:

options b43 btcoex=off
options b43  allhwsupport