[RESOLVIDO] Problema de Driver de rede Cabeada no Manjaro - Driver r8169

manjaro
#1

Pessoal, boa noite, estou com um problema com driver de rede cabeada da realtek driver r8169 que depois da atualização que teve sexta feira (atualizei hoje domingo) a rede nao pega de jeito nenhum! nao consigo fazer subir o módulo r8169! usar wifi nao é opção pois está com problema de hardware! alguem pode me ajudar? ja procurei nos forum e nada adianta! eu instalei o manjaro faz pouco tempo!

0 Likes

#2

Eu tive isso no 4.14, estava sem o módulo instalado. Vai no Octopi ou Pamac e pesquisa “linux419-r8168” se está instalado! Isso se vc estiver no kernel 4.19, se estiver utilizando outra versão muda lá “linux418-r8168” se for o 4.18 e assim sucessivamente.

0 Likes

#3

então eu ja instalei e nao funciona!

0 Likes

#4

Que versão do kernel vc está utilizando? Qualquer coisa vc faz o up ou downgrade de kernel.

0 Likes

#5

estou usando o 4.19! ja usei o modprobe e nada de funcionar!

1 Like

#6

Complicado, se não for algo necessário volta pro 4.14.

0 Likes

#7

nem adianta voltar! eu instalei o 4.20 e foi mesma coisa! não sobe o modulo!

1 Like

#8

voce sabe como coloco na lista negra os modulos? pelo que andei pesquisando pode ta dando conflito o r8169 pq o sistema na encontra o r8168!

0 Likes

#9

Tá complicado, se vc “manjar” do inglês, desculpa o trocadilho tosco, vai lá diretamente no fórum do Manjaro nesta publicação e posta lá!

0 Likes

#10

Vá até o “Manjaro Settings Manager” verificar essa questão dos drivers.

Eu tenho aqui uma máquina que funciona muito bem com o driver do próprio Kernel, mas o instalador instala o módulo extra com a ferramenta de driver do Manjaro (para o caso da minha máquina, não é necessário).

Verifique desinstalar o driver resolve o problema (já resolvi um problema assim noutra ocasião). O Kernel possui um módulo r8169 nativo, e há o módulo extra aparentemente para casos em que o módulo nativo não funciona.

Tente fazer o download do pacote do módulo extra, para o caso da desinstalação não resolver o seu problema.
Use o comando sudo pacman -Sw linux4xx-r8168 substituindo os “x” para que os pacotes correspondam ao kernel que tu usas. O pacman com -Sw serve para descarregar os pacotes simplesmente, não há instalação.
Não se esqueça de instalar os módulos através do “Manjaro Settings Manager”.

0 Likes

#11

Mas, é bsatante difícil de ver reclamação relacionada com esta placa de rede cabeada. Um evento incomum.

0 Likes

#12

Para colocar o modulo na blacklist, crie um arquivo .conf dentro de /etc/modprobe.d/
ex:

/etc/modprobe.d/blacklist.conf
#Não carrega o modulo “r8169” no boot.
blacklist r8169

Tenta desativar o modulo para testar com:

#modprobe -r nome_modulo
ou
#rmmod nome_modulo

Uma coisa é verificar com “lsmod” os modulos que estão rodando, pode realmente ter tido algum conflito e da uma verificada nos logs do sistema.

0 Likes

#13

Voltando aqui para dizer que um carinha no Telegram me ajudou, mas nao sei foi isso que resolveu! Ele pediu para instalar o pacote rtl-sdr. Eu instalei e reiniciei a maquina mas não subiu o módulo, então usei o sudo modprobe r8169 e voltou a ter internet cabeada! Eu só estou com medo de reiniciar a maquina e a rede nao voltar pq aconteceu isso ontem nas minhas tentativas! Mais tarde volto aqui pra ver como ficou depois de reiniciar a maquina! Por agora preciso da internet!

0 Likes

#14

No “Manjaro Settings Manager” não tem opção de instalar ou desisntalar drive de rede! só de video!
Esse pacote linux4xx-r8168 eu ja instalei e reinstalei varias vezes e nao aconteceu nada!

0 Likes

#15

tem varios topicos abertos no forum do manjaro, mas nenhum funcionou comigo!

0 Likes

#16

eu ja tentei colocar em blacklist mas não adiantou nada!

0 Likes

#17

Certo, então o problema era a falta de um driver da Realtek. Esse pacote é para isso.
O módulo que funcionou para ti foi o r8169, logo aquele pacote que lhe indiquei é necessário, e o “Manjaro Settings Manager” o percebeu, por isso não mostrou a opção (o MSM lida com módulos extras para o Linux, coisas como um linux4xx-nome.do.modulo).

Não subiu, talvez, por causa daquele arquivo de lista negra de módulos /etc/modprobre.d. Verifique se podes remover a entrada do r8169, e então veja se o módulo será carregado automaticamente na inicialização.

Faça um último teste, e remova o pacote do módulo r8168. Esse pacote fornece o r8168, e tu usaste o r8169.

1 Like

#18

Voltando aqui porque reiniciei o notebook, e com esse pacote rtl-sdr consegui subir o módulo com sudo modprobe r8169! agora vou deixar pra carregar no arquivo modprobe.conf lá em /etc/modules.load!

0 Likes

#19

Lembre-se de remover ou comentar o blacklist.conf caso tenha criado.

/etc/modprobe.d/blacklist.conf
#Não carrega o modulo “r8169” no boot.
#blacklist r8169

0 Likes

#20

atualizei o kernel para o 5.0 e o problema do drive de rede voltou

0 Likes