[RESOLVIDO] PopOs apresentando: Sub-process /usr/bin/dpkg returned an error code (1)

Olá, alguém pode me ajudar?

Estou utilizando o Pop!_OS 20.04 LTS e estou tentando atualizar o sistema, pela Pop Shop ele inicia e pára no meio sem atualizar . Quando tento pelo terminal ele lista no ‘sudo apt update’ e quando dou o ‘sudo apt-upgrade’ ele dá o seguinte erro:

Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Calculando atualização… Pronto

Os seguintes pacotes foram instalados automaticamente e já não são necessários: libllvm9 libllvm9:i386
Utilize ‘sudo apt autoremove’ para os remover.

Os pacotes a seguir serão atualizados:
firefox-locale-ar firefox-locale-de firefox-locale-en firefox-locale-es firefox-locale-fr firefox-locale-it firefox-locale-ja
firefox-locale-pt firefox-locale-ru firefox-locale-zh-hans firefox-locale-zh-hant fonts-opensymbol libgl1-mesa-dev libgl1-mesa-glx:i386
libgranite-common libgranite5 libgtk-3-bin libjuh-java libjurt-java libreoffice-help-common libreoffice-help-de libreoffice-help-en-gb
libreoffice-help-en-us libreoffice-help-es libreoffice-help-fr libreoffice-help-it libreoffice-help-ja libreoffice-help-pt
libreoffice-help-pt-br libreoffice-help-ru libreoffice-help-zh-cn libreoffice-help-zh-tw libreoffice-l10n-ar libreoffice-l10n-de
libreoffice-l10n-en-gb libreoffice-l10n-en-za libreoffice-l10n-es libreoffice-l10n-fr libreoffice-l10n-it libreoffice-l10n-ja
libreoffice-l10n-pt libreoffice-l10n-pt-br libreoffice-l10n-ru libreoffice-l10n-zh-cn libreoffice-l10n-zh-tw libreoffice-style-colibre
libreoffice-style-elementary libreoffice-style-tango libridl-java libsnmp-base libsnmp35 libsnmp35:i386 libuno-cppu3
libuno-cppuhelpergcc3-3 libuno-purpenvhelpergcc3-3 libuno-sal3 libuno-salhelpergcc3-3 libunoloader-java libvncserver1 libxatracker2
mesa-va-drivers mesa-va-drivers:i386 mesa-vdpau-drivers mesa-vdpau-drivers:i386 mesa-vulkan-drivers mesa-vulkan-drivers:i386 mutter
pop-gnome-shell-theme pop-gtk-theme pop-shell-shortcuts pop-sound-theme system76-power thermald uno-libs-private ure wpasupplicant
76 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

É preciso baixar 0 B/79,8 MB de arquivos.
Depois desta operação, 968 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s

Extraindo templates dos pacotes: 100%
(Lendo banco de dados … 265264 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar …/libgranite-common_5.5.0+r1759+pkg115~daily~ubuntu6.0.1_all.deb …
A descompactar libgranite-common (5.5.0+r1759+pkg115~daily~ubuntu6.0.1) sobre (5.3.0-1) …
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libgranite-common_5.5.0+r1759+pkg115~daily~ubuntu6.0.1_all.deb (–unpack):
a tentar sobre-escrever ‘/usr/share/metainfo/granite.appdata.xml’, que também está no pacote libgranite5:amd64 5.3.0-1

Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/libgranite-common_5.5.0+r1759+pkg115~daily~ubuntu6.0.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Bom, já entendi que o problema está nesse pacote libgranite-common… ele inclusive aparece na pop shop para atualizar e não atualiza, entretanto pesquisei e vi que ele pertence ao elementary OS (!!?) e o que acho mais estranho é que nenhum dos demais pacotes atualiza, alguém consegue me dar uma luz do que fazer?

Ah não sei se isso ajudaria, mas eu já dei o autoremove e o autoclean e não resolve.

Agradeço desde já!

Olá, @FGYada!

Você provavelmente adicionou algum PPA/Repositório Adicional que está causando esse problema. O que está acontecendo é que já existe no sistema a versão “libgranite5:amd64 5.3.0-1” e o APT está tentando instalar a “libgranite-common_5.5.0+r1759+pkg115~daily~ubuntu6.0.1_all”, e essa diferença está causando conflitos.

Remova os PPAs e tente novamente, que o problema deverá ser resolvido.

1 Curtida

@brunonzanette boa! tu está correto, alterei aqui e atualizou certinho. Muito obrigado!!!

1 Curtida

Eu to com um problema parecido mas não sei se a mesma solução é aplicada, se alguém puder me ajudar, agradeço.

sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  gnome-control-center gnome-control-center-data ubuntu-drivers-common
The following packages will be upgraded:
  alsa-ucm-conf apport aptdaemon aptdaemon-data busybox-initramfs busybox-static finalrd
  firefox-locale-ar firefox-locale-de firefox-locale-en firefox-locale-es firefox-locale-fr
  firefox-locale-it firefox-locale-ja firefox-locale-pt firefox-locale-ru
  firefox-locale-zh-hans firefox-locale-zh-hant gir1.2-mutter-6 gir1.2-packagekitglib-1.0
  gnome-control-center-faces google-chrome-stable grub-common grub2-common imagemagick
  imagemagick-6-common imagemagick-6.q16 libc-bin libimage-magick-perl
  libimage-magick-q16-perl libjuh-java libjurt-java libldb2 libmagick++-6.q16-8
  libmagickcore-6.q16-6 libmagickcore-6.q16-6-extra libmagickwand-6.q16-6 libmutter-6-0
  libpackagekit-glib2-18 libproxy-tools libproxy1-plugin-gsettings
  libproxy1-plugin-networkmanager libproxy1v5 libreoffice-common libreoffice-help-common
  libreoffice-help-de libreoffice-help-en-gb libreoffice-help-en-us libreoffice-help-es
  libreoffice-help-fr libreoffice-help-it libreoffice-help-ja libreoffice-help-pt
  libreoffice-help-pt-br libreoffice-help-ru libreoffice-help-zh-cn libreoffice-help-zh-tw
  libreoffice-l10n-ar libreoffice-l10n-de libreoffice-l10n-en-gb libreoffice-l10n-en-za
  libreoffice-l10n-es libreoffice-l10n-fr libreoffice-l10n-it libreoffice-l10n-ja
  libreoffice-l10n-pt libreoffice-l10n-pt-br libreoffice-l10n-ru libreoffice-l10n-zh-cn
  libreoffice-l10n-zh-tw libreoffice-style-colibre libreoffice-style-elementary
  libreoffice-style-tango libridl-java libsane libsane-common libsmbclient libuno-cppu3
  libuno-cppuhelpergcc3-3 libuno-purpenvhelpergcc3-3 libuno-sal3 libuno-salhelpergcc3-3
  libunoloader-java libuv1 libwbclient0 locales mutter mutter-common packagekit perlmagick
  pop-session pop-shell pop-shell-shortcuts popsicle popsicle-gtk python3-apport
  python3-aptdaemon python3-aptdaemon.gtk3widgets python3-problem-report rfkill samba-libs
  sane-utils secureboot-db system76-acpi-dkms teamviewer uno-libs-private ure
107 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
1 not fully installed or removed.
Need to get 0 B/188 MB of archives.
After this operation, 3,508 kB disk space will be freed.
Do you want to continue? [Y/n] y
Extracting templates from packages: 100%
Preconfiguring packages ...
Setting up linux-firmware (1.190+system76~1599667136~20.04~5b2179a) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-7642-generic
kernelstub.Config    : INFO     Looking for configuration...
kernelstub.Drive     : ERROR    Could not find a block device for the a partition. This is a critical error and we cannot continue.
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/kernelstub/drive.py", line 56, in __init__
    self.esp_fs = self.get_part_dev(self.esp_path)
  File "/usr/lib/python3/dist-packages/kernelstub/drive.py", line 94, in get_part_dev
    raise NoBlockDevError('Couldn\'t find the block device for %s' % path)
kernelstub.drive.NoBlockDevError: Couldn't find the block device for /boot/efi
run-parts: /etc/initramfs/post-update.d//zz-kernelstub exited with return code 174
dpkg: error processing package linux-firmware (--configure):
 installed linux-firmware package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 linux-firmware
E: Sub-process /usr/bin/dpkg returned an error code (1)