[RESOLVIDO] Não consigo instalar o Ubuntu no Lenovo Ideapad 330S 81JQ0002BR

Boa tarde! Comprei um notebook Lenovo IdeaPad 330S 81JQ0002BR processador AMD Ryzen 7 8GB com placa de vídeo Radeon 540 2gb e não consigo instalar o Linux Mint ou o Ubuntu, já tentei até o, Kubuntu ou Xubuntu mas dar no msm, no Linux Mint eu tentei instalar o SO pelo modo de compatibilidade e até consegui instalar mas qnd eu vou inicializar o sistema ao ligar pela primeira vez após a formatação o que me aparece só é a tela com logo da lenovo e logo após um tela preta que não sai, não aparece nd, nenhuma informação qualquer, nem mensagem de erro, não aparece nd, é só um tela preta, tentei segui um tutorial que eu encontrei no fórum da Lenovo mas não adiantou em Nd
Alguém já passou pela mesma situação? Se sim, como resolveu?
Eu não quero instalar um dualboot eu quero me livrar de vez do Windows 10, qualquer atualização ele quebrar, ele já quebrou três vezes e três vezes eu tiver que formatar.

Eu diria que provavelmente o Secure Boot está habilitado, mas pelo que pesquisei é algo ainda mais intenso, parece que fazem um bloqueio da bios mesmo que, pelo que encontrei de solução, teria que atualizar para uma versão não boqueada. Conforme abordado no vídeo abaixo:

Existe esse outro vídeo que mostra como instalar, é um pouco mais trabalhoso, mas acaba sendo uma forma de contornar:

1 Curtida

Eu vou tentar esse, vamos ver se dar jeito no problema.

Qnd eu tava pesquisando soube o problema esbarrei nesse vídeo, a Lenovo coloca esse bloqueio na bio por causa de um contrato que ela tem com a M$

Não consegui acerta, não consegui instalar o Ubuntu com esse vídeo :man_facepalming:t5:

Eu soube que pra fazer a instalação do Linux no Lenovo precisa modificar a bio, estou enviando os print da minha Bio pra alguém ver e me dizer o que eu preciso modificar.

Qual o erro apresentado na 8n inicialização ou instalação do Ubuntu?

Na inicialização do Ubuntu, tipo, assim até o momento eu consigo instalar o Ubuntu qnd eu clico no modo compatível no grub mas na hora de inicializar o sistema, entra tela com o logo da Lenovo mais depois não aparece mais nd só fica uma tela preta, totalmente preta como o display do notebook tivesse queimado ou desligado mas isso não acontece qnd eu instalo o Windows 10, inicializa normalmente…não entendo o que tá acontecendo, coloquei as fotos da minha Bio pra alguém ver e dizer onde eu tô errando, um cara do Instagram me disse que eu devo resetar a bio, desligar o segurete boot e deixar em modo UEFI msm e criar um pendrive em modo UEFI e fazer a instalação normalmente que ele vai funcionar, vou tentar dessa forma pra ver o que acontece

O que vc acha dessa forma que o rapaz do Instagram me disse, se eu fizer assim será que funciona? :thinking:

tenta reveter para uefi em vez de legacy…

outra coisa no boot order…deixe o usb hdd primeiro

Eu encontrei essa dica na net, no fórum da Lenovo, seguindo essa dica eu consegui entra no modo Live CD do Ubuntu e instalar mais ainda não consegui resolver o problema do grub ou inicialização do sistema. Ainda tô tentando ver se consigo fazer o 8° passo; se alguém tiver uma dica pra mim dar serei grato.

1º. No menu do grub você precisa apertar a tecla e para ir até as opções avançadas
2º Encontre a linha GRUB_CMDLINE_LINUX_DEFAULT=“splash quiet --” ( os parâmetros podem ser diferentes pois varia de distro pra distro)
3º Adicione o parâmetro noapic a essa linha GRUB_CMDLINE_LINUX_DEFAULT=“splash noapic quiet --” ( Não altere os parâmetros que já estão na linha, apenas adicione esse novo parâmetro)
4º Aperte F10 para iniciar o sistema
5º Instale a distro e reinicie o sistema
6º Realize os passos 1, 2 e 3 novamente para carregar o sistema, note que o touchpad não funciona, vamos corrigir isso no próximo passo
7º Agora você precisa editar o grub, abra o terminar e usando o editor da sua distro ( no meu caso foi o nano) abra o arquivo de configurações do grub
nano /etc/default/grub
8º Encontre a mesma linha do passo 2 e adicione o parâmetro ivrs_ioapic[32]=00:14.0 é ele que irá resolver todos os nossos problemas, não será mais necessários usar outros parâmetros pois este corrige o erro do touchpad( o erro que impede o sistema de inicializar). Vai ficar algo assim GRUB_CMDLINE_LINUX_DEFAULT=“splash ivrs_ioapic[32]=00:14.0 quiet --”
9º No terminal digite sudo update-grub para atualizar o grub e reinicie o notebook.

Pode ser problema com o driver da nvidia. Quando estiver na tela preta, aperte ctrl-alt-f2 para ir para o terminal. Dai digite:

sudo apt purgue nvidia*

e em seguida digite: reboot

Ele deve bootar com o driver nouveau e entrar no modo grafico normalmente.

A minha placa gráfica é a AMD Radeon 540, da pra fazer o msm procedimento?

vc ja tentou mudar a ordem de boot?
de windows boot manager para ATA HDD: WDC WD10SPZX-24Z10 OU UBUNTU.

A ordem que eu coloquei foi
USB HD
Ubuntu
Windows boot Manager

Eu vou testar esse tutorial que eu achei mas não hj por causa da morte do meu primo, tô sem cabeça, domingo eu vou fazer ele ou segunda.

Desculpe, não tinha me atentado que a sua GPU era AMD. A solução que eu propus é somente para computadores com GPU nvidia.

E meus pêsames pelo seu primo… :frowning:

1 Curtida

Eu segui um tutorial parecido mas no lugar de noapic coloquei iommu=soft e ele entrou, fiz a instalação e alterei o grub depois. Funcionou comigo e outras pessoas. Teste essa forma também que deve funcionar, não sei se a questão da versão da tua BIOS vai influenciar visto que a minha é a versão anterior mas quero atualiza, então se funcionar avisa aqui por favor. Boa sorte

1 Curtida

Cara, eu até consegui resolver a instalação, consegui instalar o Ubuntu de boa mas não resolvi o problema do touch-pad que o causador do Ubuntu não entra normalmente, em vez de o sistema inicializar normalmente o PC para em uma tela preta, achei que é grub mas resolvi o problema do grub mas msm assim o sistema não inicia normalmente, eu abri até outro tópico só pra resolver isso mas até agora nunca resolvi, tô esperando o Linux Mint 20.04 pra fazer um teste e ver se eu consigo resolver todo o problema.

cara eu sofri bastante com o meu idealpad 330s pra instalar o ubuntu nele. no meu caso eu atualizei o grub e deixei ele desse jeito funcionou normalmente ate o mouse se quiser dar uma olhada ta ai. espero que te ajude.

If you change this file, run ‘update-grub’ afterwards to update

/boot/grub/grub.cfg.

For full documentation of the options in this file, see:

info -f grub -n ‘Simple configuration’

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT=“ivrs_ioapic[32]=00:14.0”
GRUB_CMDLINE_LINUX=""

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD …)

#GRUB_BADRAM=“0x01234567,0xfefefefe,0x89abcdef,0xefefefef”

Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo’

#GRUB_GFXMODE=640x480

Uncomment if you don’t want GRUB to pass “root=UUID=xxx” parameter to Linux

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

#GRUB_DISABLE_RECOVERY=“true”

Uncomment to get a beep at grub start

#GRUB_INIT_TUNE=“480 440 1”

1 Curtida