[Resolvido] [Fedora 34] Erro ao gravar GIF no peek

:wave: Olá pessoal, Eu fui gravar um GIF usando o peek porem da esse erro

já tentei usar no x11 e não deu certo

Print

código do erro

Command “ffmpeg -f x11grab -show_region 0 -framerate 10 -video_size 702x522 -i :99.0+324,155 -filter:v scale=iw/1:-1 -codec:v libvpx-vp9 -lossless 1 -r 10 -y /home/davidmacalister/.var/app/com.uploadedlobster.peek/cache/peek/peekT6OK40.webm” failed with status 256 (received signal 0).

Output:
ffmpeg version 4.3.1 Copyright (c) 2000-2020 the FFmpeg developers built with gcc 10.2.0 (GCC) configuration: --prefix=/app --disable-debug --disable-static --enable-gpl --enable-libvpx --enable-libx264 --enable-shared --enable-libxcb --enable-libxcb-xfixes --disable-libxcb-shape --disable-ffplay --disable-ffprobe --disable-doc --disable-everything --enable-bsf=vp9_superframe --enable-decoder=libvpx_vp9 --enable-decoder=png --enable-decoder=rawvideo --enable-encoder=apng --enable-encoder=ffvhuff --enable-encoder=gif --enable-encoder=libvpx_vp9 --enable-encoder=libx264 --enable-encoder=png --enable-demuxer=image2 --enable-demuxer=matroska --enable-muxer=apng --enable-muxer=gif --enable-muxer=image2 --enable-muxer=mp4 --enable-muxer=webm --enable-filter=crop --enable-filter=fps --enable-filter=palettegen --enable-filter=paletteuse --enable-filter=scale --enable-protocol=file --enable-indev=xcbgrab libavutil 56. 51.100 / 56. 51.100 libavcodec 58. 91.100 / 58. 91.100 libavformat 58. 45.100 / 58. 45.100 libavdevice 58. 10.100 / 58. 10.100 libavfilter 7. 85.100 / 7. 85.100 libswscale 5. 7.100 / 5. 7.100 libswresample 3. 7.100 / 3. 7.100 libpostproc 55. 7.100 / 55. 7.100Input #0, x11grab, from ‘:99.0+324,155’: Duration: N/A, start: 1622672076.831489, bitrate: 117262 kb/s Stream #0:0: Video: rawvideo (BGR[0] / 0x524742), bgr0, 702x522, 117262 kb/s, 10 fps, 10 tbr, 1000k tbn, 1000k tbcStream mapping: Stream #0:0#0:0 (rawvideo (native) → vp9 (libvpx-vp9))Press [q] to stop, [?] for help[libvpx-vp9 @ 0x564f8809dc80] v1.10.0[libvpx-vp9 @ 0x564f8809dc80] Failed to initialize encoder: ABI version mismatchError initializing output stream 0:0 – Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or heightConversion failed!

eu não achei nada a respeito. aguem sabe como resolver?

já agradeço
:pray:

Eu descobri como arrumar.

  1. adicione o RPM fusion Configuration - RPM Fusion
  2. instale o ffmpeg sudo dnf install ffmpeg
  3. depois basta instalar o app sudo dnf install peek