[RESOLVIDO]Compilar VTE-ng

#1

Boa tarde, estou tentando compilar o terminal termite no linux mint 19, instalei a maior parte das dependências necessárias e nesse momento estou tentando compilar a dependência vte-ng, entretanto quando dou ./autogen.sh caio no seguinte erro:
autoreconf: running: automake --add-missing --copy --force-missing
configure.ac:94: installing ‘./compile’
configure.ac:16: installing ‘./install-sh’
configure.ac:16: installing ‘./missing’
bindings/vala/Makefile.am: installing ‘./depcomp’
src/Makefile.am:28: error: Libtool library used but ‘LIBTOOL’ is undefined
src/Makefile.am:28: The usual way to define ‘LIBTOOL’ is to add ‘LT_INIT’
src/Makefile.am:28: to ‘configure.ac’ and run ‘aclocal’ and ‘autoconf’ again.
src/Makefile.am:28: If ‘LT_INIT’ is in ‘configure.ac’, make sure
src/Makefile.am:28: its definition is in aclocal’s search path.
parallel-tests: installing ‘./test-driver’
autoreconf: automake failed with exit status: 1
Alguma ideia de como contornar isso?

0 Likes

#2

já tentaste instalar a “libtool”??
sudo apt install libtool

1 Like

#3

Duas coisas:

1 - tu checou se o termite já não tem um pacote pré-compilado nos repos do Mint?

2 - a source do termite no github nem tem um autogen.sh, onde tu pegou essa source pra compilar?

EDIT: o título deveria ser ‘‘Compilado VTE’’ não? :v seja mais claro, e o carinha já respondeu aí em cima, só pegar a dependecia que o erro tá indicando

0 Likes

#4
  1. Sim, chequei não tem
  2. No caso coloquei esse título porque achei que teria mais problemas além desse durante a compilação do termite, mas não foi o caso.
1 Like