Resolvendo problemas de video no Ubuntu (XFCE) e derivados

Bom eu vinha enfrentando problemas no meu notebook,quando eu ligava ele junto com o monitor externo,ele não dava sinal de vida (ficava uma tela preta no not e no monitor,com um cursor parado na canto da tela). O sistema bugava cada vez que abaixava a tampa do not também…
Enfim para resolver o problema instalei o “synaptic” busquei pelo pacote “xorg” e removi completamente todos pacotes que tinha haver com o mesmo.Ex “xserver-xorg-core”
Depois de remover todos, instalei o pacote 'xserver-core", após reiniciar o not os problemas foram resolvidos.

Se por acaso seu touchpad parar de funcionar o click com toque, resolva com “sudo apt install xserver-xorg-input-synaptics”

Quando você se refere há esse bug na hora que abaixa a tampa do notebook, é qual bug? Pois eu estou usando o Debian XFCE, e nas várias distros que usei (Xubuntu, Linux Mint) sempre que eu baixo a tampa e levanto novamente, a tela do LightDM fica apagada, eu tenho que colocar a senha sem ver nada. Eu só consegui ter algo de diferente no Manjaro já com o XFCE 4.14

Olha eu não sei te explica “qual é o problema exato” me parece que o xorg não criou um arquivo de configuração quando instalamos o sistema/ ou se criou ficou corrompido algo do tipo…
O problema da tampa acho que seria o mesmo bug aqui (porem nunca tentei por a senha com a tela apagada sdjgfhgfj) eu dava ul alt+f2 e depois um alt+f7 e o lightdm voltava

Veja se essa solução que postei funciona …
Qualquer coisa entre em contato no telegram ou aqui mesmo, e tento te ajudar a resolver

Se a sua GPU é NVIDIA, é possível que você precise rodar um script na inicialização do LightDM pra que ele seja exibido corretamente, na Wiki do Arch explica exatamente o procedimento, é só procurar lá por NVIDIA Optimus.

1 Curtida