[RESOLVED] Atualizar o próprio Flatpak e não programas instalados com ele

Boa dia!

Sou iniciante em Linux e estou testando o Deepin… Ao tentar instalar o Kdenlive via Flatpak pelo terminal, apareceu a seguinte mensagem:

erro: app/org.kde.kdenlive/x86_64/stable needs a later flatpak version (0.11.4).

Ou seja, parece que preciso de uma versão mais recente do Flatpak, sendo assim rodei um

sudo apt-get install flatpak

porém recebi a mensagem de que o flatpak já é a versão mais recente.

Portanto, gostaria de saber como eu poderia atualizar o Flatpak?

Que distribuição você está utilizando?

Eu estou utilizando o Deepin

Eu estou utilizando o Deepin

Momento desabafo, pode ignorar e focar no próximo comentário

Natanael, porque você implica tanto com Flatpak e Snap, você deveria incentivar o uso das novas tecnologias…

Bom, esse post explica?

1 Curtida

Simples. Você está tentando instalar o flatpak, mas ele já está instalado.
Tente um
sudo apt update && sudo apt dist-upgrade

O comando install apenas instala, não atualiza. O comando update verifica os repositórios, e o comando dist-upgrade atualiza os pacotes encontrados desatualizados.

Certo… acabei de rodar os dois comandos. Porém apareceu

0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

:thinking:
Acho que devem ser os repos do Debian…

Já considerou não usar Flatpak?

O Flatpak do Kdenlive é mantido por terceiros, oficialmente eles mantém AppImage, Snap e o .exe:

Para baixar a versão recomenda pelos Devs, você pode entrar nesse link e baixar a última versão, elas são listadas de cima pra baixo, ou seja,a mais recente (19.1) está no final da lista, pra baixar diretamente, clique aqui

Não exatamente, o comando “install” significa:

Install latest available version

Ele serve tanto pra instalar um pacote quanto pra atualizar manualmente um set de pacotes

Serve pra atualizar todos os pacotes

Ok… vou dar uma olhada.

1 Curtida

Então quer dizer que se a versão dos repositórios do Debian não estiver atualizada eu não irei conseguir atualizar?

1 Curtida

Exatamente, você vai ter que atualizar via código fonte, o que é uma coisa ruim porque a cada atualização do Flatpak você vai precisar recompilar

O único modo seria compilando o código fonte então? Não teria nenhuma outra forma?

1 Curtida

Sem correr o risco de destruir o seu sistema? Sim

O AppImage não deu certo?

Huummm… Entendi. Que tristeza… :sweat_smile:. Muito obrigado!

O deepin é base Debian stable, ou seja, tem muito pacote já absoleto…

Sim sim… Já desconfiava que podia ser esse o problema… perguntei mesmo pra ver se teria alguma alternativa segura. Obrigado!

Tem: Não usar Flatpaks