Resolução do meu monitor no Ubuntu

Olá, preciso de ajuda com isso

Sou novo no Linux e preciso de ajuda para configurar o minitor
Ele esta com a resolução muito baixa e eu não consigo alterar, ja procurei bastante na internet alguama solução mas ate agr nada.

A resolção que eu preciso é de 1600x900 e só me esta disponivel 1024x768.
A placa de video do pc e uma intel graphics 3 gen, é so isso que aparece.

Talvez não esteja usando o driver de video correto.

Manda print do comando:

glxinfo | grep OpenGL

Se mostrar algo como “llvmpipe” terá que adicionar o parâmetro nomodeset no grub.

sudo nano /etc/default/grub

obs: pode usar gedit ao invés do nano

e adicione o nomodeset na linha GRUB_CMDLINE_LINUX_DEFAULT:
ficando como algo assim:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
GRUB_CMDLINE_LINUX=""

salve (Ctrl + X / confirma se usar o nano) e:

sudo update-grub

reinicie

image
Segue o print

Outra coisa que tentei foram os comandos

sudo xrandr --newmode “1600x900_60.00” 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync

sudo xrandr --addmode XWAYLAND1 1600x900_60.00

xrandr --output XWAYLAND1 --mode 1600x900_60.00

porém no ultimo comando da um erro
X Error of failed request: BadValue (integer parameter out of range for operation) Major opcode of failed request: 139 (RANDR) Minor opcode of failed request: 21 (RRSetCrtcConfig) Value in failed request: 0x0 Serial number of failed request: 29 Current serial number in output stream: 29

estranho, pela print era para poder selecionar normal a resolução, porque tenho o mesmo chip gráfico aqui e consigo selecionar normalmente…

Eu tbm não sei dizer se estou com o driver mais recente.
Ta bem ruim de trabalhar com esse resolução
Outra cosia que reparei, nos forum geralemte a galera da um xrandr e o dispositivo vem como VGA0-1 o meu vem como XWAYLAND0-1
Não sei se tem algo a ver com o problema

Consegui um pregresso
Não sei pq mas quando eu coloco um adapatdor de VGA para HDMi abre mais as opçãoes de resolução
coloquei a 1440 x 900 porém a imagem ta bem ruim, sem foco.

Essa dica fez trocar de cabo
E deu certo kkkkk

Da desfoco porque o seu monitor é 1600x900p o que da 16:9.
A que você pode usar ai para a imagem aparecer sem desfoco são as resolução que tem “xxxx*xxx(16:9)”.

1 curtida

explicado, uso hdmi…

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.